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About This Manual

Subject

Audience

This manual describes how to use the PowerBuilder Application Library, a
collection of reusable objects that you can use to accelerate the
development process. The manual includes installation instructions, a
tutorial, an object reference, and usage instructions for the sample
applications included with the Application Library.

This manual is for anyone who will be building applications with
PowerBuilder. It assumes that:

¢ You are familiar with the user interface guidelines for the computing
platform you will be developing and deploying your applications on. If
not, consult a book that covers the user-interface conventions.

¢ You are currently developing applications using PowerBuilder and
understand the concepts and techniques described in the PowerBuilder
Building Applications manual.

¢ You understand SQL and how to use your site-specific DBMS.

Xi






PART ONE

Getting Started

This part describes the Application Library and how to install it.






CHAPTER 1
Application Library Overview

About this chapter This chapter introduces the Application Library and its components. It also
describes application development, sample applications, and code
examples.

Contents Topic Page
Introduction to the Application Library 4
Creating an application 7
Getting started with the Application Library 8



Introduction to the Application Library

Introduction to the Application Library

Two sets of objects

The PowerBuilder Application Library is a collection of PowerBuilder
objects that speed the PowerBuilder application development process.

The Application Library contains two sets of objects:

¢ The application framework provides a set of ancestor objects for
developing a PowerBuilder multiple document interface (MDI)
application. You create the core of your application by inheriting from
application framework objects.

¢ The object library provides reusable objects that you incorporate into

your application.

Application framework = ancestor objects

The ancestor
objects

An application framework provides ancestor objects (base classes) from
which objects in your application can inherit. The SYS.PBL library
contains the Application Library's application framework objects.

The application framework's ancestor objects include windows, a menu, a
function, and user objects.

Ancestor object

Description

Comment

w_sys_frame

w_sys_single_dw

w_sys_multi_dw

w_sys_shared_dw

w_sys_mast_detl_dw

w_sys_pipeline
W_sys_report

m_sys_frame

Displays the application frame
window

Displays a single-row DataWindow

Displays a multi-row DataWindow

Displays two DataWindows in a
Master/Detail relationship (uses the
shared DataWindow technique)

Displays two DataWindows in a
many-to-many relationship

Contains data pipeline functionality
Displays reports

Provides the base menu for all
applications

Descendant of
w_sys_single_dw

Descendant of
w_sys_multi_dw
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Ancestor object

Description

Comment

uo_dw

u_ole

u_ole_excel

u_ole_word

u_pipeline_Kkit

f app_open

Provides a DataWindow control
used in application framework
windows

Provides an OLE 2.0 window
control and basic functions for using
OLE

Provides an OLE 2.0 window
control with functions for use with
Microsoft Excel

Provides an OLE 2.0 window
control with functions for use with
Microsoft Word for Windows

Provides functions for use with data
pipelines

Initializes global variables

Descendant of
u_ole

Descendant of
u_ole

When you create an object inherited from an application framework object,
you get all of its characteristics and behaviors in your object. The ancestor
object's characteristics and behaviors include encapsulated events, user
events, and functions, which you can use as-is, extend, override, trigger,
post, or call, depending on your application's needs.

& For more on application framework objects and functions, see Part
Three "Object Reference." For more on using an application framework,
see Building Applications in the PowerBuilder documentation set.

Object library = reusable objects

The Application Library's object library provides reusable objects that your
application can use. These objects, which perform error handling and other
utility functions, can enhance your application's reliability and
functionality. The UTLFUNC.PBL and UTLWIN.PBL libraries contain the
object library.

The application framework uses the object library
The application framework makes extensive use of object library
functions, windows, and structures.
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Six types of
reusable objects

Object type

Description

The object library includes windows, functions, a menu, user objects,
structures, and DataWindows.

Comment

Windows

DataWindows

Functions

Structures

Menu

User objects

Windows that you can use for a
particular purpose, such as
sorting or displaying error
information. You open some
windows using Application
Library function calls and others
using the Open function.

DataWindow objects that support
other object library windows and
functions.

Global functions that perform
specific processing.

Collections of related variables
that the Application Library uses
for communications purposes.

A general-purpose menu that
contains basic File and Window
menu items.

User objects with encapsulated
functionality.

Some windows are part of
the application framework,
which means that you use
them as ancestor objects.
All other windows you can
use as-is

These objects do not
perform any database
access. Not typically used
in your application.

Processing can include
return values, window
display, and manipulation
of nonvisual attributes.
UTLFUNC.PBL contains
standalone functions;
UTLWIN.PBL contains
global functions that
display a window.

Most of these are intended
for use with other objects;
others provide general
functionality.

Use this as an ancestor
object.

These objects allow you to
define a component once
and then reuse it as many
times as you need without
any additional work.
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Creating an application

« To create an application using the Application Library:
1  Create an application object.

2 Add the SYS.PBL, UTLFUNC.PBL, and UTLWIN.PBL libraries to
your application's library search path.

Failure to do this will cause errors.

3 Create an MDI frame window by inheriting from the w_sys_frame
window.

Remember
The application framework is designed to create MDI applications.

4 Create MDI sheet windows by inheriting from the appropriate
application framework sheet window:

¢ w_sys_mast_detl dw

¢ w_sys_multi_dw

¢ w_sys pipeline

¢ w_sys_report

¢ w_sys_shared_dw

¢ w_sys_single_dw

Create a frame menu by inheriting from the m_sys_frame menu.
Add or modify frame menu items to meet your application's needs.
Create sheet menus by inheriting from your frame menu.

Modify sheet menus to meet the sheet's needs.

O 0 N O W

Associate sheet menus with corresponding sheet windows.
10 Add application-specific logic to the application.

Object library objects can help you implement application-specific
logic.
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Getting started with the Application Library

The Application Library contains many objects. Take the time to learn as
much as possible about the Application Library before creating your first
production application. The Application Library provides these resources
to help you get started:

¢ This manual The Application Library manual includes overview,
tutorial, and reference information.

¢ Tutorial The tutorial provided in Part Two steps through the creation
of a small application and demonstrates the usage of application
framework and object library objects.

¢ Sample applications The Application Library includes two sample
applications made up of Application Library objects. By running these
applications and examining their windows and events, you can observe
the structure, look, and feel of applications created using the
Application Library.

¢ Code examples Also included in the Application Library is a
frontend application demonstrating the usage of Application Library
objects that are not used in the sample applications. These code
examples allow you to execute a series of windows that show working
examples of Application Library functions and objects.



CHAPTER 2
Installation

About this chapter This chapter describes how to install the Application Library and its

supporting files.

Contents Topic | Page
Installing the PowerBuilder Application Library l 10
Verifying the installation ) 11
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Installing the PowerBuilder Application Library

10

2
L

The PowerBuilder Application Library Setup program installs the
Application Library in the directory on the drive you specify or in the
default directory, c:\pbapp.

To install the Application Library:

1  Run the PowerBuilder Application Library Setup program:

¢ To run from the DOS prompt, type:

WIN A:\SETUP

¢ To run from the Windows Program Manager, select File> Run
from the menu bar and type:

A:SETUP

2 Respond to the Setup prompts and select the options you want.

The Setup program creates a default directory c:\pbapp for the
PowerBuilder Application Library files. The c:\pbapp directory contains
the main Application Library components and subdirectories for the
tutorial, sample applications, and code examples.

C:\PBAPP:
SYS.PBL
UTLFUNC.PBL
UTLWIN.PBL
[ I I ]
CAPBAPP\TUTORIAL C:\PBAPP\PUBS C:APBAPP\TIMEMGMT C:\PBAPP\EXAMPLE
APPTUT1.PBL AUTHOR.PBL TIMEMGMT.DB EXAMPLE.PBL
TUTORALHLP PUBLISH.PBL TIMEMGMT.INI WAITFOR BAT
- PUBS.DB TIMEMGMT.LOG WAITFOR.PIF
PUBS.INI TIMEMGMT.PBL
PUBS.LOG
PUBS.PBL
STORES.PBL
TITLES.PBL

& For installation information about sample applications and code
examples, see Chapters 10, 11, and 12.
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Verifying the installation

< Verify that the following files are in the following directories:

Directory

Files

C:\PBAPP

SYS.PBL
UTLFUNC.PBL
UTLWIN.PBL

EXAMPLE.PBL
WAITFOR.BAT

AUTHOR.PBL
PUBLISH.PBL
PUBS.DB
PUBS.INI
PUBS.LOG
PUBS.PBL
STORES.PBL
TITLES.PBL

TIMEMGMT.D
TIMEMGMT.INI
TIMEMGMT.LOG
TIMEMGMT.PBL

C:\PBAPP\TUTORIAL

APPTUT1.PBL
TUTOR_AL.HLP

WF_LOG.TXT

11






PART TWO

TUTORIAL

This part provides a series of eight lessons in which you build
a simple application using Application Library objects.






CHAPTER 3

Setting Up for the Tutorial

The Application Library tutorial is a series of eight lessons in which you
build a small MDI application using Application Library objects. The

finished application looks like this.

al Compensation Report

Total Compensation Report | ... orseath ins. = 34,500

Salary Plus Benefits

Value of life insurance = $(5.43 x saiary¥1,¢
Vaiue of day care = $5,200

Department Empi Employ
D D First Name

100 Fran
105 Matthew

Empl Salary Health Life
Last Name Ins. Ins.

Whitney $45,700 ® X
Cobb $62,000 ® K
Breault $57,490 % x

The sheet windows that you build in the Application Library tutorial
application are:

L

A basic Master/Detail window The top half of the window contains
a list of employees with a pointer to a single employee; the bottom half
of the window displays extra detail for the current employee. The
DataWindows are linked by the shared DataWindow feature, which
you get automatically by inheriting from the w_sys_shared_dw

window.

A report window The window contains an employee compensation
report in a single DataWindow. It is designed for online viewing and
includes zoom in, zoom out, and print preview, which you get
automatically by inheriting from the w_sys_report window.

15



What you will do

& For more on frame windows, sheet windows, and MDI applications,
see Building Applications in the PowerBuilder documentation set.

This application is similar to the PowerBuilder tutorial
The application you create in this tutorial is similar to the one you
created in the PowerBuilder Getting Started tutorial.

If you have already completed the PowerBuilder Getting Started tutorial,
compare that application with this one. You will notice many places
where the Application Library provides enhanced error checking, ease
of use, and flexibility.

If you are new to PowerBuilder and have not yet completed the Getting
Started tutorial, consider reviewing that tutorial before using this
tutorial.

16
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What you will do

Lesson 1

Lessons 2
through 4

Lessons 5
through 7

Lesson 8

You will begin by using the PowerBuilder Application painter to create the
Application object, update the library search path, create scripts, and
associate an icon with the application.

Then you will use the Window painter to create the frame window and the
sheet windows for the application by inheriting from Application Library
windows. You will also add scripts for the application, the frame window,
and the sheet windows.

Next you will create menus for the application.

Finally you will associate DataWindow objects with the DataWindow
controls in the sheet windows and test the application.

How long it will take

You can do the entire tutorial in one sitting in about four to five hours. Or
you can stop after any lesson and continue at another time.

What you will learn

You will learn basic Application Library techniques and concepts,
including how to:

¢ Use the Application painter to include Application Library libraries
in the search path

¢ Use the Application Library f_app_open function and application
INI file to perform application setup and database connection
automatically

¢ Use the Window painter to create frame and sheet windows that are
descendants of Application Library application framework windows

¢ Use the Menu painter to create frame and sheet menus that are
descendants of the Application Library application framework menu

¢ Use the functions and user events encapsulated in Application
Library application framework objects

17



What you will do

¢ Use Application Library functions and windows

&> For more on PowerBuilder application development, see Building
Applications in the PowerBuilder documentation set.

Assumptions
This tutorial assumes that you have:
¢ Installed the Watcom SQL DBMS

¢ Installed and configured the Powersoft Demo DB database

Use the PowerBuilder installation diskettes
If your system does not contain Watcom SQL or the Powersoft Demo
DB, use the PowerBuilder installation diskettes to install them.

18



LESSON 1

Creating the Application Object

The first step in building a PowerBuilder application is to create an
application object. You are always developing within the scope of an
application.

In this lesson you will create an application object for an Employee
Maintenance application. You will also add the Application Library
libraries to the search path, code SystemError and Close event scripts, and
specify an icon for the application.

How long will this lesson take?
About 15 minutes.

What will you learn about the Application Library?
¢ How to use the w_system_error window to trap system errors.

¢ How to use the f_db_error function to check for database errors in
embedded SQL statements.

¢ How to include the SYS.PBL, UTLFUNC.PBL, and UTLWIN.PBL
libraries in the application library search path. These libraries
contain all Application Library objects.
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Create and save the application object

Create and save the application object

20

Where you are

Lesson 1 Creating the Application Object
= Create and save the application object

Update the application library search path

Add a SystemError event script

Add a Close event script

Specify an icon for the application

Now you will start PowerBuilder, open the Application painter, create the
tutor_al application object, and select the library to hold that object and all
the other objects you create in the tutorial.

1  Start PowerBuilder.

The initial window displays.

PowerBuilder - exampl40




Lesson 1 Creating the Application Object

Click the Application painter button in the PowerBar.

Powelé"uﬂder - exan_u.)M[]

Application painter
The Application painter workspace displays.

Library name: c:\pbd\pbexamwn.pbl Size in bytes:

Comments: PowerBuider 4.0 examples Checked out by:

This tutorial uses buttons that show text

The sample windows in this tutorial display buttons that show text.
If your PowerBuilder buttons have no text displayed, you can either
use PowerTips (place the pointer over a button for a few seconds
and a brief description appears) or enable button text (right-click in
the PowerBar and select Show Text).
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Create and save the application object

22

3 Select File»New from the menu bar.

The Select New Application Library dialog box displays.

polib.pbl
ppdinZ pbl
ppiut. bl

pptutt phl
antend phl

'B Libraries (*.pbl)

4  Type tutor_al.pblin the File Name box.

5 Click OK.
The Save Application dialog box displays.

ation Librars
' \pb4\tutor_al pbl

6 Type tutor_alin the Applications box.
Press the TAB key twice to move to the Comments box.
Type This is the Application Library 4.0 tutorial application.

This associates a descriptive comment with the application object. The
comment you add here displays in the Library painter and helps to
identify objects. Comments are optional.



Lesson 1 Creating the Application Object

7  Click OK.
The Application dialog box displays.

Application

Would you like PowerBuilder to
generate an Application template?

8 Click No.

PowerBuilder creates a library named tutor_al.pbl and creates and
saves the application object named tutor_al in the library. The
Application painter workspace displays.

PowerBuilder - tutor_al

Application - tutor_al

. 3 s Last modified: 10/14/94 14:2250
Al Library name: c:\pb4\tutar_al.pbl Size in bytes: 1503

Comments: This is the Application Library 4.0 tutorial Checked out by:
application

At this point, the tutor_al application is your current application.
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Update the application library search path

Update the application library search path

Where you are
Lesson 1 Creating the Application Object
Create and save the application object

= Update the application library search path
Add a SystemError event script
Add a Close event script
Specify an icon for the application

Now you will add these PowerBuilder libraries to the library search path:

¢ SYSPBL

¢ UTLFUNC.PBL

¢ UTLWIN.PBL

¢ APPTUTI1.PBL

1 Make sure you are in the Application painter.

Click the Library List button in the PainterBar.

The Select Libraries dialog box displays.

Select Librari

Librasy Search Path:
; Ic: \pb4\tutor_al.pbl;

' | mailtest.pbl
| | pbexamdw.pbl

2

£ timemgmt
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Lesson 1 Creating the Application Object

Double-click SYS.PBL.
Double-click UTLFUNC.PBL.
Double-click UTLWIN.PBL.

PowerBuilder adds the libraries to the search path.

This is the recommended order

SYS.PBL, UTLFUNC.PBL, and UTLWIN.PBL are the libraries
that contain the Application Library objects. The library order used
here is the recommended search path when using the Application
Library.

Use the Directories listbox to access the PBAPP\TUTORIAL directory.

L=

| Paaph
¢ 2> tutorial

Double-click APPTUT1.PBL.

PowerBuilder adds APPTUT1.PBL to the search path. This library
contains the DataWindow objects used by the tutorial application.

Click OK.

The Application painter workspace displays.
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Add a SystemError event script

Add a SystemError event script

Where you are

Lesson 1 Creating the Application Object

Create and save the application object

Update the application library search path
= Add a SystemError event script

Add a Close event script

Specify an icon for the application

Now you will add a script that opens the w_system_error window to the
application's SystemError event. If a system error occurs, this window
opens, displays system error information, and allows the user to exit the
application, continue the application, or print the error message.

Click the Script button in the PainterBar.

The PowerScript painter displays.

2  Make sure the title reads: Script - systemerror for tutor_al.

Script - systemerror for tutor_al
| Paste UBrET—F

[ 2R osto-Glotat—

If the title is incorrect
If the event is not the SystemError event, pull down the Select
Event listbox and select SystemError.

3 Type the following script:

open(w_system_error)

Click the Return button.
or
Select File> Return from the menu bar.

PowerBuilder compiles your script and returns to the Application
painter workspace.
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Lesson 1 Creating the Application Object

Add a Close event script

= Add a Close event script

Where you are

Lesson 1 Creating the Application Object
Create and save the application object
Update the application library search path
Add a SystemError event script

Specify an icon for the application

Now you will add a script to the application Close event to disconnect from
the database. (The application framework automatically connects you to the
database but you must execute the disconnect.)

1

Click the Script button in the PainterBar.
The PowerScript painter displays.

Make sure the title reads: Script - close for tutor_al.

Script - close for tutor_al

Thetr———F i Paste-atona

[Select Event

If the title is incorrect
If the event is not the Close event, pull down the Select Event
listbox and select Close.

3 Type the following script:

DISCONNECT using SQLCA;
IF f_db_error(SQLCA, "Disconnect Error") &
<> 0 THEN
ROLLBACK using SQLCA;
END IF

Click the Return button.
or
Select File> Return from the menu bar.

PowerBuilder compiles your script and returns to the Application
painter workspace.
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Specify an icon for the application

Specify an icon for the application

28

Where you are
Lesson 1_Creating the Application Object
Create and save the application object
Update the application library search path
Add a SystemError event script
Add a Close event script

= Specify an icon for the application

Now you will associate your application with an icon. The icon you specify
displays in the Windows workspace when you minimize your application
while executing it.

PowerBuilder automatically includes this icon in the executable when you
create an EXE file.

1

2

Click the Icon button in the PainterBar.

The Select Icon dialog box lists all available icons.

Select emp.ico, which is one of the icons delivered with PowerBuilder.

The Employee icon displays in the dialog box.

Select lcon

orgchart.ico
~ {pb.ico

| rows.ico
_ | sysinfo.ico
tutorial.ico

Click OK.
The Application painter workspace displays.

Select File> Save from the menu bar.

This saves your application object.




Lesson 1 Creating the Application Object

5 Click the Return button on the PainterBar.

You return to the initial window.
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LESSON 2

Building the Frame Window

In an MDI application, you define a window whose type is MDI frame and
open other windows as sheets within the frame. The Application Library's
application framework is designed to create MDI applications: you use the
w_sys_frame window as the ancestor for the frame window and use all
other w_sys-prefixed windows as ancestors for sheet windows.

SYS.PBL = application framework

The SYS.PBL library contains all application framework ancestor
objects. UTLFUNC.PBL and UTLWIN.PBL provide additional reusable
objects, but they are not part of the application framework.

In this lesson you will create a frame window by inheriting from the
w_sys_frame window. You will also create an application INI file and a
script for the application Open event.

How long will this lesson take?
About 15 minutes.

What will you learn about the Application Library?

¢ How to create a descendant of the w_sys_frame window. Inheriting
from w_sys_frame provides many things, including a status line
clock (w_mdi_clock), a login window, and automatic database
connection.

¢ How to create an application INI file. This file provides database
information that the frame window uses to connect your application
to a database.

¢ How to use the {_app_open function. Using this function provides
your application with database independence (because you name the
database in the INI file) and control over whether multiple
application instances are allowed.
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Create and save a descendent window

Create and save a descendent window

32

Where you are

Lesson 2 Building the Frame Window
= Create and save a descendent window

Create an application INI file

Add an application script

Run the application

Now you will create a descendent frame window by inheriting from
w_sys_frame. Because this is a frame window, you add no window
controls.

1 Click the Window painter button in the PowerBar.

The Select Window dialog box displays.

Select Window

¢ % c:\pb4\tutor_al.pbl
_ {#3% c:\pbapp\sys.pbl
| £22 c:\pbapp\utifunc.pbl
| €2 c:\pbapp\utiwin. pbl
| £28 c:\pbapp\tutorial\apptut1.pbl




Lesson 2 Building the Frame Window

Click Inherit.
The Inherit From Window dialog box displays.

pbapp\utifunc.pbl
pbapp\utiwin_pbl
-\pbapp\tutorial\apptut1_pbl

Click the line that ends with sys.pbl in the Application Libraries box.
Select w_sys_frame.
Click OK.

The Window painter workspace displays. The title should read:
Window - (Untitled) inherited from w_sys_frame.

le Edit Controls Design Declare Options
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Create and save a descendent window

4  Select Design>Window Style from the menu bar.

The Window Style dialog box displays. The title bar text is
highlighted.

~ Window Style

5  Type Application Library Tutorial

This replaces Sample Application in the Title Bar box.

6 Select the Menu box.
Click the down arrow in the dropdown listbox.
Click m_sys_frame.

In Lesson 5 you will replace the m_sys_frame specification with a
menu customized for the tutor_al application.
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Lesson 2  Building the Frame Window

7

Click OK.

This closes the Window Style dialog box and returns to the Window
painter workspace.

Select File>Save As from the menu bar.

The Save Window dialog box displays.

c:\pb. bl
c:\pbapp\sys_pbl
c:\pbapp\utifunc.pbl
c:\pbapp\utiwin.pbl
c:\pbapp\tutorial\apptut1_pbl

Type w_tut_frame in the Name box.
Type a comment in the Comments box.
Then click OK.

PowerBuilder saves your new window as a descendant of
w_sys_frame.
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Create an application INI file

Create an application INI file

36

Where you are

Lesson 2 Building the Frame Window

Create and save a descendent window
= Create an application INI file

Add an application script

Run the application

Now you will create an application INI file. This file provides database
information that the f_login function (called in the w_sys_frame window's
post_open user event) uses to connect your application to a database. You
can also use it to store other default information, which your application
can retrieve using the PowerBuilder ProfileString function.

1 Open the PowerBuilder File Editor by pressing SHIFT+F6.

The File Open dialog box displays.




Lesson 2 Building the Frame Window

Click Cancel.
The File Editor displays.

[Database1]
i dbms=0DBC
|| database=Powersoft Demo DB
i userid=dba
| dbpass=sql
| logid=
il logpass=
| servername=
DbParm=ConnectString="'DSN=Powersoft Demo DB;UID=dba;PWD=sql’

The Database and DSN specifications must match the specification for
the Powersoft Demo database in the PB.INI file.

Select File>Save As from the menu bar.

The Save As dialog box displays.
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Create an application INI file

5 Navigate to the PB4 directory in the Directories box.
Type tutor_al.iniin the File Name box.
Click OK.

6 Select File> Close from the menu bar.

The File Editor closes.
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Lesson 2 Building the Frame Window

Add an application script

Where you are
Lesson 2 Building the Frame Window
Create and save a descendent window
Create an application INI file

= Add an application script
Run the application

Now you code the application Open event. In this event, you call the
f_app_open function, which initializes instance variables and opens the
frame window.

1 Click the Application painter button in the PowerBar.

The Application painter displays.

Application - tutor_al

Object name: tutor_al Last modified: 10/14/94 14:22.50
Libraty name: c:\pbé\tutor_al. pbi Size in bytes: 1503
Comments: This is the Application Library 4.0 tutorial Checked out by:

application

2  Click the Script button in the PainterBar.

The PowerScript painter displays.

3 Make sure the title reads: Script - open for tutor_al.
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Add an application script

40

l If the title is incorrect
l If the event is not the Open event, pull down the Select Event
l listbox and select Open.

Type the following script:
f app_open(" tutor_al.ini",w_tut_frame, FALSE)

This script specifies the INI file to be used by the application, the
frame window to be opened, and whether multiple instances of the
application can be run. The frame window uses this information to
control the application.

Click the Return button.
or
Select File> Return from the menu bar.

PowerBuilder compiles your script and returns to the Application
painter workspace.



Lesson 2 Building the Frame Window

Run the application

Where you are
Lesson 2 Building the Frame Window
Create and save a descendent window
Create an application INI file
Add an application script

= Run the application

Now you will verify that the database connection is working by running the
Application Library tutorial application.

1 Click the Run button in the PowerBar.
or
Select File> Run from the menu bar.

PowerBuilder prompts you to save changes.

2 Click Yes.

The frame window's Open event script calls the f_login function,
which displays the w_login dialog box.
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Run the application

42

3 Type sq/(or whatever password you specified in the tutor_al.ini file).

Click OK.

The application connects to the database and displays the Application
Library tutorial frame window.

If you cannot connect to the database

If your application has trouble connecting to the database, check
that the TUTOR_AL.INI file is defined properly. You may need to
look at the PB.INI file (in the PB4 directory) to obtain the proper
settings for Database and Dbparm. If you are using a database other
than Watcom, you may need to fill in other TUTOR_AL.INI
parameters, as shown in the PB.INI file.

Notice the information displayed in the status bar at the bottom. This
is the w_mdi_clock window, which w_sys_frame (the ancestor of
w_tut_frame) automatically displays over the frame window and
positions in the lower-right corner.

Exit the application by pressing ALT+F4.

The Application painter workspace displays.



LESSON 3

Building the First Sheet Window

You inherit from application framework sheet windows to create the core
of your application. Application framework sheet windows include
DataWindow controls as well as predefined window functions, events, and
user events. These window functions, events, and user events perform basic
housekeeping and database access tasks, allowing you to concentrate on
your application's processing needs.

In this lesson you will create a sheet window by inheriting from the
w_sys_shared_dw window. You will also add a script to the frame
window's post_open user event to open the sheet window.

How long will this lesson take?
About 15 minutes.

What will you learn about the Application Library?

¢ How to create a descendant of the w_sys_shared_dw window.
Inberiting from w_sys_shared_dw provides many things, including
shared DataWindow setup, a CloseQuery event that prompts users to
save changes when exiting the window, and user events that
perform database management functions (add, delete, save).

¢ How to add a Retrieve function to the ue_retrieve_data user event.
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Create a descendent window

Create a descendent window

Where you are

Lesson 3 Building the First Sheet Window
= Create a descendent window

Add a script to the sheet window and save it

Add a script to the frame window

Run the application

Now you will create a sheet window by inheriting from the
w_sys_shared_dw window. You will associate this window with a menu in
Lesson 6.

1 Click the Window painter button in the PowerBar.

The Select Window dialog box displays.

“Select Window

rame window for Application Library 4.0 tutorial.

P c;\pbapp\ulllum.pbl
| {£2% c:\pbapp\utiwin_pbl
| | £2% c:\pbapp\tutorial\apptut1.pbl
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Lesson 3 Building the First Sheet Window

Click Inherit.
The Inherit From Window dialog box displays.

@ " Inherit From Window

c:\pbapp\sys.pbl
c:\pbapp\utifunc.pbl
c:\pbapp\utiwin.pbl

- 1c:\pbapp\tutorial\apptut1.pbl

Click the line that ends with sys.pblin the Application Libraries box.
Select w_sys_shared_dw.
Click OK.

The Window painter workspace displays. The title should read:
Window - (Untitled) inherited from w_sys_shared_dw.

~ PowerBuilder-tutor_al _
Design Declare Options Window Help
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Create a descendent window

4 Select Design>Window Style from the menu bar.

The Window Style dialog box displays. The title bar text is
highlighted.

5 Type Employee Maintenance

This replaces Shared Datawindow Ancestor in the Title Bar box.
6 Click OK.

This closes the Window Style dialog box and returns to the Window
painter workspace.

46



Lesson 3 Building the First Sheet Window

Add a script to the sheet window and save it

Where you are
Lesson 3 Building the First Sheet Window
Create a descendent window

= Add a script to the sheet window and save it
Add a script to the frame window
Run the application

Now you will code a Retrieve function in the ue_retrieve_data user event.

The Application Library includes database error checking

The dw_sheet DataWindow control in the w_sys_shared_dw ancestor
includes database error checking (in the DBError event in the uo_dw
DataWindow user object) so that you don't have to check for Retrieve
errors in your script.

1 Click the Script button in the PainterBar.

The PowerScript painter displays.

2 Make sure the title reads: Script - ue_retrieve_data for (Untitled) Inherited
from w_sys_shared_dw.

If the title is incorrect
If you've accidentally selected one of the DataWindow controls,
select Edit>Select Object from the menu bar and select (Untitled).

If the event is not the ue_retrieve_data event, pull down the Select
Event listbox and select ue_retrieve_data.

3 Type the following script:

dw_sheet.Retrieve()

This will retrieve rows, as defined in the DataWindow object.
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Add a script to the sheet window and save it

4  Click the Return button.
or
Select File> Return from the menu bar.

PowerBuilder compiles your script and returns to the Window painter
workspace.

5 Select File>Save As from the menu bar.

The Save Window dialog box displays.

c:\p
c:\pbapp\sys.pbl
c:\pbapp\utifunc.pbl
c:\pbapp\utiwin.pbl

| c:\pbapp\tutorial\apptut1.pbl

6 Type w_tut sharedin the Name box.
Enter a comment in the Comment box.
Click OK.

PowerBuilder saves your new window as a descendant of
w_sys_shared_dw.
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Lesson 3 Building the First Sheet Window

Add a script to the frame window

Where you are

Lesson 3 Building the First Sheet Window

Create a descendent window

Add a script to the sheet window and save it
= Add a script to the frame window

Run the application

Now you code an OpenSheet function in the w_tut_frame post_open event.
This opens the w_tut_shared window when the application is opened.
Alternatively you could start with an empty frame window and let the user
open the sheet window explicitly using a menu item.

At execution time, the w_tut_frame window's Open event invokes the
post_open event using the PostEvent function. Delaying DataWindow
retrieval by posting to a user event speeds window display.

Retrieval arguments

If you develop applications whose DataWindow objects use retrieval
arguments, you can open the sheet window using the
OpenSheetWithParm function, access the arguments in the Message
object, and specify the arguments in the Retrieve function.

1 Click the Window painter button in the PowerBar.

The Select Window dialog box displays.

Select Window

{w_tut_shared

Frame window for Application Library 4.0 tutorial.

c:\pb4\tutor_al.pbl
132 c:\pbapp\sys.pbl
{ £33 c:\pbapp\utifunc.pbl
1 #£8 c:\pbapp\utiwin_pbl
i

c:\pbapp\tutorial\apptut1.pbl
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Add a script to the frame window

50

Double-click w_tut_frame.

The Window painter workspace displays.

Ider - tutor_al

dow - w_tut_frame inhe

Move the pointer to the window and right-click.

The popup menu for the window displays.

Script...

Color 4

Icon...

Pointer...

Pasition..

Style »

Title...

Type 4
Click Script.

The PowerScript painter displays.

Make sure the title reads: Script - post_open for w_tut_frame inherited from
w_sys_frame.

pt- post_open for w_tut_frame inherited from w_

frame

l[Select Event

I




Lesson 3 Building the First Sheet Window

If the title is incorrect
If the event is not the post_open event, pull down the Select Event
listbox and select post_open.

Type the following script:
OpenSheet (w_tut_shared, this, 0,Cascaded!)

Click the Return button.
or
Select File>Return from the menu bar.

PowerBuilder compiles your script and returns to the Window painter
workspace.

Select File>Save from the menu bar.

PowerBuilder saves the frame window.
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Run the application

Run the application

Where you are
Lesson 3 Building the First Sheet Window
Create a descendent window
Add a script to the sheet window and save it
Add a script to the frame window

=®» Run the application

Now you will verify that the sheet window opens properly by running the
Application Library tutorial application.

1 Click the Run button in the PowerBar.
or
Select File>Run from the menu bar.
(If PowerBuilder prompts you to save changes, click Yes.)

The frame window's Open event calls the £_login function, which
displays the w_login dialog box.
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Lesson 3 Building the First Sheet Window

2 Type sql (or whatever password you specified in the tutor_al.ini file).
Click OK.

The application connects to the database and displays the Application
Library Tutorial sheet window.

" pplication Library Tuterial
Window Help

Employee Informa

Topics

3  Exit the application by pressing ALT+F4.

The Window painter workspace displays.
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LESSON 4

Building the Second Sheet Window

In this lesson you will create a sheet window by inheriting from the
w_sys_report window.

How long will this lesson take?
About 15 minutes.

What will you learn about the Application Library?

¢ How to create a descendant of the w_sys_report window. Inheriting
from w_sys_report provides many things, including zoom in, zoom
out, print preview, and query mode.
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Create a descendent window

Create a descendent window

Where you are

Lesson 4 Building the Second Sheet Window
= Create a descendent window

Add a script to the sheet window and save it

Now you will create a sheet window by inheriting from the w_sys_report
window. You will associate this window with a menu in Lesson 7.

1 Click the Window painter button in the PowerBar.

The Select Window dialog box displays.

w_tut_frame
w_tut_shared

Frame window for Application Library 4.0 tutorial.

c:\pb4\tutor_al.pbl
c:\pbapp\sys.pbl
c:\pbapp\utifunc.pbl

£22 c:\pbapp\utiwin.pbl

22 c:\pbapp\tutorial\apptut1_pbl

56



Lesson 4 Building the Second Sheet Window

2 Click Inherit.
The Inherit From Window dialog box displays.

w_tut_shared

_|Frame window ll

c:\pbapp\sys.pbl
c:\pbapp\utifunc.pbl
c:\pbapp\utiwin_pbl
c:\pbapp\tutorial\apptut1.pbl

3 Click the line that ends with sys.pblin the Application Libraries box.
Select w_sys_report.
Click OK.

The Window painter workspace displays. The title should read:
Window - (Untitled) inherited from w_sys_report.

PowerBuilder - tutor
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Create a descendent window

4  Select Design>Window Style from the menu bar.

The Window Style dialog box displays. The title bar text is
highlighted.

[AppWorkSpace
|AppWorkSpace

5 Type Total Compensation Report
This replaces Report Ancestor in the Title Bar box.

6 Click OK.

This closes the Window Style dialog box and returns to the Window
painter workspace.
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Lesson 4 Building the Second Sheet Window

7  Make the window rectangle larger.
Make the DataWindow control larger.

To do this, move the pointer to the lower-right corner of the window
rectangle. When it turns into a double-headed arrow, drag the arrow
down and to the right to enlarge the rectangle. Make it almost as large
as the Window painter workspace. Click in the DataWindow control
and do the same thing.

Before:
DataWindow
control
—Lower-right corner
4 of the window
rectangle
~Window - (Untitied) inherited from w_sys_report |
Cowo [#f[wo](of [[su] [=]3]
Window and
DataWindow
control fill
workspace
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Add a script to the sheet window and save it

Add a script to the sheet window and save it

60

Where you are
Lesson 4 Building the Second Sheet Window
Create a descendent window

= Add a script to the sheet window and save it

Now you will code a Retrieve function in the Open event.

When you open this window, PowerBuilder invokes the Open event, which
performs the Retrieve function. When the Retrieve function completes,
PowerBuilder displays the window. To speed window display, you could
code a PostEvent("post_open") function in the Open event and place the
Retrieve function in the post_open event.

Retrieval arguments

If you develop applications whose DataWindow objects use retrieval
arguments, you can open the sheet window using the
OpenSheetWithParm function, access the arguments in the Message
object, and specify the arguments in the Retrieve function.

Click the Script button in the PainterBar.
The PowerScript painter displays.

2  Make sure the title reads: Script - Open for (Untitled) Inherited from

W_sys_report.

i
i
i

If the title is incorrect

If the DataWindow control was still selected, (the title ends in
::dw_sheet), select Edit>Select Object from the menu bar and
select (Untitled).

If the event is not the Open event, pull down the Select Event
listbox and select Open.

3  Type the following script:

dw_sheet.Retrieve()




Lesson 4 Building the Second Sheet Window

This will retrieve rows, as defined in the DataWindow object.

Click the Return button.
or
Select File> Return from the menu bar.

PowerBuilder compiles your script and returns to the Window painter
workspace.

Select File>Save As from the menu bar.

The Save Window dialog box displays.

_tut_frame
_tut_shared

| |c:\pbapp\utiwin.pbl
bapp\tutorial\apptut1.pbl

Type w_tut_report in the Name box.
Enter a comment in the Comment box.
Click OK.

PowerBuilder saves your new window as a descendant of
w_Sys_report.
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LESSON 5
Building a Menu for the Frame Window

In MDI applications developed using the Application Library, you create a
frame menu by inheriting from the m_sys_frame menu. You use
descendants of m_sys_frame with windows that are descendants of
application framework windows. That is, many m_sys_frame menu item
scripts trigger user events defined in application framework windows.

You first create a descendent frame menu and add, modify, enable, and
disable menu items, as appropriate for your application. You then use the
descendent frame menu as the ancestor for all sheet menus.

In this lesson you will create a menu for the frame window by inheriting
from the m_sys_frame menu. You will also add new menu items and add
scripts to enable online help access. By defining application-wide items in
the frame menu you avoid coding them separately in each sheet menu.

How long will this lesson take?
About 30 minutes.

What will you learn about the Application Library?

¢ How to create a descendant of the m_sys_frame menu. Inheriting
from m_sys_frame provides a menu structure with File, Application
Topics, Actions, Window, and Help menus, as well as associated
toolbar buttons.

¢ How to define additional menu items.

¢ How to call Windows Help files from predefined Help menu items.
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Create a descendent menu

Create a descendent menu
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Where you are

Lesson 5 Building a Menu for the Frame Window
= Create a descendent menu

Add menu items

Add more scripts

Save the menu

Add the menu to the frame window

Now you will inherit from m_sys_frame to create a frame menu.

1 Click the Menu painter button in the PowerBar.

The Select Menu dialog box displays.

Select Menu

c:\pbapp\utiwin.pbl

2% c:\pbapp\tutorial\apptut1.pbl




Lesson 5 Building a Menu for the Frame Window

Click Inherit.
The Inherit From Menu dialog box displays.

c:\pbd\tut bl
_{c:\pbapp\sys.pbl
pbapp\utifunc_pbl
c:\pbapp\utiwin.pbl
-\pbapp\tutorial\apptut1.pbl

Click the line that ends with sys.pblin the Application Libraries box.
Select m_sys_frame.
Click OK.

The Menu painter workspace displays. The title should read: Menu -
(Untitled) inherited from m_sys_frame.

PowerBuilder - tutor_al
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Add menu items

Add menu items

66

Where you are
Lesson 5 Building a Menu for the Frame Window
Create a descendent menu
= Add menu items
Add more scripts
Save the menu
Add the menu to the frame window

Now you will add menu items. The m_sys_frame menu provides an
Application Topics menu under which you place application-specific
processes and functions. In the Application Library tutorial you add two
items to the descendent menu.

Using descendent menus

In a descendent menu, you can change menu item text but not the
internal menu item name. You can add menu items to the end of a menu
by typing the menu item text.

& For more on menus and inheritance, see the PowerBuilder User's
Guide.

1 Click the Application Topics menu bar item.

An empty box displays for the first menu item below Application
Topics.

2 Click in the empty box below the Application Topics header.




Lesson 5 Building a Menu for the Frame Window

Type &Employee Information

PowerBuilder uses this text to create the menu item name
m_employeeinformation. This is the name you use in a script to refer
to this menu item (for example,
m_tut_frame.m_employeeinformation).

Itom Name.

‘ i _employeeinformation

Click the Script button in the PainterBar.
The PowerScript painter displays.

Make sure the title reads: Script - clicked for m_employeeinformation.

If the title is incorrect
If the event is not the Clicked event, pull down the Select Event
listbox and select Clicked.

Type the following script:

Opensheet (w_tut_shared,w_tut_frame,0,Cascaded!)

This script opens the w_tut_shared sheet window.

Click the Return button in the PainterBar.
or
Select File> Return from the menu bar.

PowerBuilder compiles your script and returns to the Menu painter
workspace.

Click in the empty box below Employee Information.
Type &Total Compensation Report

Click the Script button in the PainterBar.
The PowerScript painter displays.
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Add menu items

10 Make sure the title reads: Script - clicked for m_totalcompensationreport.

If the title is incorrect
If the event is not the Clicked event, pull down the Select Event
listbox and select Clicked.

11 Type the following script:

OpensSheet (w_tut_report,w_tut_ frame,0,Cascaded!)

This script opens the w_tut_report sheet window.

Click the Return button in the PainterBar.
or
Select File> Return from the menu bar.

PowerBuilder compiles your script and returns to the Menu painter
workspace.
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Lesson 5 Building a Menu for the Frame Window

Add more scripts

Where you are
Lesson 5 Building a Menu for the Frame Window
Create a descendent menu
Add menu items
= Add more scripts
Save the menu
Add the menu to the frame window

Now you will add scripts for m_sys_frame Help menu items. You use these
items in conjunction with Windows online Help files.

1 Click the Help menu bar item.
Click the Contents menu item.
Click the Script button in the PainterBar.

The PowerScript painter displays.

2 Make sure the title reads: Script - clicked for m_sys_frame::m_helpindex.

If the title is incorrect
If the event is not the Clicked event, pull down the Select Event
listbox and select Clicked.

3 Type the following script:

ShowHelp( "c:\pbapp\tutorialltutor_al.hlp", &
Index!)

This starts the Windows Help system and displays the contents
window for the online Help provided with the Application Library
tutorial application. This file has usage information as well as
information on the objects used in the application.

Tutor_al.hlp must be accessible

If you installed the Application Library tutorial files in a directory
other than \PBAPP\TUTORIAL, be sure to specify the appropriate
path. Alternatively, you could ensure that the tutor_al.hlp file is in
a directory named in the DOS PATH statement.

69



Add more scripts
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Click the Return button in the PainterBar.
or
Select File>Return from the menu bar..

PowerBuilder compiles your script and returns to the Menu painter
workspace.

Click the Search for Help On menu item.
Click the Script button in the PainterBar.

The PowerScript painter displays.

Make sure the title reads: Script - clicked for m_sys_frame::m_search.

If the title is incorrect
If the event is not the Clicked event, pull down the Select Event
listbox and select Clicked.

Type the following script:

ShowHelp("c:\pbapp\tutorial\tutor_al.hlp", &
Keyword!,"")

This starts the Windows Help system using the online Help provided
with the Application Library tutorial application and displays the
Search dialog box.

Click the Return button in the PainterBar.
or
Select File> Return from the menu bar.

PowerBuilder compiles your script and returns to the Menu painter
workspace.

Click the How to use Help menu item.
Click the Script button in the PainterBar.

The PowerScript painter displays.



Lesson 5 Building a Menu for the Frame Window

10 Make sure the title reads: Script - clicked for m_sys_frame::m_helponhelp.

If the title is incorrect
If the event is not the Clicked event, pull down the Select Event
listbox and select Clicked.

11 Type the following script:
ShowHelp("winhelp.hlp"”, Index!)

This starts the Windows Help system displaying the file that explains
how to use the Help system.

Click the Return button in the PainterBar.
or
Select File> Return from the menu bar.

PowerBuilder compiles your script and returns to the Menu painter
workspace.
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Save the menu

Save the menu

Where you are
Lesson 5 Building a Menu for the Frame Window
Create a descendent menu
Add menu items
Add more scripts
= Save the menu
Add the menu to the frame window

1  Select File» Save As from the menu bar.

The Save Menu dialog box displays.

Save Menu

pp\sys.pbl
‘, pbapp\utifunc.pbl
“{c:\pbapp\utiwin.pbl
c:\pbapp\tutorial\apptut1_pbl

2  Click the line that ends with tutor_al.pblin the Application Libraries box.

This makes sure that the menu is stored in your application's library.

3 Type m_tut_frame in the Menus box.
Add a comment in the Comments box.
Click OK.

PowerBuilder saves your new menu as a descendant of m_sys_frame.

4  Select File> Close from the menu bar.

PowerBuilder closes the Menu painter.
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Lesson 5 Building a Menu for the Frame Window

Add the menu to the frame window

Where you are
Lesson 5 Building a Menu for the Frame Window
Create a descendent menu
Add menu items
Add more scripts
Save the menu
= Add the menu to the frame window

Now you will use the Window painter to associate a menu with a window.

1 Make sure you are in the Window painter with the w_tut_frame window
displayed.
If you are not, open the Window painter and select the w_tut frame
window.

Use the list of most recently accessed objects

To display one of the four most recently accessed objects, click on
the File menu and select the object from the list displayed at the
bottom of the menu.

73



Add the menu to the frame window

2

3

4

5

74

Select Design> Window Style from the menu bar.

The Window Style dialog box displays.

Click the down arrow in the dropdown listbox.
Click m_tut_frame.
Click OK.

|

The Window painter workspace displays.

Select File>Close from the menu bar.

Click Yes to save changes.



LESSON 6
Building a Menu for the First Sheet Window

In MDI applications, sheet menus typically inherit from the related frame
menu and add, modify, enable, and disable items as needed. This provides
ease of maintenance, because application-wide changes made to the frame
menu are inherited automatically by the sheet menus.

In this lesson you will create a menu for the first sheet window by
inheriting from the m_tut_frame menu. You will also enable menu items
that apply to the first sheet window (such as print, close, insert row, and
delete row) and disable the menu item that opens the first sheet window
(since only one instance can be open at a time).

How long will this lesson take?
About 30 minutes.

What will you learn about the Application Library?

¢ How to create a descendant of the frame menu. Inheriting from the
frame menu (which in turn is a descendant of m_sys_frame)
provides m_sys_frame functionality as well as the application-
specific customization you added to the m_tut_frame menu. For
example, you automatically have access to toolbar buttons (defined
in m_sys_frame) and online Help (defined in m_tut_frame).

¢ How to modify menu items. Many of the predefined menu items are
hidden but you can make them visible as needed.

¢ How to enable descendent menu items and toolbar buttons.
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Create a descendent menu

Create a descendent menu

76

Where you are

Lesson 6 Building a Menu for the First Sheet Window
= Create a descendent menu

Modify menu items

Save the menu

Add the menu to the first sheet window

Run the application

Now you will create a sheet menu by inheriting from m_tut_frame, the

frame menu used by the Application Library tutorial.

1

Click the Menu painter button in the PowerBar.

The Select Menu dialog box displays.

- 1 Frame menu for the Application Library 4.0 tutorial.

| .m: c:\pb4\tutor_al.pbl
| #£22 c:\pbapp\sys_pbl
£53 c:\pbapp\utifunc_pbl
_ | %8 c:\pbapp\utiwin.pbl
£33 c:\pbapp\tutorial\apptut1.pbl




Lesson 6 Building a Menu for the First Sheet Window

2 Click Inherit.
The Inherit From Menu dialog box displays.

Inherit From Menu

Frame menu for the Application Library 4.0 tutorial.

4

c:\pbA\tutor_al.pbl

\pbapp\utifunc_pbl
c:\pbapp\utiwin_pbl
c:\pbapp\tutorial\apptut1_pbl

3 Select m_tut_frame.
Click OK.

The Menu painter workspace displays. The title should read Menu -
(Untitled) inherited from m_tut_frame.




Modify menu items

Modify menu items
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Where you are
Lesson 6 Building a Menu for the First Sheet Window
Create a descendent menu
= Modify menu items
Save the menu
Add the menu to the first sheet window
Run the application

Now you will enable menu items and toolbar buttons that are relevant to
the sheet window. Additionally, because this application has an arbitrary
rule that only one sheet instance can be displayed at a time, you will
disable display of the Employee Information menu item.

Most items are disabled and invisible

Because m_sys_frame must provide functionality for all windows in the
application framework, there are many m_sys_frame menu items whose
initial state is disabled and invisible. For example, there are many items
in the File menu but only Print Setup and Exit are enabled initially.

1 Click the File menu bar item.
Click the Save menu item.
Select the Enabled checkbox.
Select the Visible checkbox.




Lesson 6 Building a Menu for the First Sheet Window

2

3

10

Click Change.
The Toolbar Item dialog box displays.

Select the Visible checkbox to enable display of the Save button.

Click OK.

The Menu painter workspace displays.

Click the Print menu item (you will have to scroll down the list).
Select the Enabled checkbox.
Select the Visible checkbox.

Click Change.
The Toolbar Item dialog box displays.

Select the Visible checkbox to enable display of the Print button.
Click OK.

The Menu painter workspace displays.

Click the Close menu item.
Select the Enabled checkbox.
Select the Visible checkbox.

Click Change.
The Toolbar Item dialog box displays.

Select the Visible checkbox to enable display of the Close button.
Click OK.

The Menu painter workspace displays.
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Modify menu items

11 Click the Application Topics menu bar item.
Click the Employee Information menu item.
Deselect the Enabled checkbox.

Menu - (Untitled) inherited from m_tut_frame
7 i g

12 Click the Actions menu bar item.
Select the Enabled checkbox.

13 Click the Insert Row menu item (not the Insert Detail menu item).
Select the Enabled checkbox.
Select the Visible checkbox.

ed) inherited from m_tut_frame
s

Vibha Db
Insert Row

i
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14

15

16

17

18

Click Change.
The Toolbar Item dialog box displays.

Select the Visible checkbox to enable display of the Insert Row button.
Click OK.

The Menu painter workspace displays.

Click the Delete Row menu item.
Select the Enabled checkbox.
Select the Visible checkbox.

Click Change.
The Toolbar Item dialog box displays.

Select the Visible checkbox to enable display of the Delete Row button.

Click OK.

The Menu painter workspace displays.
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Save the menu

Save the menu

Where you are
Lesson 6 Building a Menu for the First Sheet Window
Create a descendent menu
Modify menu items
= Save the menu
Add the menu to the first sheet window
Run the application

1 Select File>Save As from the menu bar.

The Save Menu dialog box displays.

_tut_frame

-\pbapp\utifunc_pbl
app\utiwin_pbl
app\tutorial\apptutl.pbl

2 Type m_tut_sharedin the Menus box.
Add a comment in the Comments box.
Click OK.

PowerBuilder saves your new menu as a descendant of m_tut_frame.

3 Select File>Close from the menu bar.

PowerBuilder closes the Menu painter.
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Add the menu to the first sheet window

Where you are
Lesson 6 Building a Menu for the First Sheet Window
Create a descendent menu
Modify menu items
Save the menu
= Add the menu to the first sheet window
Run the application

Now you will use the Window painter to associate the menu you just
created with the first sheet window.

1 Make sure you are in the Window painter with the w_tut_shared window
displayed.

If you are not, open the Window painter and select the w_tut shared
window.
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Add the menu to the first sheet window

2

4

5

84

Select Design>Window Style from the menu bar.

The Window Style dialog box displays.

| [AppWorkSpace

Select the Menu box.

Click the down arrow in the dropdown listbox.
Click m_tut_shared.

Click OK.

m_tut_frame
m_tut_shared

The Window painter workspace displays.

Select File>Close from the menu bar.

Click Yes to save changes.



Lesson 6 Building a Menu for the First Sheet Window

Run the application

Where you are
Lesson 6 Building a Menu for the First Sheet Window
Create a descendent menu
Modify menu items
Save the menu
Add the menu to the first sheet window
= Run the application

Now you will verify that the menus display properly by running the
Application Library tutorial.

Click the Run button in the PowerBar.

or

Select File>Run from the menu bar.

If PowerBuilder prompts you to save changes, click Yes.

The frame window's Open event calls the f login function, which

displays the w_login dialog box.

Please Login j
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Run the application
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Type sql (or whatever password you specified in the tutor_al.ini file).
Click OK.

The application connects to the database and displays the Employee
Maintenance sheet window, including the associated menu bar and
toolbar.

Click on the various menus to make sure that they display correctly. The
Help menu items should work; all other menu items require DataWindow
objects, which you have not yet associated with the DataWindow
controls.

You will associate DataWindow objects with this window's
DataWindow controls in Lesson 8.

Exit the application by pressing ALT+F4.



LESSON 7

Building a Menu for the Second Sheet
Window

In this lesson you will create a menu for the second sheet window by
inheriting from the m_tut_frame menu. You will also enable menu items
that apply to the second sheet window (such as print zoom and print
preview) and disable the menu item that opens the second sheet window
(since only one instance can be open at a time).

How long will this lesson take?
About 10 minutes.

What will you learn about the Application Library?

¢ How to create a descendant of the frame menu. Inheriting from the
frame menu (which in turn is a descendant of m_sys_frame)
provides m_sys_frame functionality as well as the application-
specific customization you added to the m_tut_frame menu. For
example, you automatically have access to toolbar buttons (enabled
in m_sys_frame) and online Help (defined in m_tut_frame).

¢ How to enable descendent menu items and toolbar buttons.

87




Create a descendent menu

Create a descendent menu

Where you are

Lesson 7 Building a Menu for the Second Sheet Window
» Create a descendent menu

Modify menu items

Save the menu

Add the menu to the second sheet window

Run the application

Now you will create another sheet menu by inheriting from m_tut_frame,
the frame menu used by the Application Library tutorial.

1 Click the Menu painter button in the PowerBar.

The Select Menu dialog box displays.

E m_tut (la
{m_tut_shared

Comments: .

| Frame menu for the Application Library 4.0 tutorial.

Application Libraties:
<miz c:\pb4\tutor_al.pbl
128 c:\pbapp\sys.pbl
£ c:\pbapp\utifunc.pbl

#£% c:\pbapp\utiwin.pbl

F £33 c:\pbapp\tutorial\apptuti.pbl

i 4 ;
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2 Click Inherit.
The Inherit From Menu dialog box displays.

Inherit From Menu

_tut_shared

\pbapp\utifunc.pbl
-\pbapp\utiwin_pbl
:\pbapp\tutorial\apptut1_pbl

3 Select m_tut frame.
Click OK.

The Menu painter workspace displays. The title should read: Menu -
(Untitled) inherited from m_tut_frame.
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Modify menu items

Modify menu items

Where you are
Lesson 7 Building a Menu for the Second Sheet Window

= Modify menu i

Add the menu

Create a descendent menu

tems

Save the menu

to the second sheet window

Run the application

Now you will enable menu items and toolbar buttons that are relevant to

this sheet window.

Additionally, because this application has an arbitrary

rule that only one sheet instance can be displayed at a time, you will
disable display of the Total Compensation Report menu item.

1 Click the File menu bar item.
Click the Zoom Out menu item.
Select the Enabled checkbox.
Select the Visible checkbox.

Ctil+F12

- {Delete

' |Save

e ﬂ‘Save As...

{ShiftsF12

S
F12

2 Click Change.

The Toolbar Item dialog box displays.
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Lesson 7  Building a Menu for the Second Sheet Window

3

10

Select the Visible checkbox to enable display of the Zoom Out button.

Click OK.

The Menu painter workspace displays.

Click the Zoom In menu item.
Select the Enabled checkbox.
Select the Visible checkbox.

Click Change.
The Toolbar Item dialog box displays.

Select the Visible checkbox to enable display of the Zoom In button.
Click OK.

The Menu painter workspace displays.

Click the Print menu item (you will have to scroll down the list).
Select the Enabled checkbox.
Select the Visible checkbox.

Click Change to enable display of the Print button.
The Toolbar Item dialog box displays.

Select the Visible checkbox.
Click OK.

The Menu painter workspace displays.
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92

1

12

13

14

15

Click the Print Preview menu item.
Select the Enabled checkbox.
Select the Visible checkbox.

Click the Close menu item.
Select the Enabled checkbox.
Select the Visible checkbox.

Click Change.
The Toolbar Item dialog box displays.

Select the Visible checkbox to enable display of the Close button.
Click OK.

The Menu painter workspace displays.

Click the Application Topics menu bér item.
Click the Total Compensation Report menu item.
Deselect the Enabled checkbox.
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Save the menu

Where you are
Lesson 7 Building a Menu for the Second Sheet Window
Create a descendent menu
Modify menu items
= Save the menu
Add the menu to the second sheet window
Run the application

1 Select File>Save As from the menu bar.

The Save Menu dialog box displays.

m_tut_frame
m_tut_shared

pbapp\utifunc_pbl
pbapp\utiwin_pbl
pbapp\tutorial\apptut1_pbl

2 Type m_tut_reportin the Menus box.
Add a comment in the Comments box.
Click OK.

PowerBuilder saves your new menu as a descendant of m_tut_frame.

3  Select File>Close from the menu bar.

PowerBuilder closes the Menu painter.
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Add the menu to the second sheet window

Add the menu to the second sheet window

Where you are
Lesson 7 _Building a Menu for the Second Sheet Window
Create a descendent menu
Modify menu items
Save the menu
= Add the menu to the second sheet window
Run the application

Now you will use the Window painter to associate the menu you just
created with the second sheet window.

1 Make sure you are in the Window painter with the w_tut_report window
displayed.
If you are not, open the Window painter and select the w_tut_report
window.

Window - w_tut_report inherited from w_sys_report
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Lesson 7 Building a Menu for the Second Sheet Window

2 Select Design>Window Style from the menu bar.

The Window Style dialog box displays.

otal Compensation Repor{

/AppWorkSpace

|AppWorkSpace

3  Select the Menu box.
Click the down arrow in the dropdown listbox.
Click m_tut_report.
Click OK.

—[Total Comper -] -]
Help

File Edit

m_sys_frame
m_tut_frame

The Window painter workspace displays.
4  Select File>Close from the menu bar.

5 Click Yesto save changes.
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Run the application

Run the application

Where you are
Lesson 7 Building a Menu for the Second Sheet Window
Create a descendent menu
Modify menu items
Save the menu
Add the menu to the second sheet window
= Run the application

Now you will verify that the menu displays properly by running the
Application Library tutorial.

Click the Run button in the PowerBar.

or

Select File>Run from the menu bar.

If PowerBuilder prompts you to save changes, click Yes.

The frame window's Open event calls the f_login function, which
displays the w_login dialog box.

" Please Login
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Lesson 7 Building a Menu for the Second Sheet Window

Type sql (or whatever password you specified in the tutor_al.ini file).
Click OK.

The application connects to the database and displays the first sheet
window.
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Run the application

98

Select Application Topics > Total Compensation Report from the menu
bar.

The Total Compensation Report sheet should display.

Total Compensation Report

Click on the various menus to make sure that they display correctly. The
Help menu items should work; all other menu items require a
DataWindow object, which you have not yet associated with the
window's DataWindow control.

You will associate a DataWindow object with the sheet window's
DataWindow control in Lesson 8.

Exit the application by pressing ALT+F4.



LESSON 8

Associating DataWindow Objects with
DataWindow Controls

Application Library application framework windows include DataWindow
controls with encapsulated scripts that perform basic window management
and database functions. Before you can use the window to access data,
however, you must associate each DataWindow control with a
DataWindow object. After associating DataWindow objects with
DataWindow controls, you can create additional scripts to meet your
application's needs.

In this lesson you will associate predefined DataWindow objects with the
DataWindow controls in the w_tut_shared and w_tut_report windows. You
will also use Application library functions to perform basic activity logging
in the w_tut_shared window's on_insert, on_update, and on_delete user
events.

How long will this lesson take?
About 35 minutes.
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Select DataWindow objects for w_tut_shared

100

What will you learn about the Application Library?

¢ The dw_sheet DataWindow control in w_tut_shared is inherited
from the uo_dw user object.

¢ The uo_dw user object provides many encapsulated events and
functions, including RowFocusChanged, DBError,
ItemFocusChanged, and SQLPreview.

¢ The encapsulated DBError event script calls the f_error_box
function, which in many cases eliminates the need for database error
checking.

¢ The encapsulated SQLPreview event script calls the on_insert,
on_update, and on_delete user events, which allows you to perform
optional processing just prior to accessing the database.

¢ The f_write_log function appends a string to the end of a specified
file.




Lesson 8 Associating DataWindow Objects with DataWindow Controls

Select DataWindow objects for w_tut_shared

Where you are
Lesson 8 Associating DataWindow Objects with DataWindow
Controls
= Select DataWindow objects for w_tut_shared
Add scripts for the dw_sheet DataWindow control
Select DataWindow object for w_tut_report
Run the application

Now you will use the Window painter to associate the d_emplist and
d_employee DataWindow objects with the dw_sheet and dw_detail
DataWindow controls in the w_tut_shared window.

Multiple levels of inheritance
It may help to know the levels of inheritance in this situation:

uo_dw standard DataWindow user object
>w_sys_single_dw window
>w_sys_multi_dw window
>w_sys_shared_dw window
>w_tut_shared window

Each step in the inheritance chain further customizes the DataWindow
control's behavior. For example:

¢ Uo_dw includes support for the DBError event.
W_sys_single_dw adds support for the ItemFocusChanged event.

L4
¢ W_sys multi_dw adds support for the RowFocusChanged event.
¢ W_sys_shared_dw adds support for shared DataWindows.

*

And you will add support in w_tut_shared for the on_insert,
on_update, and on_delete user events.
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Select DataWindow objects for w_tut_shared

1 Make sure you are in the Window painter with the w_tut_shared window
displayed.
If you are not, open the Window painter and select the w_tut_shared
window.

Top DataWindow
control (dw_sheet)

Bottom DataWindow
control (dw_detail)

2 Double-click inside the top DataWindow control (dw_sheet).

The Select DataWindow dialog box displays.

pb4\tutor_al.pbl
| #38 c:\pbapp\sys_pbl
1 #2% c-\pbapp\utifunc.pbl
| #£23% c:\pbapp\utiwin.pbl

| £23 c:\pbapp\tutorial\apptut1.pbl
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Lesson 8 Associating DataWindow Objects with DataWindow Controls

3  Click the line that ends with apptut1.pblin the Application Libraries box.
Double-click d_emplist.

The DataWindow dialog box displays some of the attributes of the
dw_sheet DataWindow control.

4 Click OK.

The Window painter workspace displays.

Wi nd—c:::-\;-:tut_s hared inherited from w_sys_shared_dw
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Select DataWindow objects for w_tut_shared

104

5

6

Adjust the size of the DataWindow control if necessary.

If you do not see all the columns in the DataWindow control, make it
wider.

Double-click inside the bottom DataWindow control (dw_detail).

The Select DataWindow dialog box appears.

1% c:\pbapp\sys.pbl
| £28 c:\pbapp\utifunc.pbl
{222 c:\pbapp\utiwin.pbl
£3% c:\pbapp\tutorial\apptut1.pbl
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7  Click the line that ends with apptut1.pblin the Application Libraries box.
Double-click d_employee.

The DataWindow dialog box displays some of the attributes of the
dw_detail DataWindow control.

8 Click OK.
The Window painter displays.

herited from w_sys_shared_dw
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Select DataWindow objects for w_tut_shared

9  Adjust the size of the DataWindow control if necessary.

If you do not see all the columns in the DataWindow control, make it
bigger (you may need to make the window bigger too).
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Add scripts for the dw_sheet DataWindow
control

Where you are
Lesson 8 Associating DataWindow Objects with DataWindow
Controls
Select DataWindow objects for w_tut_shared
= Add scripts for the dw_sheet DataWindow control
Select DataWindow object for w_tut_report
Run the application

Now you will create a window function to log database updates and call it
from three different user events. The SQLPreview event script
encapsulated in the dw_sheet DataWindow control triggers different user
events, depending on the update type:

Update type | User event triggered by SQLPreview
Update existing row ‘ on_update

Update new row on_insert

Delete row on_delete

The Application Library tutorial application uses these user events to
invoke a window function that writes database request information to a log
file. First you will code the window function and then you will code the
user events.

107



Add scripts for the dw_sheet DataWindow control

1 Make sure you are in the Window painter with the w_tut_shared window
displayed.
If you are not, open the Window painter and select the w_tut_shared
window.

Window w_tut_shared inherited from w_sys_shared_dw

2  Select Declare>Window Functions from the menu bar.

The Select Function in Window dialog box displays.

Select Function in Window _
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3 Click New.
The New Function dialog box displays.

4  Type wf_log in the Name box.
Type Boolean in the Returns box.
Type database_action in the Name box.
Type string in the Type box.
Click OK.

The PowerScript painter displays.

= 0g fo d 1=
Paste Argument |34 Paste Global 3] Paste Instance | #4 Paste Object

| 5

* 0001:0001
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5

Select File>Import from the menu bar and select wf_log.txt from the
\PBAPP\TUTORIAL directory.

or

Type the following script:

// Write to log file.
// Uses f_write_log function.

dwbuffer dwb_buf

long 11 row

string 1s_log text

string 1s_divider = " === =
string 1s_log_file = "c:\pb4\tutor_ al.log"
integer 1li_emp id

dw_sheet.GetUpdateStatus(11l_row,dwb_buf)
1i_emp_id = dw_sheet.GetItemNumber(ll row, &
"emp_id",dwb_buf,FALSE)

1s_log_text = "Employee ID: " &
+ String(li_emp_id) + " " &
+ database_action + ", " &
+ String(Today()) + ", " &

+ String(Now())

IF NOT f write_log(ls_log file,ls divider) THEN
Return FALSE

END IF

IF NOT f write_log(ls_log_file,ls_log text) THEN
Return FALSE

END IF

Return TRUE

You may need to change the path for the Is_log_file variable.

Click the Return button.
or
Select File> Return from the menu bar.

PowerBuilder compiles your function and returns to the Window
painter workspace.

Move the pointer to an unused area in the top DataWindow control and
right-click.

This selects the DataWindow control and displays the popup menu.

Select Script from the popup menu.

The PowerScript painter displays.
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10

11

12

13

Click the down arrow next to the Select Event listbox and select
on_delete.

The title should read: Script - on_delete for w_sys_shared::dw_sheet.

B _ Script-on_ delete for w_sys_shared dw dw_ sheet
Select Event i —

If the title is incorrect
If the object is not dw_sheet, select Edit> Select Object from the
menu bar and select dw_sheet.

Type the following script:

IF NOT wf_log("Delete") THEN
f_error_box("Write Log", &
"Problem writing to log file.")
this.SetActionCode(1)

END IF

Click the down arrow next to the Select Event listbox and select
on_insert.

The title should read: Script - on_insert for w_sys_shared::dw_sheet.

Select Event

I

Sulpt on_insert for w_sys_ shared_dwi:dw_sheet

Type the following script:

IF NOT wf log("Insert") THEN
f _error_ box("Write Log", &
"Problem writing to log file.")
this.SetActionCode(1)
END IF

Click on the down arrow next to the Select Event listbox and select
on_update.

The title should read: Script - on_update for w_sys_shared::dw_sheet.
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Add scripts for the dw_sheet DataWindow control

14 Type the following script:

IF NOT wf_ log("Update") THEN
f_error box("Write Log", &
"Problem writing to log file.")
this.SetActionCode(1)
END IF

15 Click the Return button.
or
Select File> Return from the menu bar.

PowerBuilder compiles your scripts and returns to the Window painter
workspace.

16 Select File> Save from the menu bar.

PowerBuilder saves your changes.

112



Lesson 8 Associating DataWindow Objects with DataWindow Controls

Select DataWindow object for w_tut_report

Where you are
Lesson 8 Associating DataWindow Objects with DataWindow
Controls
Select DataWindow objects for w_tut_shared
Add scripts for the dw_sheet DataWindow control
= Select DataWindow object for w_tut_report
Run the application

Now you will select a DataWindow object to display in the w_tut_report
window.

1 Make sure you are in the Window painter with the w_tut_report window
displayed.
If you are not, open the Window painter and select the w_tut_report
window.
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Select DataWindow object for w._tut_report

2 Double-click inside the DataWindow control.

The Select DataWindow dialog box displays.

Select DataWindow

i c:\pb4\tutor_al.pbl
| £8% c:\pbapp\sys.pbl
| {29 c:\pbapp\utifunc.pbl
| | £29 c:\pbapp\utiwin.pbl
| | £2% c:\pbapp\tutorial\apptut1_pbl

3 Click the line that ends with apptut1.pbl in the Application Libraries box.
Double-click a_emp_total_compensation.

The DataWindow dialog box displays some of the attributes of the
dw_sheet DataWindow control.
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4 Click OK.

The Window painter workspace displays.

Total Compensation Report | ... o peam ins - 4,500

salary PIUS Beneﬁts Value of life insurance = $(5.43 x saiary¥1,000
\fatue of day care = §5,200

Department Empl Empl Empl Salary Health Life Day
D 1] First Name Last Name Ins. Ins. Car

- r
Grand total: 50 ™ érandtot

Overall average:

5  Adjust the size of the DataWindow control if necessary.

If you do not see all the columns in the DataWindow control, make the
control wider, enlarging the window, if possible.

Total compensation Repon Vaive of health ins. = 34,300

Salary P]us Beneﬁts Vaiue of lite insurance = $(5.43 x salany¥1,000
Vaiue of day care = $5,200

Department Empl Emple Empl Salary Health Life Day
1] )] First Name Last Name Ins. Ins. Care

- -
Grand total: so 17 éranatbtat:

Overall average:

Overall average:

6 Select File>Save from the menu bar.

PowerBuilder saves your changes.
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Run the application

Run the application

Where you are
Lesson 8 Associating DataWindow Objects with DataWindow
Controls
Select DataWindow objects for w_tut_shared
Add scripts for the dw_sheet DataWindow control
Select DataWindow object for w_tut_report
= Run the application

Now you will verify that the DataWindows work properly by running the
Application Library tutorial.

Click the Run button in the PowerBar

or

Select File>Run from the menu bar.

If PowerBuilder prompts you to save changes, click Yes.

The frame window's Open event calls the f_login function, which
displays the w_login dialog box.
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2

Type sql (or whatever password you specified in the tutor_al.ini file).
Click OK.

The application connects to the database and displays the Employee
Maintenance window, populating the DataWindow controls with rows
retrieved from the Powersoft Demo database.

Application ITE;;’;y_}utorial

Click rows in the top DataWindow control and verify that detail
information displays in the bottom DataWindow control.

Add an employee.

Delete an employee.

Modify employee information.

Select File>Save to update the database.

If you cannot save data
If error messages are displayed when trying to update the database,
the wf_log window function may have been defined incorrectly.
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Run the application

4 Select Application Topics > Total Compensation Report from the menu
bar.

The Total Compensation Report window displays.

Application Lib{ar\}?ulmial N

Total Compensation Report | ... oresith ins. = 34,600

Vatue of life insurance = $(5.43 x saia
salary PIUS Beneﬁts Vatue of day care = $5,200

Empl Empl Salary Health
First Name Last Name Ins.

Fran Whitney $45,700 x

Total Compensation Report

Total Compensation Report Value of heaith ins. = $4,800
Salary Plus Beneﬁts Value of life insurance = $(5.43 x salaryy1,000

Vaiue of day care = $5,200

Empl Emple Salary Health Life Day
First Name Last Name Ins. Ins. Care

Fran Whitney $45,700
Matthew Cobb $62,000
Robert Breault $57,490
Natasha Shishoy $72,995
Kurt Driscoll $48,024
Rodrigo Guevara $42,998

I O
I e
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6

7

Use the scrollbars to browse the report.

Exit the application by pressing ALT+F4.

If your application has problems
Your application should run without errors. If an error occurs, double-
check your scripts to make sure they were entered correctly.

If problems persist, use Debug to help solve them.

&~ For information on Debug, see the PowerBuilder User's Guide.

L

What to do next

This completes the Application Library tutorial. To continue learning
about the Application Library and PowerBuilder application
development, you can:

Review this tutorial to reinforce the basic application development
techniques.

Read the rest of this manual to understand the functions and
objects available to you.

Review the Time Management and Pubs sample applications to
see how to use the Application Library to create a robust MDI
application.

Read the Building Applications manual for additional design,
development, and deployment information.

Enhance the tutorial application by adding functionality provided
by other types of application framework windows.
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Object Reference

This part describes the objects in the Application Library.






CHAPTER 4

Window Objects

About this chapter

w_about

Description

Type
Library
Invocation

Controls used

Control events

This chapter describes the window objects in the Application Library. It
includes a description and sample of each window, as well as information
on each window's controls, events, and functions. Windows are listed in
alphabetical order.

Displays the application name and version number.

Response

bout Sampﬁe Applicatio

UTLWIN.PBL

Open (w_about )

Control | Control type

cb_ok CommandButton

Control | Event | Description

cb_ok Clicked , Closes the w_about window.
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w_db_error

Usage

Example

w_db_error

Description

Type
Library

Invocation

124

Open this window or a customized descendant from your application's
Help> About menu item.

This example opens window w_about in the Clicked event of the menu
item Help> About in the main menu.

Open (w_about)

Displays the current database error that is passed from the global function
f_db_error. It enables the user to print the error message if desired, and
then continue with the application session.

The f_db_error global function opens the window.

[ owbeseemr |

Please Login

Transaction Error Code : -1
Database Enor Code : 0

DEMS odbe

Database Powersoft Demo DB

User ID dba

DBPaim ConnectSting="DSN=Powersoft Demo
DB.UID=dba:PWD=sq!

Login ID

ServerName
AutoCornrit : False
Database Ermor Message

Response
UTLWIN.PBL

f_db_error ( transactionobject, errormessage )

Parameter | Description

transactionobject | Name of the programmer-specified transaction object
currently being used

errormessage String containing the user-defined error message
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Controls used Control Control type

cb_ok CommandButton

cb_print CommandButton

mle_message MultiLineEdit
Control events Control Event Description

cb_ok Clicked Closes the w_db_error window

cb_print Clicked Creates a print file using the database

Usage

Example

See also

error message information and prints the

file

You might use this window by coding the f_db_error function in a script
for a DataWindow control's DBError event.

This example calls global function f_db_error and passes the default

transaction object SQLCA and an application-specific error message. This
call opens window w_db_error and displays the application message along
with the specific database error message.

f_db_error (SQLCA, &
"Database error for Test Application")

f db_error

f debug_box

f_error_box
f get string

w_debug_box
w_error_box
w_get_string
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w_debug_box

w_debug_box

Description Displays an error message passed from global function f_debug_box. This
window object acts similarly to the window displayed using the
PowerBuilder MessageBox function; however, this window is non-modal
(it does not require immediate response and can be left open).

The f_debug_box global function opens this window.

ﬁ w_tut_frame

About to issue OpenSheet
w_tut_shared Sheet Open script Line 1

Type Popup
Library UTLWIN.PBL
Invocation f_debug_box ( windowtitle, errormessage )
Parameter Description
windowtitle String specifying w_debug_box window title. Usually
contains the title of the window in which the error occurred.
errormessage String containing the error message to be displayed.
Controls used Control Control type
cb_ok CommandButton
cb_print CommandButton
Control events Control Event | Description
cb_ok Clicked ‘ Closes the w_debug_box window
cb_print Clicked Prints the displayed message
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Usage Use this window from any event when building and debugging
applications.
Example This example opens window w_debug_box in the Clicked event of an OK

CommandButton and checks the input variables (SingleLine Edit text
values) before passing these variables as parameters.

f_debug_box("Username entered "+ sle username.text)

f_debug_box ("Password entered "+ sle password.text)

See also f db_error
f_debug_box
f_error_box
f get string
w_db_error
w_error_box
w_get_string

w_dw_print_options

Description Provides a Print Options dialog box for a DataWindow control, allowing
you to control which pages are printed and the print destination.

The f_dw_print global function opens this window and prints the
DataWindow.

Datawindow Print Options

All Pages in Range
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w_dw_print_options

Type Response
Library UTLWIN.PBL
Invocation f_dw_print ( dwcontrol, numberofcopies, filename )
Parameter Description
dwcontrol DataWindow variable of the DataWindow control whose
contents will be printed
numberofcopies | Integer specifying the number of copies to be printed
filename String containing the fully qualified name of the file to
contain the DataWindow contents
Controls used Control Control type
cb_cancel CommandButton
cb_file CommandButton
cb_ok CommandButton
cb_printer CommandButton
cbx_collate CheckBox
cbx_print_to_file CheckBox
ddlb_range DropDownListBox
em_copies EditMask
gb 1 GroupBox
rb_all RadioButton
rb_current_page RadioButton
rb_pages RadioButton
sle_page_range SingleLineEdit
sle_printer SingleLineEdit
sle_printer SingleLineEdit
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Control events

Window events

Window functions

Control Event Description

cb_cancel Clicked Closes the window, returning -1 in
Message.DoubleParm

cb_file Clicked Displays the Print to File dialog box,
allowing the user to specify a filename

cb_ok Clicked Closes the window, returning 7 in
Message.DoubleParm

cb_printer Clicked Displays the Windows Printer Setup
dialog box, allowing the user to change
the default printer

rb_all Clicked Specifies that all pages will be printed

rb_current_page Clicked Specifies that the current page will be
printed

tb_pages Clicked Specifies that the pages named in the

sle_page_range field will be printed

Event Description

Open Initializes fields and variables using the passed parameter

wf_disable_printfile Hides all items related to printing a file.
¢ Parameters: None.

¢ Returns: None.

wf_enable_printfile Shows all items related to printing a file.
¢ Parameters: None.

¢ Returns: None.

wf_page_range Sets fields and variables, depending on which
RadioButton is clicked.

¢ Parameters: RadioButton specifying which page range option is
clicked.

¢ Returns: None.
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w_dw_print_options

Instance variables

Usage

Example

See also

130

Variable | Data type Access
idw_dw DataWindow Public
is_page_range String Public

Use this window to allow users to control the printing of DataWindow
pages.
If you use this window apart from the £ dw_print function:

¢ Before opening the window, ensure that datawindow.print.copies is set
to zero and datawindow.print.file is set to "" (an empty string). Use the
Describe function to query these values and the Modify function to
update them.

¢ Remember that this window does not actually print the DataWindow;
to print the DataWindow, issue a Print function after the window
closes.

¢ After the window closes, check Message.DoubleParm before printing
the DataWindow. A I indicates that the user made print specifications
and clicked OK; -1 indicates that the user clicked Cancel.

This example uses the f_dw_print function to open the
w_dw_print_options window.

nn

string 1ls_filename =
integer 1li_num_copies = 0
integer 1li_return

1i_return = f£_dw_print (dw_sheet, &
1i_num_copies, ls_filename)
IF 1i_return = -1 THEN
MessageBox("Print Error", &
"User pressed Cancel or an error occured")
END IF

f dw_print
f print_file
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w_dw_ select

Description

Type
Library

Invocation

Provides a reusable selection list window for DataWindows. The window is
populated using a SQL statement you specify. The user then picks one of
the selected rows to be passed back to the calling window.

The f_select_data global function opens this window.

Response

UTLWIN.PBL

f_select_data ( sql, title, columns, dwcontrol, row, autoquery )

Parameter Description

sql String containing SQL statement used to build a
DataWindow.

title String specifying title for w_dw_select window.

columns String specifying column mapping. Composed of one or

more pairs of column names from the calling DataWindow
equated to a column number in the passed SQL statement.
This mapping defines which columns in the calling
DataWindow will be updated.

dw DataWindow variable identifying the DataWindow control
that is to be updated when the user selects a row in the
selection window.

row Long indicating the row of the calling DataWindow that is to
be updated when the user selects a row in the selection
window.
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w_dw_select

Parameter

Description

autoquery

Boolean indicating whether to automatically retrieve the
data in the selection window (TRUE) or allow the user to
enter retrieval criteria (FALSE).

Tip

The window's Open event processes these parameters within the
str_select_parms structure.

Controls used Control Control type
dw_created DataWindow
cb_ok CommandButton
cb_cancel CommandButton
cb_sort CommandButton
cb_query CommandButton
Control events Control Event Description
cb_ok Clicked Triggers the DoubleClicked event in
the dw_created DataWindow control.
cb_cancel Clicked Closes the window without
performing any updates to the calling
DataWindow.
cb_sort Clicked Opens the w_sort window to allow
the user to specify a sort order for the
dw_created DataWindow control.
cb_query Clicked Toggles the DataWindow in and out

132

of query_mode. If the window was in
query_mode, then a Retrieve for
dw_created is also performed. The
text of the button changes from
Query to Execute Query as the mode
changes.
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Window events

Instance variables

Usage

Example

Control Event Description
dw_created DoubleClicked Indicates that the user has selected a
row and that the data in the columns
requested are set on the calling
DataWindow. This event assumes
that the data types of the source and
target columns are the same. It also
closes the window.
dw_created RetrieveEnd Enables the cb_ok CommandButton
if rowcount > 0.
dw_created RowFocusChanged | Highlights the current row.
Event Description
Open Transfers the parameters passed on the message object to
local variables. It then creates the DataWindow from the
SQL statement, sizes the DataWindow and window to fit the
created DataWindow object, positions the CommandButtons
on the window, and issues a PostEvent to the post_open
event. This PostEvent is issued so that the window displays
before the actual retrieve, if there is one.
post_open Checks the autoquery parameter, and if it is TRUE it causes

(user event)

Variable

the DataWindow to be retrieved automatically.

Data type | Access

parm

str_select_parms l Public

Use this window to display a list of items from which the user can select
one item to be returned to the calling window. The user selects an item
either by double-clicking it, or by single-clicking and then clicking OK.

This example calls the f_select_data global function from a DataWindow
control (typically from the Clicked or DoubleClicked event). This call
opens window w_dw_select, displaying rows retrieved by the specified

SQL statement.

string col_name

long row

col_name
col_name

GetObjectAtPointer()
f _get_token(col_name,"~t")
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w_error_box

See also

w_error_box

Description

Type
Library

Invocation

134

IF col name = 'title_id' THEN
row = GetClickedRow()
f_select_data ("SELECT title id,title, price,&
ytd_sales, type FROM titles", &
"gelect Title", "title id=1,title=2,price=3, &
ytd _sales=4, type=5", this, row, false )
END IF

f get token

f select_data
str_select_parms
w_select

Displays an error message passed from global function f_error_box. This
window acts similarly to the PowerBuilder MessageBox function; however,
this window is non-modal (it does not require immediate response and can
be left open).

The f_error_box global function opens this window.

ﬂ Employee Maintenance

[Error while Inserting row 1
Data Base error Number is: -193
Data Base error Message is:

SQLSTATE = 23000

[WATCOM][ODBC Driver]WATCOM SQL]Integrity
contraint violation: primary key for table ‘employee’ i
not unique

No changes made to database.

Response
UTLWIN.PBL

f_error_box ( windowtitle, errormessage )
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Controls used

Control events

Usage

Example

See also

Parameter Description

windowtitle String containing w_error_box window title. Usually
contains the title of the window in which the error
occurred.

errormessage String containing the error message to be displayed.

Control | Control type

cb_ok ' CommandButton

cb_print CommandButton

Control | Event Description

cb_ok Clicked Closes the window

cb_print Clicked Prints the message displayed

You typically use this window by coding the f_error_box function in a
script for a DataWindow control's DBError event.

This example opens window w_error_box in the Clicked event of a Print
CommandButton if the PrintOpen function fails.

integer 1li x

li_ x = PrintOpen( )
IF 1i x = -1 THEN
f_error_box(parent.title, &
"Error in Clicked event of object cb_print")
END IF

f db_error
f_debug_box
f_error_box
f_get_string
w_db_error
w_debug_box
w_get_string
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w_exit_status

w_exit_status

Description Displays a message if the current window is closing and data has been
modified but not saved or if changed data is about to be lost after moving to
a different row or window.

The f_exit_status global function opens this window and prompts the user
to choose one of the following options:

¢ Save, Then Exit Save data before continuing
¢ Exit Without Saving Do not save data before continuing

¢ Cancel Exit Cancel the close or move and redisplay the window

Attempting to close Employee Maintenance.

Data has not been saved. Please select

Type Response
Library UTLWIN.PBL
Invocation f_exit_status ( windowtitle, saveormove )

Parameter Description

windowtitle String specifying w_exit_status window title. Usually contains
the title of the window to be closed.

saveormove String indicating whether data will be lost due to closing a
window or moving from a DataWindow row in which data has
been changed for the row:

¢ S - Unsaved changes will be lost because the window is
closing

& M — Unsaved changes will be lost because the user is
moving from a DataWindow row with unsaved changes

Controls used Control Control type
cb_save CommandButton
cb_cancel CommandButton
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Control events

Window events

Usage

Example

See also

Control Control type

cb_exit CommandButton

st_heading StaticText

Control Event | Description

cb_save Clicked ’ Returns an S and closes the w_exit_status window
cb_cancel Clicked Returns a C and closes the w_exit_status window
cb_exit Clicked Returns an E and closes the w_exit_status window
Event Description

Open Uses the windowtitle parameter to set the window.title of

window w_exit_status

In a window's CloseQuery event, check to see if any changed data has not
been saved to the database. If there is unsaved data, use the f_exit_status
function to open the w_exit_status window.

This example checks to see if there is any unsaved data in the window. If
TRUE, use {_exit_status to open w_exit_status and ask the user if
information should be saved.

string ls_status

IF dw_sheet.ModifiedCount + &
dw_sheet.DeletedCount <> 0 THEN
ls_status = f_exit_status(this.title)

END IF
CHOOSE CASE 1ls_status
CASE "s"
// Save data then exit.
CASE "E"
// Exit the application.
CASE "cC"
// Cancel the exit.
END CHOOSE

f exit_status
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w_file_display

w_file_display

Description Displays a file with the TXT extension and allows users to print the
displayed information.

The f_display_file global function opens this window.

e Displa v ]a
File Name : C:\pb040\read1st txt

READ1ST.TXT for UisionPlus 1968

When you install, bhe sure that no

3rd party SuperUGA drivers are running.
They will work with the product but
will cause the installation te fail.

If you like what you see in this
product, send $15.808 to:

Uision Products
1408 South 13th Street
Grand Forks, ND 58201

and we will send you printed documentation
las well as the next release.
when available.

Type Popup
Library UTLWIN.PBL
Invocation f_display_file ( filename)
Parameter Description
filename String containing the fully qualified name of the file to be
displayed in the w_file_display window.
This file must use the TXT extension.
Controls used Control Control type
cb_exit CommandButton
cb_print CommandButton
dw_displayfile DataWindow
st_filename StaticText
st_name StaticText
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Control events Control Event | Description

cb_exit Clicked ‘ Closes the w_file_display window

cb_print Clicked ’ Prints the displayed information
Window events Event Description

Open Imports filename into the dw_displayfile DataWindow

control

Resize Resizes the DataWindow based on the size of the window

Usage Use the f_display_file function and w_file_display window to display text

files from within your application.

Example This example displays file C:\PB\CUSTOMER.TXT.
string ls_filename

ls_filename = "c:\pb\customer.txt"
f_display_file(ls_filename)

See also f_display_file
f print_file

w_get_free_resources

Description Displays the free system resources at the time it opened. These resources
consist of: graphic display interface (GDI), user, and free memory (which
includes virtual memory).

Free Resources

=

Type Response
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w_get_fr ee_resources

Library
Invocation

Controls used

Control events

Window events

Usage

Example

See also
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UTLWIN.PBL

Open ( w_get_free_resources )

Control Control type

cb_ok CommandButton

Control Event | Description

cb_ok Clicked i Closes the w_get_free_resources window
Event | Description

Open ‘ Sets the static text with the current resource values.

Use this window to allow your application to display free system resources.
You could add a Help menu item that displays this window.

This window uses the GetFreeSystemResources and GetFreeSpace
Windows functions, which are declared as local external functions:

function uint GetFreeSystemResources(uint
SysResource) library 'user.dll’

function long GetFreeSpace(uint SysResource) library
'kernel.dll’

This example opens the w_get_free_resources window object.

Open (w_get_free_resources)

m_sys_frame
w_get_free_resources_graph
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w_get_free_resources_graph

Description

Type
Library
Invocation

Controls used

Window events

Control events

Usage

Displays the free system resources as a graph at the time it is opened.
These resources consist of: graphic display interface (GDI), user, and free
memory (which includes virtual memory).

Free Resour

Response

UTLWIN.PBL

Open (w_get_free_resources_graph )

Control Control type

gr 1 Graph

cb_ok CommandButton

Event Description

Open Sets the static text and graph control with the current resource
values.

Control | Event | Description

cb_ok Clicked l Closes the window

Use this window to allow your application to display a graph of free system
resources. You might consider adding a Help menu item that displays this
window.
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w_get_string

Example

See also

This window uses the GetFreeSystemResources and GetFreeSpace
Windows functions, which are declared as local external functions:

function uint GetFreeSystemResources(uint
SysResource) library 'user.dll’

function long GetFreeSpace(uint SysResource) library
'kernel.dll’

This example opens the w_get_free_resources_graph window object.

Open (w_get_free_resources_graph)

m_sys_frame
w_get_free_resources

w_get_string

Description

Type
Library

Invocation
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Displays a window that prompts the user to enter a string. The window is
passed parameters that determine the maximum size of the string the user
will input, the character case, and the current window title.

This window resizes automatically based on the maximum length of the
string the user will input.

The f_get_string global function opens this window.

" Pleasc Enter an Employee ID.

Response

UTLWIN.PBL

f_get_string ( windowtitle, maxlength, caseindicator, currentvalue )

Parameter | Description

windowtitle i String indicating the title to be used in w_get_string.
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Controls used

Control events

Window events

Instance variables

Usage

Examples

Parameter Description

maxlength Integer specifying the maximum number of characters that can
be entered.

caseindicator Single-character string indicating the case of the string to be
entered: U - Uppercase, L — Lowercase, A — Any case.

currentvalue Optional string containing the current value of what is to be
modified.

Control Control type

cb_ok CommandButton

cb_cancel CommandButton

Control Event | Description

cb_ok Clicked Returns the string entered by the user and

closes the w_get_string window
cb_cancel Clicked Returns a NULL string and closes the
w_get_string window

Event Description

Open Reads the input parameters and centers the window on its
parent

Variable Data Type | Access

ii_max_len Integer l Public

Use this window to prompt users for key variables or other additional

information.

This example prompts the user for a string that is up to 40 characters long
and uppercase only. The title of w_get_string will be equal to the title of
the calling window.

string
1s_string

ls_string

= f_get_string(parent.title,40,"U")
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w_hold_parms

See also

This example prompts the user for multiple strings different in length and
case type. The title of the new window opened is equal to the information
being requested.
string 1ls_custnum, ls_dept, 1ls_custname
1ls_custnume = f_get_string("Customer number",8,"U")
1ls_dept = f_get_string("Department", 4, "U")
1s_custname = f_get_string("Customer name", 40, "A")

f get_string
str_parms

w_hold_parms

Description

Type
Library
Invocation

Window functions
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Contains the functions that are used to manipulate values in a parameter
stack. You can use this window to replace the use of global variables.

This window, which is invisible by default, must be opened during the
Open event of the application.

Popup
UTLFUNC.PBL
Open ( w_hold_parms )

wf_add_item Adds or updates the string item in a DataWindow to the
string value. It does not return any parameters.

wf_get_item Finds the item name that corresponds to the passed
parameter value. It returns the string value of the item found. If nothing is
found, a NULL string is returned.

wf_pop_item Removes the first value in the stack array. It returns the
value to the calling routine.

wf_push_item Adds an item to the parameter stack. It also increments
the stack array by one.
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Instance variables

Usage

Example

See also

Variable Datatype | Access
is_stack] ] String Public
ii_num_in_stack Integer Public

The main purpose of this window (to pass parameters when opening and
closing windows) has been replaced with the functionality provided by
OpenWithParm and CloseWithReturn functions. Window object
w_hold_parms has been retained for backward compatibility and for the
capabilities that wf_add_item and wf_get_item provide.

This example shows the usage of wf_pop_item and wf _push_item
functions:

// In the event called to open window w_foo

// push the value needed to retrieve the data in
// window w_foo onto the stack.
w_hold_parms.wf_push_item(ret_arg)

Open(w_foo)

// In the open event of w_foo get the retrieve
// argument from the stack.

string ret_arg

ret_arg = w_hold_parms.wf_pop_item()
dw_l.retrieve(ret_arg)

This example shows how to set a globally accessible string named foo into
the list:

// Set a variable name foo into the list.
w_hold_parms.wf_add_item('foo',value)

// In some other event, access the value of foo.
string value
value = w_hold_parms.wf_get_item('foo')

f_pop_parm
f push_parm
f set_parm
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w_login

w_login
Description Displays a window that prompts the user for a user name and a password to
connect to the database of the current application.
The f_login global function opens this window.
Type Response
Library UTLWIN.PBL
Invocation f_login ( inifilename)
Parameter Description
inifilename The path and complete name of the INI file name associated
with the current application. The INI file contains specific
DBMS information used for connecting to the database.
Controls used Control Control type
st_1 StaticText
st 2 StaticText

sle_username SingleLineEdit
sle_password SingleLineEdit

cb_ok CommandButton

cb_cancel CommandButton
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Control events

Window events

Instance variables

Usage

Example

Control Event Description

cb_ok Clicked Ensures that the user entered a user name and
a password. Depending on the DBMS being
used, the event will set either the user id,
logid, dbpass, or logpass and attempt to
connect to the database. If the connection is
unsuccessful, the event will display the
specific DBMS error message and allow the
user three login attempts. It passes a boolean
parameter back to the calling function
indicating the success of the login.

cb_cancel Clicked Passes a boolean parameter back to the calling
function indicating an unsuccessful login, and
closes the window.

st_1 Clicked Sets focus to sle_username.

st 2 Clicked Sets focus to sle_password.

Event Description

Open Sets the default transaction object to corresponding information

in the application's INI file.

Variable Data type Access

ii_attempts Integer Public

ib_connected Boolean Public

You typically use this window in the initial window of an application to
prompt users to log in to the database. For example, the post_open user
event of the w_sys_frame application framework window uses the f_login

function to open this window.

The user name and password are not automatically converted to upper or
lowercase. You can change this by setting the case attribute on the

SingleLineEdits.

This example call the f_login function in the Open event of the frame
window. If the user is unable to log in, the application closes.
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w_mdi_clock

See also

IF NOT f£_login("c:\pubs\pubs.INI") THEN
halt close
END IF

f db_error
f login

w_mdi_clock

Description

Type
Library

Invocation

Controls used

Window events
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Displays date, time, memory information, and other user-specified text in
the lower-right corner of an MDI frame window. You must call a function
to reposition w_mdi_clock when the MDI frame is moved or resized.
Popup

UTLWIN.PBL

OpenWithParm ( w_mdi_clock bitmask )

Parameter Description

bitmask Bit mask that specifies which standard items to display:
¢ 1 Time and date

¢ 2 User memory

¢ 4 GDImemory

¢ 8 Free memory

Control Control type

st_time StaticText

Event Description

Open Determines display information and sets the timer process,

which runs at one-minute intervals.

Close Removes user object items from w_mdi_clock.
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Window functions

Event | Description

Timer ’ Refreshes window items.

wf_add_item Adds anitem to w_mdi_clock.
¢ Parameters:
¢ Integer specifying item width.

¢ Alignment enumerated variable specifying justification (center!,
left!, or right!).

¢ Single-character string used to size the four predefined items
(T=time and date, G=GDI memory, U=user memory, or M=free
memory). This is an empty string for user-defined items.

¢ Returns: Integer indicating the number of items displayed in
w_mdi_clock.

wf_calc_sizes Calculates the total width of tile w_mdi_clock window.
¢ Parameters: None

¢ Returns: None

wf_del_item Removes the specified item from w_mdi_clock.

¢ Parameters: Integer specifying the position of the item to be deleted.
+ Returns: Boolean. Returns TRUE if the item was deleted successfully

and FALSE if it was not.
wf_num_items Returns the number of items currently displayed in
w_mdi_clock.
¢ Parameters: None
¢ Returns: Integer specifying the number of items currently displayed in
w_mdi_clock.
wf_parent_resized Moves the window so that it is positioned properly
on the MicroHelp bar of the MDI frame.
¢ Parameters: None

¢ Returns: None
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w_mdi_clock

Instance variables

Usage

150

wf_predefined_action

the four predefined actions (T, G, U, and M).

Indicates whether the passed action is one of

¢ Parameters: Single-character string specifying the action.

¢ Returns: Boolean. Returns TRUE if the passed action is one of the four

predefined actions and FALSE if it is not.

wf_set_text Sets the contents of the specified w_mdi_clock position.

Parameters:

*

¢ Integer specifying the position to contain the new text

¢ String containing the text

¢ Retumns: Boolean. Returns TRUE if the text was set successfully and

FALSE if it was not.
Variable Default Data type Access
iw_parent_window | None Window Private
ii_menu_ht 0 (zero) Integer Private
ii_menu_ht2 74 Integer Private
ii_not_menu_ht 0 (zero) Integer Private
ii_resizeable_offset | None Integer Private
ii_border None Integer Private
ii_border_width None Integer Private
ii_border_height None Integer Private
item_cnt 0 (zero) Integer Private
u_mdi_clock_item[] | None UserObject Private
items_actions None String Private
ib_init_phase None Boolean Private

Use this window to display date, time, Windows memory information, and
application-specific information in your MDI application's status bar.
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Example

See also

You must add a custom user event to the MDI frame to reposition
w_mdi_clock when the frame is moved. To do this, declare a Move user
event, which uses the Windows message pbm_move. Call the
wf_parent_resized function in this event. You must also add a call to
wif_parent_resized in the MDI Frame window's Resize event.

You can open w_mdi_clock displaying four predefined items. From right
to left, they are: T (time). G (GDI memory), U (user memory), and M (free
memory). You can also use the wf_add_items and wf_set_text functions to
add your own items to the left side of the display.

Tip
To examine an implementation of w_mdi_clock, see the Open, Resize,
and Move events in the application framework window w_sys_frame.

This example opens window w_mdi_clock displaying the four default
items.

OpenWithParm(w_mdi_clock 1+2+4+8)

This example opens window w_mdi_clock displaying the time only.

OpenWithParm(w_mdi_clock 1)

Code this script in the Resize and Move events of the MDI frame.

IF IsValid(w_mdi_clock) THEN
w_mdi_clock.wf_parent_resized( )
END IF

Use this code to add an item to w_mdi_clock.
integer 1li_position

1i_position =
w_mdi_clock.wf_add_item(350,center!,"")
w_mdi_clock.wf_set_text(li_position,"New item text")

Use this code to remove the leftmost item from w_mdi_clock.
integer 1i_del_item
1li del item = w_mdi_clock.wf_num_items( )

w_mdi_clock.wf_del_item(li_del_item)

u_mdi_clock_item
w_sys_frame
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w_printzoom

w_printzoom

Description

Type
Library

Invocation

Controls used

Control events

152

Controls DataWindow print preview.

Response

UTLWIN.PBL

OpenWithParm ( w_printzoom, dwname )

Parameter Description

dwname DataWindow that is being previewed

Control Control type
_cbx_rulers | CheckBox

cb_cancel CommandButton

cb_ok CommandButton
_em_custom EditMask (spin control)

pb_cancel PictureButton

rb_custom RadioButtons

rb_30

rb_65

rb_100

rb_200

Control Event | Description

cb_cancel Clicked ‘ Closes the window
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Window events

Instance variables

Usage

Example

Control Event Description

cb_ok Clicked Sets the DataWindow to the state
specified by the current control
settings

em_custom Spun Sets rb_custom.clicked to TRUE

pb_cancel_previe
w

(pbm_enchange)
Clicked

Turns print preview off for the
DataWindow and close the
w_printzoom window

rb_30 Clicked Sets the zoom percentage to 30%

rb_65 Clicked Sets the zoom percentage to 65%

rb_100 Clicked Sets the zoom percentage to 100%

rb_200 Clicked Sets the zoom percentage to 200%

tb_custom Clicked Sets the zoom percentage to the spin

control (em_custom)

Event Description

Open Reads the current settings of the passed DataWindow and
sets the controls as required

Variable Data type | Access

idw_dw DataWindow l Public

The user can use this window:

¢ Toggle a DataWindow in and out of print preview mode

¢ Select the percentage of print zoom

¢ Display rulers when a DataWindow is in print preview mode

This example opens w_printzoom.

OpenWithParm (w_printzoom,dw_sheet)
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w_profile

w_profile

Description

Type
Library
Invocation

Controls used

Window events

Window functions

154

Allows you to capture performance statistics on application windows while
they are processing.

Popup
UTLWIN.PBL

Open ( w_profile )

Control Control type

cb_exit CommandButton

cb_saveas CommandButton

cb_print CommandButton

cb_close CommandButton

dw_1 DataWindow

Event Description

Resize Resizes the DataWindow to fit the window

wf_checkpoint Finds the difference between the current time and the
last wf_checkpoint (or wf_start). Also displays elapsed time and a message.

¢ Parameters: String containing message to be displayed with
checkpoint time.

¢  Return value: None
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wf_start Resets the DataWindow title with the parameter passed to it
and resets the instance variables il_start_time and il_last_time.

o Parameters: String containing text to be displayed on title of dw_1
DataWindow control.

¢  Return value: None

Instance variables Variable | Data type Access
il_start_time ‘ Long Private
il_last_time Long Private
Usage Use this window's wf_checkpoint function to write periodic messages to

w_profile, allowing you to determine the length of interim processing.

Example This example uses w_profile.
Open(w_profile)

// Set the title and reset the counters.
w_profile.wf_start("tracking calculation progress”

// Set checkpoints to determine length of

// phase 1 and phase 2.
w_profile.wf_checkpoint("Before calculation")
calc_project_phasel()
w_profile.wf_checkpoint("after Phase 1")
calc_project_phase2()
w_profile.wf_checkpoint("after Phase 2")

w_progress

Description Displays a percentage complete indicator. It is a shaded bar showing the
percentage of the process that is complete, a status area (text), and a
Cancel button.

Converting File
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w_progress

Type Popup

Library UTLWIN.PBL

Invocation OpenWithParm ( w_progress, progressparms )
Parameter Description

progressparms A structure of parameters used by w_progress. Use the
str_progress structure to contain these parameters:

¢ Window that is to be notified if the user clicks the Cancel
button or closes the Progress window

¢ Event to be triggered on the above window if canceled

¢ Title to be used on progress window

Controls used Control Control type
dw_progress DataWindow
cb_cancel CommandButton
Control events Control Event | Description
cb_cancel Clicked Triggers the passed event on the passed window

and then closes the w_progress window

Window events Event Description

Open Sets instance variables

Window functions wf_progress Causes the displayed percentage and bar size to reflect the
percentage passed as a parameter. You also use this function to display
additional status information. Pass these parameters to wf_progress:

¢  Parameters: Real containing a value in the range 0 to 1.0 to indicate
percent complete and an optional string that contains additional status
information, such as the sub-task being performed.

¢ Return value: None
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Window Objects

Instance variables

Usage

Example

See also

Variable | Datatype | Access
ii_bar_width Integer Public
is_cancel_event String Public
iw_cancel_window Window Public

After opening the w_progress window, your long-running process calls
wf_progress periodically, passing the percent complete. The user has the

option to cancel the process at any time.

This example opens the window w_progress:

str_progress parm

parm.title = 'Installing System'
parm.cancel_window = w_install_ window
parm.cancel event = "install_canceled"”
OpenWithParm (w_progress,parm)

This example calls wf_progress:

w_progress.wf_progress( current_ step/total_steps,&

"Copying foo.pbl")

str_progress
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w_select

w_select

Description

Type
Library

Invocation

Controls used

158

Use this window as an ancestor for producing selection windows based on

tables associated within an application (for example, searching for a
particular customer ID number, a particular customer name, and so on.).

_——

Select an Author

26 Records Found m Cance
Author ID Last Name First Name _
ong Eennett Ahraham

648921872 Blotchet-Halls Reginald
1238857766 Carson Cheryl
617708484  Coopernum Davidoff
722515454 DeFrance Michel
712451867  del Castillo Innes
427172319 Dull Ann
1213468915 Green Marjorie
527723246  Greene Morningstar
472272348 Gringlesby Burt

BfQZT1BB Hunter Sheryl

-

Response

UTLWIN.PBL

OpenWithParm ( w_select_descendant, retrieveindicator )

Parameter

| Description

w_select_descendant

Window that is a descendant of w_select.

retrieveindicator String value indicating whether the DataWindow
should retrieve the data when the window is opened
("TRUE") or open in query mode ("FALSE").

Control Control type

cb_cancel CommandButton

cb_filter CommandButton

cb_search CommandButton

cb_ok CommandButton

cb_sort CommandButton

dw_1 DataWindow

st_num StaticText
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Control events

Window events

Window functions

Instance variables

Control Event Description

cb_ok Clicked Not used in the ancestor window. This event
takes data from selected columns and passes it
back to the calling process, closing the window
at the same time. See the example below.

cb_sort Clicked Not used in the ancestor window. This event
expects the descendant to call one of the sort
routines. See the example below.

cb_filter Clicked Allows the user to enter information that will
filter the data that is displayed.

cb_search Clicked Causes the DataWindow to perform a Retrieve
using the query information that has been
entered.

cb_cancel Clicked Closes the window and returns without passing

any information back.

Event Description

Open Determines whether to do the retrieve automatically or wait
until the user enters search criteria

wf_check_row_count Takes the passed SQL statement and
determines the number of rows that will be returned if the SQL statement
is executed.

¢ Parameters. String containing SQL statement to be executed.

¢ Return value. Boolean. Returns TRUE if the count is over 500 and
FALSE if it is not.

wf_set_buttons Sets the state of the command buttons to enabled or

disabled as necessary. The scope of this function is private.

¢ Parameters. Boolean. TRUE enables buttons and FALSE disables
them.

¢ Return value. None

Variable | Datatype | Access

il_cur_row ' Long I Protected

159



w_select

Variable Data type Access
ib_data_ok Boolean Protected
istr_parm str_parms Protected
il_row_count Long Private
ii_num-selected | Integer Private
ii_columns Integer Private
ii_max_rows Integer Private
ib_query_mode | Boolean Private
Usage To use this window, you inherit (or copy an existing descendant) from this

window, place a new DataWindow that displays the necessary data, and
then code certain event scripts in the descendant.

Add a window title
The default title for this window is Select a. Customize the title based
on the window's function.

Example This example opens the w_select_desc window (descendent window) and
retrieves all of the data.

OpenWithParm(w_select desc,true)

This example is placed in the descendent window's cb_ok:clicked event
script.

// Need to pass two strings back to calling objects
// so place them in the structure and return.

if not ib_data_ok then return

istr_parm.string arg[l]= &
dw_l.GetItemString(il_cur_row, "au_id")

istr_parm.string arg[2]= &
dw_l.GetItemString(il_cur_row, "au_fname") &
+ " "+ o

dw_l.GetItemString(il_cur_ row, "au_ lname"

CloseWithReturn(parent,istr parm)

This is an example of what would be found in the Clicked event for the
¢b_sort control on a descendent window.

f_sort_order(dw_1, "Author ID:au id, &
Last Name:au_lname," &
+ "First Name:au_fname,Contract:contract")

160



Chapter 4 Window Objects

See also

w_set_sqlca

Description

Type
Library
Invocation

Controls used

f sort_order
str_parms

Used to enter database connection information if it is not provided in some

other way.

The f_set_sglca global function opens this window.

Set Value for Transaction Obiecl

Database: i_————_:]
Password: :’
] E—
DB Parameter :]
String:

Response
UTLWIN.PBL

f_set_sqlca ()

Control Control type
sle_database SingleLineEdit
sle_dbparm SingleLineEdit
sle_dbpass SingleLineEdit
sle_server SingleLineEdit
sle_userid SingleLineEdit
cb_close CommandButton
cb_ok CommandButton
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w_set _toolbars

Control events

Window events

Usage

Example

See also

Control Event Description

cb_ok Clicked Sets the transaction object values and attempts
to connect to the database. If the connection
succeeds, the window will close. If the
connection fails, a database error message will
display.

cb_cancel Clicked Closes the w_set_sqlca window.

Event Description

Open Displays existing transaction object information, if any

Use this window as an alternative method of establishing database
connection information. This window is best used in the development and
testing environment. Other methods (such as establishing an application
INI file) are preferred in the production environment, since they do not
require the user to enter database-specific information.

This example opens the window w_set_sqlca.

f _set_sqlca( )

f set_sqlca

w_set toolbars

Description

162

Allows the user to specify the position of the toolbar, whether the text for
the toolbar buttons is displayed or not, and whether the toolbar is visible or
not.
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Type
Library

Invocation

Controls used

Control events

Response

UTLWIN.PBL

OpenWithParm ( w_set_toolbars, framewindow )

Parameter Description

framewindow Window variable that contains the MDI frame window for the
toolbar

Control Control type

cb_done CommandButton

cb_visible CommandButton

cbx_showtext CheckBox

cbx_show_tips | CheckBox

rb_bottom RadioButton

rb_floating RadioButton

rb_left RadioButton

rb_right RadioButton

tb_top RadioButton

Control Event Description

cb_done Clicked Closes the window

cb_visible Clicked Toggles the toolbar from visible to invisible

cbx_showtext Clicked Toggles the display of toolbar text

cbx_show_tips | Clicked Toggles the display of PowerTips

rb_bottom Clicked Moves the toolbar to the bottom of the frame

rb_floating Clicked Changes the toolbar into a floating toolbar

rb_left Clicked Moves the toolbar to the left edge of the frame

rb_right Clicked Moves the toolbar to the right edge of the frame

rb_top Clicked Moves the toolbar to the top of the frame
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w_set_toolbars

Window events

Instance variables

Usage

Example

See also

164

Event Description

Open Sets instance variables and control status as required to reflect
the current state of the toolbar for the active sheet or frame

Variable Data type Access
iw_win_ref Window Public
iapp_ref Application Public

Most PowerBuilder applications display the w_set_toolbars window
through a Window> Toolbars menu item.

Tip
Use w_set_toolbars to provide a way for users to redisplay a hidden
toolbar.

This example opens the w_set_toolbars window.
w_sys_frame frame

frame = mf frame()
OpenWithParm(w_set_toolbars, frame)

Tip
The mf_frame function is an ancestor-level menu function that returns
the MDI frame name.

m_sys_frame
w_sys_frame
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w_sort

Description

Type
Library

Invocation

Controls used

Allows the user to specify the sort order of a DataWindow. This window
assumes that there will be a text object that corresponds to each visible
column on the DataWindow and that the name of the text object is the
same as the column name but with the _t suffix. If there is no matching
text object, then the name of the column is displayed rather than the
associated text.

DataWindow should not use grouping
Unpredictable results can occur if the DataWindow to be sorted contains
grouping.

Sort - E;ﬁployee List [by Department]

Response
UTLWIN.PBL

OpenWithParm ( w_sort, sortparms )

Parameter Description

sortparms A structure of parameters used by w_sort. Use the str_sort
structure to contain these parameters:

¢ The DataWindow to be sorted
¢ The title to be placed on w_sort

Control Control type
cb_cancel CommandButton
cb_ok CommandButton
dw_sort DataWindow
rb_bottom RadioButton
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w_sort_order

Window events

Control events

Instance variables

Usage

Example

See also

Event Description
Open Sets instance variables and determines the columns on the
DataWindow to be sorted. If the DataWindow is already
sorted, it displays the current sort.
Control Event Description
cb_ok Clicked Sorts the passed DataWindow and closes the
window
cb_cancel Clicked Closes the window without doing any
sorting
Variable Data type Access
idw_dw DataWindow Public
is_title String Public

Use the w_sort window as a way of allowing users to control DataWindow
sort order.

This example opens the w_sort window.

str_sort parm

parm.dw = dw_sheet // DataWindow to be sorted
parm.title = title // Title for the w_sort window
OpenWithParm(w_sort,parm)

f sort_order
str_sort
w_sort_order

w_sort order

Description

166

Allows user control of DataWindow sort order. If the DataWindow is
already sorted, the current sort order is displayed.
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Type
Library

Invocation

Controls used

DataWindow should not use grouping
Unpredictable results can occur if the DataWindow to be sorted contains
grouping.

The w_sort_order window allows the user to specify up to four levels of
sorting for a DataWindow and it can display up to ten columns on which to
sort.

The f_sort_order global function opens this window.

Response

UTLWIN.PBL

f_sort_order ( dwname, sortcolumns)

Parameter Description

dwname DataWindow control to be manipulated by w_sort_order.

sortcolumns String containing the possible sort columns that the user can
choose. The string list should be in the format of
Heading:column_name,Heading:column_name,
Heading:column_name, for up to ten columns.

Control Control type
cb_cancel CommandButton
cb_ok CommandButton
dw_sort DataWindow
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Control events

Window events

Usage

Example

See also

Control Event Description

cb_ok Clicked Finds the columns selected by the user in which to
sort the parent window and returns the column list

cb_cancel Clicked Returns a NULL string and closes window
w_sort_order

Event Description

Open Gets the sort order list from the message object and parses
through the list in order to paste the column names on the
DataWindow

Use the w_sort_order window as a way of allowing users to control
DataWindow sort order.

This example opens window w_sort_order allowing the user to choose
columns in dw_1 (emp_name, dept_name, and emp_num) to sort in either
ascending or descending order. The user can choose multiple sort columns.

f_sort_order(dw_1, "Employee Name:emp_name," &
+ "Department:dept_name,Employee Number:emp_ num")

f sort_order
w_sort

w_sys_frame

Description
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Application framework window object that is the ancestor MDI frame
window used for all MDI applications.

Use as an ancestor window

This window is designed to be used as the ancestor frame window for all
MDI applications built using the Application Library application
framework.
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Type
Library

Invocation

Window events

You can inherit from w_sys_frame for MDI frame windows or copy it. If
inheritance is used, any changes made to w_sys_frame will affect all
application frame windows inherited from it. Typically, changes are not
necessary for w_sys_frame.

Application llhmr\?Tui‘ur
Ip

MDI frame with MicroHelp
SYS.PBL

Open ( w_sys_frame_descendant )

Parameter Description

w_sys_frame_descendant | MDI frame window that is a descendant of
w_sys_frame

Event Description

Move Indicates to the w_mdi_clock window that the parent

(user event) window has been moved

Open Registers the window as a global variable and opens
the window w_mdi_clock

post_open Calls the f_app_open function, which initializes

(user event) instance variables and calls the f_login function
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Window functions

Control events

Instance variables

Usage

170

Event | Description

Resize Indicates to the w_mdi_clock window that the parent
window has been resized

wf_allow_multiple Tells you whether the application allows multiple
window instances, as specified in the £ app_open function.

¢ Parameters. None.

¢ Return value. Boolean. Returns TRUE if multiple instances are
allowed and FALSE if they are not.

wf_application Returns the application object.

¢ Parameters. None.

¢ Return value. Application. Returns the application, as specified in the
f app_open function.

wf_ini_file_name Returns the name of the application INI file.

¢ Parameters. None.

¢ Return value. String. Returns the INI file name, as specified in the
f app_open function.

This window has no controls. But it does display the w_mdi_clock window
at the bottom of the window.

&~ For more this window, see the w_mdi_clock discussion on page 148

Variable Data type Access
ib_mult Boolean Private
is_ini_file String Private
ia_app Application Private
iw_frame w_sys_frame Public

Use the w_sys_frame window as the ancestor object for your MDI
application's frame window. Use a descendant of the m_sys_frame menu as
the menu for w_sys_frame.
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Use with the m_sys_frame menu

Associate your descendent frame window with a descendant of the
m_sys_frame menu and inherit from your frame menu to create menus
for sheets opened in this frame. Keeping the m_sys_frame menu in your
menu inheritance chain provides integration with user events, window
functions, and user object functions defined in the application
framework sheet windows.

Example For an example of using this window as an ancestor object, see Lesson 2 of
the tutorial application.

See also m_sys_frame
w_mdi_clock
w_sys_mast_detl_dw
w_sys_multi_dw
W_Sys_report
w_sys_shared_dw
w_sys_single_dw

w_sys_mast_detl_dw

Description Application framework window object that provides the functionality
needed for a many-to-many Master/Detail maintenance window. For a
many-to-one Master/Detail window use the w_sys_shared_dw window.

ﬁ..,,,,,..,l.J"mI;a _______

Type Main (but designed to be opened as a sheet in an MDI frame)
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Library

Invocation

Controls used

Control events for
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SYS.PBL

Open ( w_sys_mast_detl_dw_descendant)

Parameter

| Description

w_sys_mast_detl_dw_descendant

Control

Window that is a descendant of

w_sys_mast_detl_dw

Control type

dw_master

dw_detail

Control

uo_dw standard user object (DataWindow control)

uo_dw standard user object (DataWindow control)

Event

Description

dw_master

dw_master

dw_master

dw_master

dw_detail

dw_detail

dw_detail

GetFocus

ItemFocusChanged

RetrieveEnd

RowFocusChanged

GetFocus

ItemFocusChanged

RetrieveEnd

Triggers the ItemFocusChanged event
and makes sure the MicroHelp is
updated.

Sets the MicroHelp to the tag values
assigned in the DataWindow.

Triggers the RowFocusChanged event to
properly populate the detail
DataWindow.

If there are no pending updates, this
event changes rows. If updates have not
been committed, it prompts the user to
commit before moving the row indicator.
You must add script to this event in your
descendent window to retrieve on the
detail DataWindow based upon the now
current master row.

Triggers the ItemFocusChanged event
and makes sure the MicroHelp is
updated.

Sets the MicroHelp to the tag values
assigned in the DataWindow.

Triggers the RowFocusChanged event to
properly show the current row in the
detail DataWindow.
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Window events

Control

| Description

dw_detail

Event

‘ RowFocusChanged \ Highlights the current row.

Description

Close

CloseQuery

Open

Resize

ue_filenew
(user event)

ue_fileopen
(user event)

If duplicate instances of the same information cannot
be opened, this event removes the sheet from the list
of open windows for this type of sheet.

Checks the DataWindows to see if any rows have been
modified and not saved. If so, it calls the f_exit_status
function, which opens the w_exit_status window
allowing the user to save the modifications and exit
the window, exit without saving, or cancel the request.

Sets the transaction object for the dw_master and
dw_detail DataWindow controls. It also registers the
MDI frame assigned to the sheet. This registration
assigns the MDI frame to an instance variable,
allowing you to reference it in scripts without
hardcoding the actual window name.

Resizes the DataWindow controls dw_master (width
only) and dw_detail (width and height).

Checks to see if the current information displayed was
modified and prompts the user to save the
information. Then it resets the dw_detail control and
inserts a new row into the dw_master control. This
event is triggered from the File>New menu item or
the corresponding toolbar button.

Used to open a search window and display
information based on entered criteria. This event is
triggered from the File> Open menu item or from the
associated toolbar button. The user is prompted to
save any changes that have been made before the new
search criteria are selected.

This user event triggers the ue_select_window user
event, which you can use to perform processing that
selects new information (usually by opening a
descendant of the w_select window). This information
is then stored in instance variables referenced in the
ue_retrieve_data event, which performs the actual
retrieve. You must code the ue_select_window and
ue_retrieve_data events in the descendent window.
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Event

Description

ue_filedelete
(user event)

ue_filesave
(user event)

ue_filesaveas
(user event)

ue_fileprint
(user event)

ue_validate
(user event)

ue_validatedelete
(user event)

ue_select_window
(user event)

Prompts for confirmation on the delete. If yes, it
triggers the ue_validatedelete user event. If the row
can be deleted, it first deletes detail rows and then
deletes master rows. This event does an automatic
update to the database and is triggered from the
File>Delete menu item or the corresponding toolbar
button.

Makes sure that the information entered in the
DataWindow controls has been accepted and then
saves it. This event is triggered from the File>Save
menu item or from the corresponding toolbar button.

Calls the PowerBuilder SaveAs function, which

allows the information displayed in the DataWindows
to be saved as a file of a user-specified type. This
event is triggered from the File> SaveAs menu item or
the corresponding toolbar button.

Calls the PowerBuilder Print function, which prints
both DataWindows. This event can be overridden in
the descendant to call other print functions. This event
is triggered from the File>Print menu item or the
corresponding toolbar button.

Not used in the ancestor window. Descendent
windows can trigger this event to perform cross-
reference checking between multiple columns before
the information is saved.

Called from the ue_filedelete user event. The event
initializes the boolean variable ib_data_ok = TRUE.
The descendent event scripts should include
referential integrity checking as needed. If the delete
should not be performed for referential integrity
reasons, the descendent script should set ib_data_ok
to FALSE.

Not used in the ancestor window. Call this event from
the ue_fileopen and ue_open_as_dependent events in
the descendent window. Use it to set instance
variables that you then use in the ue_retrieve_data
event to retrieve data into the DataWindow controls.
For examples, see the Pubs sample application.
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Window functions

Event

Description

ue_open_as_dependent
(user event)

ue_fileprint_preview
(user event)

ue_retrieve_data
(user event)

ue_detail_delete
(user event)

ue_detail_new
(user event)

ue_sort_master
(user event)

ue_sort_detail
(user event)

Similar to the ue_fileopen event in that is also triggers
the ue_select_window and ue_retrieve_data events.
You use the ue_select_window to populate the
instance variable(s) used in the ue_retrieve_data event
without prompting the user for the information.

Trigger this event in the window Open event script
when being opened from another window if multiple
instances are not allowed.

Opens the w_printzoom window, which allows the
user to specify the degree of zoom and other options
for viewing the DataWindow before printing it. Both
DataWindows are affected by the degree of zoom.

Not used in the ancestor window. Use this event to
retrieve data by coding a dw_sheet.Retrieve function
in the descendent window.

Prompts for confirmation on the delete of a detail row.
If yes, it triggers the user defined event
ue_validatedelete_detail. If the row can be deleted,
the delete is performed. This event is triggered from
the Action> Delete Detail menu item or from the
corresponding toolbar button.

Inserts a new row into the detail DataWindow. Make
sure that code is placed in the descendant to populate
any related columns from the master DataWindow.
For an example, see the
w_author_master_detail_sheet in the Pubs sample
application.

Opens the window w_sort, which allows the user to
specify a sort order for the master DataWindow.

Opens the window w_sort, which allows the user to
specify a sort order for the detail DataWindow.

wf_modified Returns the status of the DataWindow controls on the

window.

& Parameters. None.

¢ Return value. Integer. Returns -1 if either DataWindow fails the
AcceptText function (the data doesn't pass validation), 0 if rows have
been deleted or updated, and ! if all changes have been saved to the

database.
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wf_ok_to_continue Checks to see if data was modified, and if so uses
the f_exit_status function to allow the user to choose the action to be taken.

¢ Parameters. String specifying whether data should be saved because
the user is exiting or simply changing DataWindow rows:

¢ M specifies the user is moving between rows
¢ S specifies the user is exiting the window

This parameter is used by the f_exit_status function, which can be
called by this event.

¢  Return value. Boolean. Returns TRUE if processing should continue
and FALSE if the current window should be maintained.

wf_set_sheettitle If the application does not allow windows with
duplicate information to be opened at the same time, this window function
determines if the instance of the window being opened has already been
opened by checking the window title against a shared string array variable.
If the title already exists, the function returns FALSE,; if it does not exist,
the title is added to the list of existing titles.

¢ Parameters. String containing the information being added to the title
of the window.

¢ Return Value. Boolean. Returns TRUE if no window instance is
already open and FALSE if a window instance is already open.

wf_update_dw Updates the database and does all error checking. If the
master DataWindow is performing a delete, then the update for the detail
DataWindow is performed first and then the master DataWindow is
updated. This is done to make sure that any referential integrity checking
done by the database will not cause the transaction to roll back because the
master record was deleted with the detail record still existing.

If it is not for a delete, then the update for the master is performed first to
ensure that the primary key exists in the database before any records are
inserted from the detail DataWindow that uses that primary key.

If either of the DataWindows fails to successfully perform its update, then
all updates are rolled back and the DataWindows remain in the state that
they were in (they are not aware that an update has been attempted) before
the update process started.

¢ Parameters. None.
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Instance variables

Usage

Example

¢ Return Value. Boolean. Returns TRUE if the update succeeded and
FALSE if it failed.

Variable Data type Access
ib_data_ok Boolean Protected
ib_inserting Boolean Protected
ib_insert_on_open Boolean Protected
ib_insert_on_zero_rows Boolean Protected
il_master_cur_row Long Protected
il_detail _cur_row Long Protected
is_window_title String Protected
is_window_title_new String Protected
is_window_title_data String Protected
allow_duplicate_processes | Boolean Protected
iw_frame w_sys_frame Protected
str_parms istr_parms Protected

Use descendants of this window for all sheets that display two
DataWindow controls with a many-to-many master/detail relationship. Its
frame window should be a descendant of w_sys_frame. In addition to your
application-specific processing, you must add script to retrieve rows (in the
ue_retrieve_data user event) and to synchronize the DataWindow controls
(in the dw_master RowFocusChanged event).

Associate this sheet window with a descendant of your frame menu. The
frame menu should in turn be a descendant of m_sys_frame. Keeping the
m_sys_frame menu in your inheritance chain provides integration with
user events, window functions, and user object functions defined in this
window.

Referential integrity

This window assumes that the DBMS handles referential integrity
automatically. That is, it does not lock the master row when updating a
related detail row.

For an example of using w_sys_mast_detl_dw as an ancestor window, see
the w_author_master_detail_sheet window in the Pubs sample application.
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See also f db_error
f _exit_status
f get token
w_sys_frame
w_sys_multi_dw
W_sys_report
w_sys_shared_dw
w_sys_single_dw

w_sys_multi_dw

Description Application framework window object that provides the functionality
needed for multirow DataWindows. This window is the ancestor for all
windows that contain multirow DataWindows.

This window is inherited from w_sys_single dw, described on page 193.
Additionally, it is the ancestor for w_sys_shared_dw, described on page
191.

Type Main (but designed to be opened as a sheet in an MDI frame)
Library SYS.PBL
Invocation Open ( w_sys_multi_dw_descendant )
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Controls used

Control events

Window events

Window functions

Parameter

| Description

w_sys_multi_dw_descendant

Window that is a descendant of
w_sys_multi_dw

Control | Control type

dw_sheet ! uo_dw standard user object (DataWindow control)
Control Event | Description

dw_sheet RowFocusChanged l Highlights the current row

Event Description

ue_filenew Overrides the ancestor script. This event inserts a row after

(user event)

ue_filedelete
(user event)

ue_deleteall
(user event)

the current row of the DataWindow unless no rows exist. This
event is triggered from the File>New menu item or the
corresponding toolbar button.

Overrides the ancestor script. This event deletes one row at a
time from the multirow DataWindow. This event is triggered
from the File> Delete menu item or the corresponding toolbar
button.

Deletes all rows from the multirow DataWindow.

& Inherited events are not documented in this section. For information
on inherited events, see "w_sys_single_dw," on page 193.

wf_deleterow This function is called from the ue_deleteall user event.
As each row of the DataWindow is about to be deleted, the row number is
passed to this function. If referential integrity checks have passed, this
function calls the DeleteRow function for the row. To add referential
integrity checks to your application, define them using the
uf_add_validation user object function, explained in Chapter 9, "User

Objects."

¢ Parameters. The current row number.

¢ Return value. Boolean. TRUE indicates that the delete was successful;
FALSE indicates that it failed.
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Instance variables

Usage

Example

See also

w_sys_pipel

Description
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Variable | Data type | Access
il_current_row Long Protected
il_new_row Long Protected
il_num_rows Long Protected

Use descendants of this window for all sheets that display a multirow
DataWindow control. Its frame window should be a descendant of
w_sys_frame. In addition to your application-specific processing, you must
add script to retrieve rows (in the ue_retrieve_data user event).

Associate this sheet window with a descendant of your frame menu. The
frame menu should in turn be a descendant of m_sys_frame. Keeping the
m_sys_frame menu in your inheritance chain provides integration with
user events, window functions, and user object functions defined in this
window.

For an example of using w_sys_multi_dw as an ancestor window, see the
w_titleauthor_sheet window in the Pubs sample application.

w_sys_frame
w_sys_mast_detl_dw
w_sys_report
w_sys_shared_dw
w_sys_single_dw

ine

Application framework window object that provides the functionality
needed to execute a data pipeline. This window creates an instance of the
u_pipeline_kit Class user object (nonvisual user object) and provides
events, user events, and windows functions that allow you to move data
between data sources using a pipeline. This window is the ancestor for all
windows that provide pipeline functionality.
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Type
Library

Invocation

Controls used

_SYS_| pe}mc
s Actions Window Help

Main (but designed to be opened as a sheet in an MDI frame)

SYS.PBL

Open ( w_sys_pipeline_descendant )

Parameter | Description

w_sys_pipeline_descendant ’ Window that is a descendant of w_sys_pipeline
Control Control type

dw_msg DataWindow that displays processing messages

dw_pipe_errors
st_elapsed_time

st_errors

st_read

St_written

DataWindow used by the pipeline to display errors
StaticText to display elapsed time

StaticText to display the number of errors that can occur
before the pipeline stops processing

StaticText to display the number of rows read

StaticText to display the number of rows written
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Window events
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Event

Description

CloseQuery

Open

ue_cancel_pipe
(user event)

ue_execute_pipe
(user event)

ue_print_errors
(user event)
ue_print_log
(user event)
ue_repair_pipe
(user event)

ue_reset_log
(user event)

ue_set_pipe_commit
(user event)

ue_set_pipe_ext_attr_copy
(user event)

Checks the ib_executing instance variable to
determine if the pipeline is currently executing. If
the pipeline is executing, this event sets
Message.ReturnValue to 1, stopping window
Close processing.

The descendent window's Open event must:

¢ Create a transaction object for the source
database

& Create a transaction object for the destination
database

¢ Create the pipeline object and connect to the
databases by calling the wf_initialize_pipeline
function

Cancels pipeline execution. This event is triggered
from the Actions> Cancel menu item.

Begins pipeline execution. This event is triggered
from the Actions>Execute menu item.

Prints the pipeline errors DataWindow. This event
is triggered from the File> Print Errors menu item.

Prints the dw_msg DataWindow. This event is
triggered from the File> Print Log menu item.

Resubmits corrected rows to the destination
database. This event is triggered from the
Actions> Repair Pipeline menu item.

Clears the rows in the dw_msg DataWindow. This
event is triggered from the File>Reset Log menu
item.

Sets the pipeline COMMIT frequency to the value
specified in Message.LongParm. This event is
triggered from choices under the

Actions> Pipeline Commits menu item.

Controls whether the pipeline copies extended
attributes by setting the attribute to the value
specified in Message.StringParm. This event is
triggered from the Actions> Pipeline Copy
Extended Attributes menu item.
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Window functions

Event Description
ue_set_pipe_maxerrors Sets the value of the attribute indicating the
(user event) number of errors the pipeline will allow before

canceling processing. This event is triggered from
choices under the Actions> Pipeline Maximum
Errors menu item.

ue_set_pipe_type Sets the pipeline type (create, append, replace, and
(user event) so on). This event is triggered from choices under
the Action>Pipeline Type menu item.

wf_add_msg Adds a row to the dw_msg DataWindow.

¢ Parameters. String specifying the message text to add to the dw_msg
DataWindow.

¢  Return value. None.

wf_get_errcount Returns the number of errors.

¢ Parameters. None.

¢ Return value. Long indicating the number of rows in the
dw_pipe_errors DataWindow.

wf_get_pipe_ext_attr_copy Returns a boolean indicating whether

extended attributes will be copied.

¢ Parameters. None.

¢ Return value. Boolean. TRUE if extended attributes will be copied and
FALSE if they will not.

wf_get_pipe_commit Returns the current COMMIT frequency.

¢ Parameters. None.

¢ Return value. Long indicating the current COMMIT frequency.

wf_get_pipe_maxerrors Returns the value of the attribute indicating

the number of errors the pipeline will allow before canceling execution.

¢ Parameters. None.

¢ Return value. Long indicating the maximum errors the pipeline will
allow before canceling execution.
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wf_get_pipe_type Returns the pipeline type.

¢ Parameters. None.

¢ Return value. String indicating the pipeline type.
¢ Create

¢ Replace

¢ Append

¢ Refresh

¢ Update

wf_initialize_pipeline Initializes the u_pipeline_kit user object and

connects to the source and destination databases. For sample code that you

place in the Open event to prepare the call to wi _initialize_pipeline, see
the comments in the w_sys_pipeline Open event.

¢ Parameters:
¢  String specifying the name of the pipeline object.

¢ Transaction object for the source database (passed by reference).
You must create this transaction object before calling the
wf_initialize_pipeline function.

¢ Transaction object for the destination database (passed by
reference). You must create this transaction object before calling
the wf_initialize_pipeline function.

o Return value. Boolean. Returns TRUE if the database connection
succeeded and FALSE if it did not.

wf_set_menu_attributes Sets menu item states to reflect the current

state of the pipeline object.

¢ Parameters. None.

¢ Return value. None.

Instance variables Variable Data type Access
ib_attempt_connect | Boolean Public
ib_executing Boolean Public
i_dest Transaction Public
i_pipe U_pipeline_kit Public
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Variable | Data type | Access
i_src I Transaction ‘ Public
Usage Use descendants of this window for all sheets that implement data pipeline

functionality. To use this functionality, you must also have defined:
¢ A data source for the source database
¢ A data source for the destination database

¢ A pipeline object (using the Data Pipeline painter)

Pipeline object versus pipeline user object

A pipeline object includes data selection criteria, source database
information, and destination database information. You create pipeline
objects using the Data Pipeline painter. A pipeline user object is a Class
object descended from the Pipeline system object. The application
framework includes the u_pipeline_kit pipeline user object. At runtime,
you create an instance of the u_pipeline_kit user object and associate it
with a pipeline object using the wf_initialize_pipeline window function.

Example To use the w_sys_pipeline, window:
1 In the Window painter, create a descendant of w_sys_pipeline.

2 Use the PowerScript painter to access the descendent window's Open
event. In this event, you include PowerScript statements that:

¢ Create a transaction object for the source database.
¢ Create a transaction object for the destination database.

¢ Call the wf_initialize_pipeline window function, passing the name
of the pipeline object, the source transaction object, and the
destination transaction object. This function creates an instance of
the pipeline user object and connects to the databases.

Save the window.
In the Menu painter, create a descendant of m_sys_frame.
Enable pipeline functionality in the File and Actions menus.

Save the menu.

N O e AW

Use the Window painter to associate the new menu with your
w_sys_pipeline descendant.
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See also

8  Associate your new window with a frame menu by adding a menu item
to the frame menu that opens it as an MDI sheet.

9  Test the pipeline window.

These instructions assume that a pipeline object, source data source, and
destination data source already exist.

m_sys_frame
w_sys_frame
u_pipeline_Kkit

w_sys_report

Description

Type
Library

Invocation

186

Application framework window object that provides the functionality
needed for generating reports where the report is a single DataWindow. It
allows you to automatically implement query mode (set the corresponding
query mode menu items to visible and enabled) and also limit which
columns can be used with query mode. It also includes print preview and
zoom functionality. It has no data manipulation or update functionality and
assumes that all DataWindow columns have a tab order of zero.

Main (but designed to be opened as a sheet in an MDI frame)
SYS.PBL

Open ( w_sys_report_descendant )
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Controls used

Window events

Parameter

| Description

w_sys_report_descendant

‘ Window that is a descendant of w_sys_report

Control Control type

dw_sheet DataWindow

Event Description

Close If duplicate instances of the same information cannot
be opened, this event removes the sheet from the list
of open windows for this type of sheet.

Open Sets the transaction object for the DataWindow
control dw_sheet and also registers the MDI frame
and the menu assigned to the sheet. This registration
assigns the menu and MDI frame to instance
variables, allowing you to reference them in scripts
without hardcoding actual menu and window names.

Resize Resizes the dw_sheet DataWindow control to the

ue_filesaveas
(user event)

ue_fileprint
(user event)

ue_retrieve_data
(user event)

ue_select_window
(user event)

size of the window.

Calls the PowerBuilder SaveAs function, which
allows the information displayed in the DataWindow
to be saved as a file of a user-specified type. This
event is triggered from the File> SaveAs menu item
or the corresponding toolbar button.

Calls the PowerBuilder Print function, which prints
the DataWindow. This event can be overridden in the
descendant to call other print functions. This event is
triggered from the File> Print menu item or the
corresponding toolbar button.

Not used in the ancestor window. Use this event to
retrieve data by coding a dw_sheet.Retrieve function
in the descendent window.

Not used in the ancestor window. Call this event
from the ue_fileopen and ue_open_as_dependent
events. Use it to set instance variables that you then
use in the ue_retrieve_data event to retrieve data into
the DataWindow. For examples, see the Pubs sample
application.
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Event

Description

ue_open_as_dependent
(user event)

ue_fileprint_preview
(user event)

ue_zoom_smaller
(user event)

ue_zoom_bigger
(user event)

ue_toggle query_mode
(user event)

ue_reset_query_criteria
(user event)

ue_sort
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Triggers the ue_select_window and ue_retrieve_data
events. You use the ue_select_window event to
populate the instance variable(s) used in the
ue_retrieve_data event without prompting the user
for the information.

Trigger this event in the window Open event script
when being opened from another window if multiple
instances are not allowed.

Opens the w_printzoom window, which allows the
user to specify the degree of zoom and other options
for viewing the DataWindow before printing it.

Decrements the zoom factor (stored in the
ii_current_zoom instance variable) by the value
stored in the ii_zoom_increment instance variable
and then redisplays the dw_sheet DataWindow using
that zoom factor.

Increments the zoom factor (stored in the
ii_current_zoom instance variable) by the value
stored in the ii_zoom_increment instance variable
and then redisplays the dw_sheet DataWindow using
that zoom factor.

Examines the dw_sheet DataWindow; if the
DataWindow is not in query mode it sets the border
and tab sequence of the columns that have been
marked as allowable for query mode so that the user
can enter data to be used for the query; puts the
DataWindow into query mode; and resets the menu
and toolbar to reflect query mode. If the DataWindow
is already in query mode, the event resets the
columns used for query mode input, takes the
DataWindow out of query mode, and triggers the
ue_retrieve_data event.

For information on specifying columns for query
mode, see the wf_add_query_mode_column function,
under Window functions, next.

Resets the DataWindow so that any data it contains
is eliminated. It also resets any information that may
have been entered to be used as query criteria.

Opens the w_sort window, allowing the user to
specify sort criteria for the DataWindow.



Chapter 4 Window Objects

Window functions

Instance variables

wf_set_sheettitle If the application does not allow windows with
duplicate information to be opened at the same time, this window function
determines if an instance of the window being opened is already open. It
does this by checking the window title against a shared string array
variable. If the title already exists, the function returns FALSE; if it does
not exist, the title is added into the list of existing titles.

¢ Parameters. String containing the information being added to the title
of the window.

¢ Return value. Boolean. Returns TRUE if no window instance is

already open and FALSE if a window instance is already open.
wif_query_status Returns the status of the DataWindow's query mode
attributes.

¢ Parameters. None.

¢ Rewrn Value. Boolean. Returns TRUE if the DataWindow is in query
mode and FALSE if it is not.

& For more information on query mode, see Building Applications in
the PowerBuilder documentation set.

wf_set_query_state Turns query mode on or off, as specified by the
input parameter. It also sets the menu state to reflect the current mode.

¢ Parameters. Boolean specifying the requested query mode state. TRUE
turns query mode on and FALSE turns it off.

¢ Return value. None.
wf_add_query_mode_column Adds to the list of columns that are
allowed to be used while in query mode.

¢  Parameters. String specifying the name of the column to be added to
the list.

¢ Return value. None.

Variable | Default | Data type Access
is_window_title j None ' String Protected
is_new_window_title None ) String Protected
is_window_title_data None ‘ String Protected
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Usage

Example

See also
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Variable Default Data type Access
allow_duplicate_processes None Boolean Protected
ib_data_ok None Boolean Protected
istr_parms None str_parms Protected
im_menu_id None m_sys_frame | Protected
iw_frame None w_sys_frame | Protected
ii_zoom_increment 10 Integer Protected
ii_current_zoom None Integer Protected
is_query_mode_cols[] None String Protected

Use descendants of this window for all report sheets. Its frame window
should be a descendant of w_sys_frame. In addition to your application
specific processing, you must add script to retrieve rows (in the
ue_retrieve_data user event).

Associate this sheet window with a descendant of your frame menu. The
frame menu should in turn be a descendant of m_sys_frame. Keeping the
m_sys_frame menu in your inheritance chain provides integration with
user events, window functions, and user object functions defined in this
window.

For an example of using this window as an ancestor object, see any of the
online reports in the Time Management sample application.

Ww_printzoom

w_sort

w_sys_frame
w_sys_mast_detl_dw
w_sys_multi_dw
w_sys_shared_dw
w_sys_single_dw



Chapter 4 Window Objects

w_sys_shared_dw

Description

Type
Library

Invocation

Controls used

Control events

Application framework window object that provides the functionality
needed for a many-to-one Master/Detail maintenance window. For many-
to-many Master/Detail windows, use the w_sys_mast_detl_dw window.

This window is a descendant of w_sys_multi_dw, described on page 178.

Shared Datawindow Ancestor

Main (but designed to be opened as a sheet in an MDI frame)

SYS.PBL

Open ( w_sys_shared_dw_descendant )

Parameter | Description

w_sys_shared_dw_descendant | Window that is a descendant of
w_sys_shared_dw

Control Control type

dw_sheet uo_dw standard user object (DataWindow control)

dw_detail DataWindow control

Control Event Description

dw_sheet RowFocusChanged | Causes the dw_detail DataWindow
control to scroll to the current row of
the dw_sheet DataWindow control
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Control Event Description

dw_detail RowFocusChanged | Causes the dw_sheet DataWindow
control to scroll to the current row of
the dw_detail DataWindow control

Window events Event Description

open Extends the ancestor script by sharing the two DataWindows
and then posts the ue_retrieve_data event.

Resize Overrides the ancestor script. No action is taken when the
window is resized.

ue_filenew Overrides the ancestor script. It inserts a row after the current
(user event) row of the DataWindow unless no rows exist. This event is
triggered from the File>New menu item or the corresponding
toolbar button.

& Inherited events are not documented in this section. For information
on inherited events, see "w_sys_single dw," on page 193 and
"w_sys_multi_dw," on page 178.

Window functions wf_modified Overrides the ancestor and includes functionality that
examines the dw_detail DataWindow when determining if unsaved
changes exist.

¢ Parameters. None.

¢ Return value. Integer. Returns -1 if the DataWindow fails the
AcceptText function (the data doesn't pass validation), 0 if rows have
been deleted or updated, and 1 if all changes have been saved to the
database.

Usage Use descendants of this window for all sheets that display two
DataWindow controls with a many-to-one Master/Detail relationship. Its
frame window should be a descendant of w_sys_frame. In addition to your
application-specific processing, you must add script to retrieve rows for the
dw_sheet DataWindow control (in the ue_retrieve_data user event).

Associate this sheet window with a descendant of your frame menu. The
frame menu should in turn be a descendant of m_sys_frame. Keeping the
m_sys_frame menu in your inheritance chain provides integration with
user events, window functions, and user object functions defined in this
window.
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Example

See also

For an example of using descendants of this window, see the tutorial in
Part Two.

w_sys_frame
w_sys_mast_detl_dw
w_sys_multi_dw
W_Sys_report
w_sys_single_dw

w_sys_single_dw

Description

Type
Library

Invocation

Application framework window object that provides the functionality
needed for a single-row maintenance window. In the sample applications,
this window is used as the ancestor for all windows with a single-row
DataWindow.

This window is the ancestor for w_sys_multi_dw, described on page 178.

Untitled

Main (but designed to be opened as a sheet in an MDI frame)
SYS.PBL

Open ( w_sys_single_dw_descendant )
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Controls used

Control events

194

Parameter

| Description

w_sys_single_dw_descendant

Window that is a descendant of

w_sys_single_dw

Control Control type

dw_sheet uo_dw standard user object (DataWindow control)

Control Event Description

dw_sheet ItemFocusChanged Sets the MicroHelp to the tag values
assigned in the DataWindow.

dw_sheet RetrieveEnd Resets the toolbar buttons and menu items
based on the status of the DataWindow.

dw_sheet ue_tab_out Not used in the ancestor window.

(user event) Descendent windows should set the
column in this event to the first column in
the DataWindow. This event is triggered
by the pbm_dwntabout event for the
DataWindow.

dw_sheet on_delete Triggered by the SQLPreview event. It

(user event) allows you to perform application-specific
processing just before deleting a row from
the database. To reject the request, issue a
SetActionCode(1) function.

dw_sheet on_insert Triggered by the SQLPreview event. It

(user event) allows you to perform application-specific
processing just before inserting a row into
the database. To reject the request, issue a
SetActionCode(1) function.

dw_sheet on_update Triggered by the SQLPreview event. It

(user event)

allows you to perform application-specific
processing just before updating a row in
the database. To reject the request, issue a
SetActionCode(1) function.
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Window events

Event

Description

Close

CloseQuery

Open

Resize

ue_filenew
(user event)

ue_fileopen
(user event)

If duplicate instances of the same information cannot
be opened, this event removes the sheet from the list
of open windows for this type of sheet.

Checks the DataWindow to see if any rows have been
modified and not saved. If any have, the f_exit_status
function is called, which opens the w_exit_status
window, allowing the user to save the modifications
and exit the window, exit without saving, or cancel
the request.

Sets the transaction object for the DataWindow
control dw_sheet and also registers the MDI frame
and the menu assigned to the sheet. This registration
assigns the menu and MDI frame to instance
variables, allowing you to reference them in scripts
without hardcoding actual menu and window names.

Resizes the DataWindow control dw_sheet to the size
of the window.

Checks to see if the current information displayed was
modified and prompts the user to save the
information. Then it resets DataWindow and inserts a
new row. This event is triggered from the File>New
menu item or from the corresponding toolbar button.

Used to open a search window and display
information based on entered criteria. The user is
prompted to save any changes that have been made
before the new record is selected. This event is
triggered from the File>Open menu item or the
corresponding toolbar button.

This user event triggers the ue_select_window user
event, which is expected to perform processing that
selects new information (usually by opening a
descendant of the w_select window). This information
is then stored in instance variables that are referenced
in the ue_retrieve_data event, which performs the
actual retrieve. You must code the ue_select_window
and ue_retrieve_data events in the descendent
window.

195



w_sys_single_dw

196

Event

Description

ue_filedelete
(user event)

ue_filesave
(user event)

ue_filesaveas
(user event)

ue_fileprint
(user event)

ue_retrieve_data
(user event)

ue_validate
(user event)

ue_validatedelete
(user event)

ue_select_window
(user event)

Prompts for confirmation on the delete. If yes, it
triggers the ue_validatedelete user event. If the row
can be deleted, the delete is performed. This event
does an automatic update to the database and is
triggered from the File>Delete menu item or the
corresponding toolbar button.

Ensures that the information entered in the
DataWindow control has been accepted and performs
the update. This event is triggered from the
File>Save menu item or the corresponding toolbar
button.

Calls the PowerBuilder SaveAs function, which
allows the information displayed in the DataWindow
to be saved as a file of a user-specified type. This
event is triggered from the File> SaveAs menu item or
the corresponding toolbar button.

Calls the PowerBuilder Print function, which prints
the DataWindow. This event can be overridden in the
descendant to call other print functions. This event is
triggered from the File>Print menu item or the
corresponding toolbar button.

Not used in the ancestor window. Use this event to
retrieve data by coding a dw_sheet.Retrieve function
in the descendent window.

Not used in the ancestor window. Descendent
windows can trigger this event to perform cross-
reference checking between multiple columns before
the information is saved.

Called from the ue_filedelete user event. The event
initializes the boolean variable ib_data_ok to TRUE.
The descendent event scripts should include
referential integrity checking as needed. If the delete
should not be performed for referential integrity
reasons, the descendent script should set the
ib_data_ok variable to FALSE.

Not used in the ancestor window. Call this event from
the ue_fileopen and ue_open_as_dependent events in
the descendant window. Use it to set instance
variables that you then use in the ue_retrieve_data
event to retrieve data into the DataWindow. For
examples, see the Pubs sample application.
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Window functions

Event Description

ue_open_as_dependent | Similar to the ue_fileopen event in that it also triggers
(user event) the ue_select_window and ue_retrieve_data events.
You use the ue_select_window to populate the
instance variable(s) used in the ue_retrieve_data event
without prompting the user for the information.

Trigger this event in the window Open event script
when being opened from another window if multiple
instances are not allowed.

ue_fileprint_preview Opens the w_printzoom window, which allows the
(user event) user to specify the degree of zoom and other options
for viewing the DataWindow before printing it.

wf_set_sheettitle If the application does not allow windows with
duplicate information to be opened at the same time, this window function
determines if an instance of the window being opened is already open by
checking the window title against a shared string array variable. If the title
does not exist, it adds the title to the list of existing titles.

¢ Parameters. String containing the information being added to the title
of the window.

¢ Return value. Boolean. Returns TRUE if no window instance is
already open and FALSE if a window instance is already open.

wf_update_dw Performs the update to the DataWindow control and

does all error checking.

¢ Parameters. None.

¢ Return value. Boolean. Returns TRUE if the update succeeded and
FALSE if it failed.

wf_modified Returns the status of the window's DataWindow control.

¢  Parameters. None.

¢ Return value. Integer. Returns -1 if the DataWindow fails the
AcceptText function (the data doesn't pass validation), 0 if rows have
been deleted or updated, and 1 if all changes have been saved to the
database.
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Instance variables

Usage

Example

See also
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Variable Data type Access
allow_duplicate_processe | Boolean Protected
s

ib_data_ok Boolean Protected
ib_insert_on_open Boolean Protected
im_menu_id m_sys_frame Protected
is_new_window_title String Protected
is_window_title String Protected
is_window_title_data String Protected
istr_parms str_parms Protected
iw_frame w_sys_frame Protected

Use descendants of this window for all sheets that display a single-row
DataWindow control. Its frame window should be a descendant of
w_sys_frame. In addition to your application-specific processing, you must
add script to retrieve the row (in the ue_retrieve_data user event).

Associate this sheet window with a descendant of your frame menu. The
frame menu should in turn be a descendant of m_sys_frame. Keeping the
m_sys_frame menu in your inheritance chain provides integration with
user events, window functions, and user object functions defined in this
window.

For an example of using this window as an ancestor object, see the
w_author_sheet window in the Pubs sample application.

f db_error

f exit_status

uo_dw

w_sys_frame
w_sys_mast_detl_dw
w_sys_multi_dw
W_Sys_report
w_sys_shared_dw
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w_system_error

Description ‘ Displays system errors. It allows the user to continue running the
application, exit the application, or print the error message. You should
call it from the SystemError event in the application object.

Error Number: 2

Error Message : Null object reference
WindowMenu: f_error_box
Object: f_error_box

Event: f_error_box

Line in Script: 31

Type Response
Library UTLWIN.PBL
Invocation Open ( w_system_error )
Controls used Control Control type
dw_error DataWindow
cb_continue CommandButton
cb_exit CommandButton
cb_print CommandButton
Control events Control Event Description
cb_continue Clicked Closes the w_system_error window, remaining
in the application
cb_exit Clicked Closes the w_system_error window, ending the
application
cb_print Clicked Prints the error information displayed on the
window
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Window events

Usage

Example

w_wait for

Description

Type
Library

Invocation
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Event | Description

Open | Sets the error information from the error object into dw_error

Use this window in the application object's SystemError event to display
system errors.

This example opens window w_system_error from the SystemError event
in the application object.

Open (w_system_error)

Checks every three seconds to determine if a file has appeared or
disappeared.

The f_wait_for function opens this object.

Response

UTLWIN.PBL

f_wait_for ( filename, appeardisappear )

Parameter | Description

filename ’ String containing the name of the file
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Parameter Description

appeardisappear | Boolean variable indicating whether to wait for file to
appear or to disappear:

¢ TRUE — Wait for the named file to appear
¢ FALSE — Wait for the named file to disappear

Controls used Control Control type
cb_cancel CommandButton
st_curr_time StaticText
st_filename StaticText
st_start_time StaticText

st_times_looked StaticText

Control events Control Event ‘ Description

cb_cancel Clicked Closes the window and returns FALSE to
the calling function

Window events Event Description
Open Initializes window text and triggers the Timer event.
Timer Looks every three seconds for the filename passed to

determine whether it has appeared or disappeared. Once the
file exists or is deleted, the window will be closed, returning
TRUE back to the calling function.

Instance variables Variable | Datatype | Access
ib_appear ‘ Boolean ‘ Public
is_filename String t Public
ii_times_looked Integer ‘ Public
Usage Use this window when your application depends on the presence or

absence of a particular file.
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Example This example runs a process named work.pif, which writes a file named
done.xxx when it is completed. The script will resume running when this
file appears.

boolean status

// Make sure that the semaphore file does not exist.
FileDelete( 'done.xxx')

Run("work.pif")

// Wait for the file 'done.xxx' to appear.

status = f_wait_for('done.xxx',TRUE)

IF NOT status THEN

// Error on process or user canceled.
END IF

See also f wait_for
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DataWindow Objects

About this chapter This chapter describes the DataWindow objects contained in the
Application Library.

& For information on the uo_dw DataWindow user object, which is a
DataWindow control used in application framework windows to perform
database access, refer to Chapter 9, "User Objects."

d_file_display

Description Displays the contents of a previously stored text file in the w_file_display
window.

Library UTLWIN.PBL
Usage This DataWindow object is used by the function f_display_file.
See also f display_file

w_display_file
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d free resources

Description Displays the free resources graph.

Library UTLWIN.PBL

Usage This DataWindow object is used by the window
w_get_free_resources_graph.

See also w_get_free_resources
w_get_free_resources_graph
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d_global_vars

Description Maintains global variables.

Library UTLFUNC.PBL
Usage This DataWindow object is used in the window w_hold_parms.
See also w_hold_parms

d_profile

Description Displays profile information.

[Jz;a\Nlnduw d_profile

Library UTLWIN.PBL
Usage This DataWindow object is used in the w_profile window.
See also w_profile
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d_progress
Description Graphically shows the progress of a process.
] N ééWiqdow - d,—pr,
Library UTLWIN.PBL
Usage This DataWindow object is used in the w_progress window.
See also W_progress
d_sort
Description Allows the user to select the new sort order for another DataWindow.
Data\ﬁlﬁndnw -d_sort
Library UTLWIN.PBL
Usage This DataWindow object is used in the w_sort window.
See also w_sort
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d_sort_order

Description Allows the user to select the new sort order for another DataWindow.

Library UTLWIN.PBL
Usage This DataWindow object is used in the w_sort_order window.
See also w_sort_order

d_system_error

Description Displays system error information.
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Library UTLWIN.PBL
Usage This DataWindow object is used in the w_system_error window.
See also w_system_error
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Global Functions

About this chapter

f_app_open

Description

Library

Syntax

This chapter describes the global functions in the Application Library. It
includes descriptions and examples of each function. Functions are listed
in alphabetical order.

Opens the application's MDI frame window. It accesses the application INI
file and is required for all applications that use the Application Library's
application framework.

SYS.PBL

f_app_open ( appinifile, mainwindow, allowmultiples)

Return value

Parameter Description

appinifile String containing the name of the application's INI file

mainwindow Window variable of type w_sys_frame containing the name of
the application's MDI frame window (the MDI frame window
to be opened)

allowmultiples Boolean value indicating whether multiple application
instances are allowed

None
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Usage

Example

See also

f block text

Description

Library

Syntax

210

Call this function from the application object's Open event. The INI file
provides database connection information. This is a sample INI file:
[Databasel]
DBMS=0DBC
LogId=
LogPassword=
ServerName=
Database=HOTLINE
UserId=dba
DatabasePassword=
DbParm=Connectstring='DSN=HOTLINE ; UID=DBA; PWD=SQL'

&~ Use the PUBS.INI file as a template when creating your application's
INI file.

This example calls the f_app_open function in the Open event of the
application. PUBS.INT is the INI file for the application and duplicate
windows are not allowed.

f_app_open('PUBS.INI',w frame,FALSE)

w_sys_frame

Receives a string and a block width for the string to be formatted and
returns the string as a left-justified paragraph reformatted to the specified
width.. It uses carriage return/line feed (~r~n) as the line separator.

UTLFUNC.PBL

f_block_text ( originalstring, blockwidth )

Parameter | Description

originalstrin String containing the text to be formatted
8 g g g

blockwidth Integer representing the width of the format block
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Return value
Usage

Example

String. Returns the string formatted in the specified width.
Use this global function to reformat text blocks to different lengths.

This statement passes the multiline edit text string mle_message.text to the
f_block_text function. The string Is_err_msg will contain the MLE text
formatted in a 60-character-wide, left justified block.

1s err msg = f_block_text (mle_message.text, 60)

f_boolean_to_string

Description
Library

Syntax

Return value

Usage

Example

See also

Returns the passed boolean value as a string.
UTLFUNC.PBL

f_boolean_to_string ( booleanvalue )

Parameters | Description

booleanvalue , Boolean value to be converted to a string.

String. Returns "TRUE" for a TRUE boolean value and "FALSE" for a
FALSE boolean value.

Use this function to convert boolean values for display or printing as text.

This example sets the value in Is_last_record to "TRUE" if Ib_last_record
is TRUE. Otherwise, it sets the field to "FALSE".

Boolean 1lb_last_record
string 1ls_last_record

ls_last record = f_boolean_to_string
(1lb_last_record)

f string_to_boolean
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f cascade window

Description

Library

Syntax

Return value

Usage

Example

f db_error

Description

212

Positions a window on opening so that it is just below the title or menu bar
of the window that opened it.

Not for MDI applications
This global function is for non-MDI applications only.

UTLFUNC.PBL

f_cascade_window ( window )

Parameter | Description

window Window variable naming the popup, child, or response window
to be opened. Window cannot specify a window of type Main,
MDI, or MDI with MicroHelp.

None

Use this function in a non-MDI application to open cascaded windows.
You should use this function with popup windows although it also works
for child and response windows.

This example is from the Open event of the cascading window.

f_cascade_window (this)

Identifies whether a database error has occurred by checking the
SQLCODE of the passed transaction object. If an error has occurred,
f_db_error opens the window w_db_error, passing a string parameter
containing the application-specific message and a boolean variable.
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Library

Syntax

Return value

Usage

Example

See also

Window w_db_error displays the error message passed and the DBMS-
specific error message. It also allows the user to print the error, close the
error window, or continue using the application.

UTLWIN.PBL

f_db_error ( transactionobject, errormessage )

Parameter | Description
transactionobject | Name of the programmer-specified transaction object
currently being used

errormessage Application-specific message that will be displayed above

the database error message

Integer. Returns 0 if no database error is found and I if a database error
occurred. If a database error occurs, then w_db_error displays.

Use this global function to trap errors after any embedded SQL is executed
in scripts. Use the f_error_box function to check database errors for
DataWindows.

This example calls global function f_db_error and passes the default
transaction object SQLCA with an application-specific error message.

IF f_db_error (SQLCA,"Error for Test Application") &
<> 1 THEN

END IF

f debug box
f error_box
w_db_error
w_debug_box
w_error_box
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f_dddw_lookup

Description
Library

Syntax

Return value

Usage

Example

214

Positions an editable dropdown DataWindow based on what the user types.
UTLFUNC.PBL

f_dddw_lookup ( dwcontrol, dwcolumnname, dddwcolumndata,
dddwcolumndescription )

Parameter Description

dwcontrol DataWindow variable of the DataWindow control that
contains the dropdown DataWindow

dwcolumnname String specifying the name of the column displayed in
the dropdown DataWindow

dddwcolumndata String specifying which column of the dropdown
DataWindow to use for data (typically the same as
dwcolumnname)

dddwcolumndescription | String specifying which column of the dropdown
DataWindow to use for the lookup

Boolean. Returns TRUE if the typed characters match an item in the
dropdown DataWindow and FALSE if they do not.

Use this global function in the EditChanged and ItemChanged events to
scroll the dropdown DataWindow based on what the user types. You can
also use it to ensure that values exist in the dropdown DataWindow.

The dropdown DataWindow to be edited must be editable.

This is an example of what you might code for the DataWindow control's
EditChanged event. The code in this event, which occurs each time a key is
pressed, first checks to see if the column is state_code. If the column is
state_code, it calls the f_dddw_lookup function to position the dropdown
DataWindow list, based on what the user typed.

string col

col = this.GetColumnName /()

IF col = 'state_id' THEN
f_dddw_lookup(this,col, 'state_id', 'state_name')
END IF
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This is an example of what you might code for the DataWindow control's
ItemChanged event. It validates that the user-specified value in the
state_code column exists in the dropdown DataWindow.

string col

col = GetColumnName()
IF col = 'state_id' THEN
IF NOT f dddw_lookup(this,col, 'state_id', &
'state_name') THEN
SetActionCode(1)
Return
END IF
END IF

f_debug_box

Description

Library

Syntax

Return value

Usage

Opens the window w_debug_box, which displays the title and error
message passed from the calling window.

UTLWIN.PBL

f_debug_box ( windowtitle, errormessage )

Parameter | Description

windowtitle String containing a name for the w_debug_box window title.
Usually passes the current window title (that is, this.title or
parent.title).

errormessage String variable containing the error message to be displayed.

None

Use the f_debug_box function to communicate variables and status
information when debugging applications.

The w_debug_box window is nonmodal, which means that it can remain
open while the user performs other actions associated with the application,
and it can display multiple messages. Multiple calls to the f_debug_box
function append the new text to the existing window text.
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Example

See also

This example opens window w_debug_box if the PrintOpen function fails.

IF PrintOpen() = -1 THEN
f_debug_box (this.title, "Error in Print event")
END IF

f db_error

f error_box
w_db_error
w_debug_box
w_error_box

f_display_file

Description
Library

Syntax

Return value
Usage

Example

See also
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Displays the specified text file in the w_file_display window.
UTLFUNC.PBL

f_display_file ( filename)

Parameter | Description

filename String containing the fully qualified name of the file to be
displayed in the w_display_file window. Filename must use
the .TXT extension

None
Use this function to display text files in the w_file_display window.

This example displays the file if the GetFileOpenName function succeeds.

int result

string docname, named

result = GetFileOpenName("Select File", docname, &
named, "txt", "Text Files, *.txt")

IF result = 1 THEN f_display_file (docname)

w_file_display
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f_dw_fill_ddlb

Description

Library

Syntax

Return value

Usage

Example

Fills the items in a DataWindow dropdown listbox from a specified
database table.

UTLFUNC.PBL

f_dw_fill_ddlb ( datawindowname, sqlstatement, colname)

Parameter Description

datawindowname DataWindow variable pointing to the DataWindow
containing the dropdown listbox

sqlstatement String containing the SQL statement used to fill the
dropdown listbox

colname String containing the name of the column to be populated

Boolean. Returns TRUE if the SQL statement succeeds and FALSE if it
does not.

This function is provided to maintain backward compatibility. For new
applications, use dropdown DataWindows instead.

This example fills the dropdown listbox column STATE in
dw_location_info with values from the table STATES.

f_dw_£fill_ddlb(dw_location_info, &
"SELECT state, state_code FROM STATES", "STATE")

f_dw_get_attributes

Description

Library

Provides information about a series of attributes for a single object in a
DataWindow.

UTLFUNC.PBL
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f_dw_get_attributes

Syntax f_dw_get_attributes ( dwcontrol, dwobject, attributelist)
Parameter Description
dwcontrol DataWindow variable pointing to the DataWindow control
containing the attributes to be returned
dwobject String naming the object on the DataWindow whose attributes
are to be returned
attributelist String containing a comma-separated list of attributes to be
returned
Return value String containing a comma-separated list of attribute names. Returned

attributes are separated by newline (~n) characters.

Usage Use this function to get information about a series of attributes for a single
object on a DataWindow.

You can use the f_get_token function to separate the returned attribute
values.

Example This example calls function f_dw_get_attributes to get information about
the object au_id.
string results

integer 1i_x, li_y
boolean 1lb_visible

results = &
f_dw_get_attributes (dw_1,'au_id', 'x,y,visible’)
1li_x = integer(f_get_token(results,'~n'))
1li_y = integer(f_get_token(results,’'~n'))
1b _visible = f_string_to_boolean(results)

See also f dw_get_objects
f dw_get_objects_attrib
f dw_set_color
f dw_set_color_row
f get token
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f_dw_get_objects

Description

Library

Syntax

Return value

Usage

Examples

Parses the list of objects contained in the data object associated with a
DataWindow control, placing their names into a string array passed by
reference and returning the number of names in the array. You can control
the objects returned by type and by band.

& For information on valid band and object type names, see the
PowerBuilder Function Reference.

UTLFUNC.PBL

f_dw_get_objects ( dwcontrol, objectlist, objecttype, band)

Parameter Description

dwcontrol DataWindow variable pointing to the DataWindow control
containing the objects to be returned.

objectlist Unbounded string array into which f dw_get objects places
the data object names. This array is passed by reference.

objecttype String indicating the object type to be searched on.
Specifying an asterisk (*) returns the names of all objects.
band String indicating which band to search for objecttype.

Specifying an asterisk (*) returns data object names for all
bands.

Integer indicating the number of names in the objectlist array.

Use this function to get information about the DataWindow object
associated with a window's DataWindow control.

All DataWindow columns must have names
If this function will be used against columns, all of the DataWindow's
columns must have names.

This example returns the names of all text objects in the header band of
dw_1 into the mylist array; the number of names is returned in obj_num.

integer obj_num
string mylist[ ]
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f_dw_get _objects_attrib

See also

obj num = f_dw_get_objects(dw_1, mylist, &
"text", "header")

This example returns the names of all column objects in dw_1 into the
mylist array; the number of names is returned in obj_num.

integer obj_num

string mylist[ ]

obj num = f_dw_get_objects(dw_1l,mylist,"column”,"*")
This example returns the names of all objects in the summary band of
dw_1 into the mylist array; the number of names is returned in obj_num.

integer obj_num

string mylist[ ]

obj _num = f_dw_get_objects(dw_1, mylist, &
l|*|| , llsummaryll )

This example returns the names of all objects in dw_1 into the mylist
array; the number of names is returned in obj_num.

integer obj_num
string mylist[ ]

obj num = f_dw_get_objects(dw_1, mylist, "*", "*" )

f dw_get_attributes

f dw_get_objects_attrib
f dw_set_color

f dw_set_color_row

f_dw_get_objects_attrib

Description

220

Parses the list of objects contained in the data object associated with a
DataWindow control, placing their names into a string array passed by
reference and returning the number of names in the array. You can control
the objects returned by type and by band. Additionally, you can request
attribute values by passing a comma-separated list of attribute names. If
you request attributes, the function returns them as part of the array,
separated from the object name by newline (~n) characters.

& For information on valid band and object type names, see the
PowerBuilder Function Reference.



Chapter 6 Global Functions

Library

Syntax

Return value

Usage

Examples

UTLFUNC.PBL

f_dw_get_objects_attrib ( dwcontrol, objectlist, objecttype, band,

attributes)

Parameter Description

dwcontrol DataWindow variable pointing to the DataWindow control
containing the objects to be returned.

objectlist Unbounded string array into which f dw_get_objects_attrib
places the data object names. This array is passed by reference.

objecttype String indicating the object type to be searched on.
Specifying an asterisk (*) returns names and attributes of all
objects.

band String indicating which band to search for objecttype.

Specifying an asterisk (*) returns data object names and
attributes for all bands.

attributes String containing a comma-separated list of attributes.

Integer indicating the number of names in the objectlist array.

Use this function to get information about the DataWindow object and
object attributes associated with a window's DataWindow control.

All DataWindow columns must have names
If this function will be used against columns, all of your columns must
have names.

This example returns the names of all text objects in the header band of
dw_1 into the mylist array, and the number of names is returned into
obj_num. Their x and y coordinates are also returned.

integer obj_num

string mylist[ ]

obj_num = f_dw_get_objects_attrib(dw_1, mylist, &
lltextll ’ llheaderll , I|x’yll )

This example returns the names of all column objects in dw_1 into the
mylist array, and the number of names is returned into obj_num. No
attributes are requested.
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integer obj_num
string mylist[ ]

obj num = f_dw_get_objects_attrib(dw_1, mylist, &
Ilcolumnll , II*II , nn )

This example returns the names of all objects in the summary band of
dw_1 into the mylist array, and the number of names is returned into
obj_num. Information about the object's height is also requested.
integer obj_num
string mylist[ ]

obj num = f_dw_get_objects_attrib(dw_1, mylist, &
T« "summary" , "height")

This example returns the names of dw_1 objects into the mylist array, and
the number of names is returned into obj_num. No attributes are requested.

integer obj_num
string mylist[ ]

obj num = f_dw_get_objects_attrib(dw_1, mylist, &

"y "y un
' )

See also f dw_get_attributes
f dw_get objects
f dw_set_color
f dw_set_color_row
f get_token

f_dw_getcolnames

Description Gets the names for all columns in a DataWindow.
Library UTLFUNC.PBL
Syntax f_dw_getcolnames ( dwcontrol, colnames )
Parameter | Description
dwcontrol DataWindow variable of the DataWindow control containing

the columns to be returned.
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Return value
Usage

Example

See also

Parameter | Description

colnames Unbounded string array into which f dw_getcolnames places
the column names. This array is passed by reference.

Integer indicating the number of names in the colname array.
Use this function to determine the names of all columns in a DataWindow.

This example returns all DataWindow column names into the Is_colnames
array. The li_colnum variable indicates the number of entries in the
Is_colnames array.

integer 1i_colnum
string 1s_colnames] ]

1li_colnum = f_dw_getcolnames (dw_sheet, ls colnames)

f dw_get_attributes

f dw_get objects

f dw_get_objects_attrib
f dw_getheaderlabel

f dw_getvisiblecolumns
f_dwobjectatpointer

f_dw_getheaderlabel

Description

Library

Syntax

Determines an appropriate header for a column. This function first looks
for a static text label with column name plus the _t suffix. If that isn't
found, it then looks for a tag value. If there is no tag value, the function
returns the column name. And if the column name isn't available, it returns
an empty string.

UTLFUNC.PBL

f_dw_getheaderlabel ( dwcontrol, colname )
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Parameter Description

dwcontrol DataWindow control variable of the DataWindow control
containing the column

colname String specifying the column name for which a heading value
will be returned

Return value String containing the column label. If a heading cannot be found it returns
an empty string and displays an error message.

Usage Use this function when you want to use a column's header text instead of
the column name in a message box.

Example This example returns the column header for emp_id into Is_colheader.
string 1ls_colheader

1s_colheader =
f_dw_getheaderlabel (dw_sheet, "emp_id")

See also f_dw_get_attributes
f dw_get_objects
f dw_get_objects_attrib
f dw_getcolnames
f_dw_getvisiblecolumns
f_dwobjectatpointer

f_dw_getvisiblecolumns

Description Gets the names of all visible columns in a DataWindow.
Library UTLFUNC.PBL
Syntax f_dw_getvisiblecolumns ( dwcontrol, colnames )
Parameter | Description
dwcontrol DataWindow variable of the DataWindow control containing

the columns to be returned.
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Return value

Usage

Example

See also

Parameter | Description

colnames Unbounded string array into which f dw_getvisiblecolumns
places the column names. This array is passed by reference.

Integer indicating the number of columns in the colname array.

Use this function to determine the names of all visible columns in a
DataWindow.

This example returns the names of all visible DataWindow columns into
the Is_colnames array. The li_colnum variable indicates the number of
entries in the Is_colnames array.

integer 1i_colnum

string 1s_colnames][ ]

1i_colnum = &
f_dw_getvisiblecolumns (dw_sheet,ls colnames)

f dw_get attributes

f dw_get_objects

f dw_get_objects_attrib
f dw_getcolnames

f dw_getheaderlabel

f dwobjectatpointer

f_dw_objectatpointer

Description

Library

Syntax

Separates the string returned by the PowerBuilder GetObjectAtPointer
function into object name and row number.

UTLFUNC.PBL

f_dw_objectatpointer ( dwcontrol, rownumber, objectname )

Parameter | Description

dwcontrol DataWindow variable of the DataWindow control containing
the object under the pointer.
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f_dw_print

Return value

Usage

Example

See also

f_dw_print

Description

Library

Syntax

226

Parameter Description

rownumber Integer into which f_dwobjectatpointer places the row number.
This integer is passed by reference.

objectname String into which £ _dwobjectatpointer places the object name.
This string is passed by reference.

Integer. Returns 7 if the function succeeded and -1 if it did not.

The PowerBuilder GetObjectAtPointer function returns a string containing
the name of the object under the pointer, a nondisplaying tab, and the row
number. Use the f_dwobjectatpointer function to separate this string into
separate variables.

This example returns the row number into li_row and the object name into
Is_object.

integer 1li_row, li_return

string 1ls_object, ls_obj_and_row

1ls_obj_and row = dw_sheet.GetObjectAtPointer()
1li_return = &
f dw_objectatpointer(dw_sheet,li_row,ls_object)

f dw_get_attributes

f dw_get_objects

f dw_get_objects_attrib
f dw_getcolnames
f_dw_getheaderlabel

f dw_getvisiblecolumns

Prints the specified DataWindow to a printer or a file, optionally displaying
the w_dw_print_options window to prompt the user for more information.

UTLWIN.PBL

f_dw_print ( dwcontrol, numberofcopies, filename )
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Return value

Usage

Example

See also

Parameter Description

dwcontrol DataWindow variable of the DataWindow control whose
contents will be printed.

numberofcopies | Integer specifying the number of copies to be printed.

filename String containing the fully qualified name of the file to
contain the DataWindow contents. PowerBuilder creates this
file in the format of the current printer driver (for example,
PCL or PostScript).

Integer. Returns 7 if the function succeeded and -7 if it did not (or if the
user pressed Cancel in the w_dw_print_options window).

Use this function to control DataWindow printing and print options.

To display the w_dw_print_options window, numberofcopies must be 0
(zero) and filename must contain an empty string. If numberofcopies is
greater than O or if filename contains a nonempty string, the function does
not display the w_dw_print_options window but instead prints the
DataWindow immediately (to either a printer or a file, depending on
whether filename is empty).

This example prints the dw_sheet DataWindow and displays the
w_dw_print_options window to prompt the user for additional information.
If the user presses Cancel or the print function fails, then an error message
is displayed.

string 1s filename = ""
integer 1li_num copies = 0
integer 1i_return
li_return = f_dw_print (dw_sheet, &

1li_num copies, ls_filename)
IF 1li_return = -1 THEN

MessageBox("Print Error", &

"User pressed Cancel or an error occured")

END IF

f print_file
w_dw_print_options
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f_dw_set _color

f dw_set color

Description

Library

Syntax

Return value

Usage

Example

See also

228

Sets values in the specified column to the color designated in the parameter
colortrue if the expression is evaluated to be TRUE. Otherwise, the column
value is set to the color designated in the parameter colorfalse.

& For a list of color values, see the PowerBuilder Function Reference.
UTLFUNC.PBL

f_dw_set_color ( dwcontrol, column, expression, colortrue,

colorfalse)

Parameter Description

dwcontrol DataWindow variable pointing to the DataWindow control
containing the column whose color will be modified

column String containing the name of the database column whose color
will be modified

expression String expression to be evaluated

colortrue Long representing the color used if expression is TRUE

colorfalse Long representing the color used if expression is FALSE

None

Use this function to selectively highlight values in a DataWindow.

Use the RGB function
Use the PowerBuilder RGB function to name the color.

This example changes the color of column PRICE in dw_1 from black to
red when its value is greater than 100.

f _dw_set_color(dw_1, "PRICE", "PRICE > 100", &
RGB(255,0,0),RGB(0,0,0))

f dw_set_color_row
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f dw_set color row

Description

Library

Syntax

Return value

Usage

Example

See also

Sets all columns on the row to the color designated in the colortrue
parameter if the passed expression is TRUE. Otherwise, the row color is set
to the value in colorfalse.

&~ For a list of color values, refer to the PowerBuilder Function
Reference.

UTLFUNC.PBL

f_dw_set_color_row ( dwcontrol, expression, colortrue,

colorfalse)
Parameter Description
dwcontrol DataWindow variable pointing to the DataWindow control

containing the column whose color will be modified

expression String expression to be evaluated

colortrue Long representing the color used if expression is TRUE
colorfalse Long representing the color used if expression is FALSE
None

Use this function to selectively highlight rows in a DataWindow.

Use the RGB function
Use the PowerBuilder RGB function to name the color.

This example sets the row to red if the field ACTIVITY is equal to SALE;
otherwise, the color is set to green.
f_dw_set_color_row (dw_1, "IF ACTIVITY = 'SALE'", &
RGB(255,0,0), RGB(0,255,0))

f dw_set_color
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f_error_box

f error_box

Description

Library

Syntax

Return value

Usage

Example

See also
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Opens the window w_error_box, which displays the title and error message
passed from f_error_box.

The w_error_box window is non-modal window, which means that it can
remain open while the user performs other actions associated with the
application.

UTLWIN.PBL

f_error_box ( windowtitle, errormessage)

Parameter | Description

windowtitle String containing w_error_box window title. Usually contains
the title of the window in which the error occurred.

errormessage String containing the error message to be displayed.

None

This global function is typically called from the DBError event of a
DataWindow control.

For an example, see the DBError event for the uo_dw DataWindow user
object found in SYS.PBL.

This example opens window w_error_box in the Clicked event of a print
commandbutton if the PrintOpen function fails.
IF PrintOpen( ) = -1 THEN
f_error _box(parent. title, &

"Error in clicked event of object cb_print")
END IF

f db_error

f debug_box
w_db_error
w_debug_box
w_error_box
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f exit status

Description Opens the window w_exit_status, which allows the user to choose the
action to be taken if the modified data has not been saved.

Library UTLWIN.PBL
Syntax f_exit_status ( windowtitle, saveormove )
Parameter Description
windowtitle String specifying w_exit_status window title. Usually contains

the title of the window to be closed.

saveormove String indicating whether data will be lost due to closing a
window or moving from a DataWindow row in which data has
been changed for the row:

¢ S - Unsaved changes will be lost because the window is
closing

¢ M - Unsaved changes will be lost because the user is
moving from a DataWindow row with unsaved changes

Return value One of the following single-character string values: S — save data and then
close the window; E — close the window without saving; C — Cancel the
request.

Usage In a window's CloseQuery event, check to see if any changed data has not

been saved to the database. If there is unsaved data, use this function to let
the user determine how to proceed.

Example This example checks to see if data has been modified on the window and
not saved. If TRUE, use the f_exit_status function to open w_exit_status
and prompt the user to determine if information should be saved.

string ls_status

IF ModifiedCount(dw 1) <> 0 THEN
ls_status = f_exit_status(this.title, "s")

END IF
CHOOSE CASE 1s_status
CASE "s"
// Save data and close the window.
CASE "E"

// Close the window without saving.
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f_get_parm

See also

f _get_parm

Description

Library

Syntax

Return value

Usage

Example

See also

232

CASE "C"
// Cancel request; return to window.
END CHOOSE

w_exit_status

Returns the value that corresponds to the passed variable name.

The main purpose of this window (to pass parameters when opening and
closing windows) has been replaced with the functionality provided by
OpenWithParm and CloseWithReturn functions. Global function
f_get_parm has been retained for backward compatibility.

UTLFUNC.PBL

f_get_parm ( variable )

Parameter | Description

variable ‘ String whose value is to be returned

String. If nothing is found, it returns NULL.

This function, which is provided for backward compatibility, can be used
in place of global variables when communicating between objects. New
applications should use OpenWithParm and CloseWithReturn instead.

This example retrieves a DataWindow based on the value stored in the
string instance variable is_state_name.

Retrieve(dw location_info, &
f_get_parm (is_state_name))

f_pop_parm

f push_parm
f_set_parm
w_hold_parms
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f_get_string

Description

Library

Syntax

Return value
Usage

Examples

Opens the response window w_get_string, which allows the user to enter
the requested information. It returns a string containing the information
the user entered on window w_get_string.

UTLWIN.PBL

f_get_string ( windowtitle, maxlength, caseindicator, currentvalue )

Parameter Description

windowtitle String indicating the title to be used in w_get_string.

maxlength Integer specifying the maximum number of characters that can
be entered.

caseindicator | Single-character string indicating the case of the string to be
entered: U — Uppercase, L — Lowercase, A — Any case.

currentvalue Optional string containing the current value of what is to be
modified.

String
Use this function to prompt the user for a string value.

This example prompts the user for a string 40 characters long and
uppercase only. The title of w_get_string will be equal to the title of the
calling window.
string 1s_string
ls_string = &
f_get_string (parent.title,40,"U",1ls_string)

This example prompts the user for multiple strings different in length and
case type. The title of the new window opened is equal to the information
being requested.

string 1ls_custnum, ls_dept, 1ls_custname

ls_custnum = &
f_get_string("Customer number",8,"U",ls_custnum)
ls_dept = f_get_string("Department"”, 4, "U",ls_dept)
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1ls_custname = &
f_get_string("Customer name", 40,
"A",1s_custname)

See also w_get_string

f_get_token

Description Returns the token from a passed string. This function receives as
arguments a string from which the token is to be removed (from the left)
and the separator character.

What is a token?
A token is a collection of characters separated by a delimiter.

If the separator character appears in the string, the function returns the
token, not including the separator character. If the separator character does
not appear in the string, the function returns the entire string. In either
case, the source string is truncated on the left by the length of the token
and separator character, if any.

Library UTLFUNC.PBL

Syntax f_get_token ( sourcestring, separatorstring )
Parameter | Description
sourcestring String to be parsed. It is passed by reference.
separatorstring String containing the separator character(s).

Return value String. Returns the token if separatorstring is found within sourcestring

and returns the entire sourcestring if separatorstring is not found.

Usage Use this function to break up strings with embedded values into separate
strings.
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Example This example calls function f_get_token to break out the information
returned from f_dw_get_attributes.

string results
integer 1i x, 1li_ y
boolean 1b_visible

results = &
f_dw_get_attributes(dw_1,'au_id', 'x,y,visible')

1li_x = integer(f_get_token(results,'~n'))
li y = integer(f_get_token(results,'~n'))
1b_visible = f_string to_boolean(results)

See also f dw_get_attributes

f_global_replace

Description Replaces all occurrences of a string in one string with another string.
Library UTLFUNC.PBL
Syntax f_global_replace ( source, lookfor, replacewith )

Parameter | Description

source ’ String to be searched

lookfor String to be found

replacewith String used to replace lookfor
Return value String that includes the substituted value.
Usage Use this function to substitute one value for another in a string.
Example This example replaces all occurrences of red in string1 with green.

string results, stringl

results = f_global_replace (stringl,'red', 'green')
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f _invert_color

Description
Library

Syntax

Return value

Usage

Example

See also
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Returns the inverse of the color passed.
UTLFUNC.PBL

f_invert_color ( colorvalue )

Parameter | Description

colorvalue Long representing the value of the color whose inverse is
returned by the function

& For alist of color values, refer to the PowerBuilder Function
Reference.

Long specifying the inverse color.

Use this function to determine the inverse of a passed color.

Use the RGB function
Use the PowerBuilder RGB function to name the original color.

This example sets the column to the inverse of the current color, green,
when the local field li_price is larger than 1000.

long 11 inverse_color, 1l _current_color

11 current_color = RGB (0,128, 0)
11 inverse_color = f_invert_color (1ll_current_color)

f dw_set_color(dw_1, "PRICE", "PRICE > 1000", &
11_inverse_color, 1l _current_color)

f dw_set_color
f dw_set_color_row
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f_julian
Description

Library

Syntax

Return value

Usage

Example

Converts a date from Date format (for example, 1994-06-29) into julian
format (for example, 1994-180)

UTLFUNC.PBL

f_julian ( date, julianyear, julianday )

Parameter Description

date Date from which julian date is to be calculated.

julianyear Integer into which f_julian returns the year portion of the julian
date. This value is passed by reference.

julianday Integer into which f_julian returns the day number. This value

is passed by reference.

String containing year - day, for example, 1994 - 230.

Use this function to calculate a julian date (such as, 1994-180) from a date
in Date format (such as, 1994-06-29).

This example calculates the julian date for June 29, 1994. It returns 7994-
180 into the Is_julian_all field; 7994, into the li_julian_year field; and 180
into the li_julian_day field.

string ls_julian_all
integer 1i_julian year, 1li_julian_day
date 1d_date_in

1d_date_in = Date("1994-06-29")

1s_julian_all = £_julian(ld_date_in, &
1i_julian_year,1li_julian day)
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f_login

Description

Library

Syntax

Return value

Usage

Example

See also
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Opens window w_login, which prompts the user to log in to the
application. The user must supply a user ID and password. The global
function passes an INI file (usually the application's) as a parameter to
w_login and is typically used in the application or main window's Open
event.

UTLWIN.PBL

f_login ( iniflename)

Parameter | Description

inifilename The path and complete name of the INI filename associated
with the current application. The INI file contains specific
DBMS information used for connecting to the database.

Boolean. Returns TRUE if the login succeeded and FALSE if it did not.

Use this function for database login. The INI file provides database
connection information. A sample INI file is shown below:

;Setup for SQLCA

[Databasel]

DBMS=0DBC

Logld=

LogPassword=

ServerName=

Database=HOTLINE

UserId=dba

DatabasePassword=
DbParm=Connectstring='DSN=HOTLINE; UID=DBA; PWD=SQL

This example call the f_login function in the Open event of the frame
window. If the user is unable to log in, the application closes.
IF NOT £_login("c:\pubs\pubs.INI") THEN

halt close
END IF

w_login
w_sys_frame
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f_lookupcode

Description

Library

Syntax

Return value

Usage

Example

See also

Returns the code value associated with the passed display value for a
dropdown DataWindow column.

UTLFUNC.PBL

f_lookupcode ( dwcontrol, displayvalue, columnname )

Parameter Description

dwcontrol DataWindow variable of the DataWindow control containing
the column

displayvalue String containing the display value

columnname String containing the name of the column for displayvalue

String containing the code value that corresponds to displayvalue.

Use this function for two purposes:

¢ To determine the code value (typically the value that is actually stored
in the database) that corresponds to a dropdown DataWindow value
without scrolling the dropdown DataWindow.

¢ To ensure that a user-specified value has a corresponding code in the
dropdown DataWindow.

This example returns the 2-character state code that corresponds to the
Is_state value.

string 1s_code
string 1s_state = "Minnesota"
ls_code = f_lookupcode ( dw_sheet,ls state,"state" )

f lookupdisplay
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f_lookupdisplay

Description

Library

Syntax

Return value

Usage

Example

See also
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Returns the current display value associated a particular row and column.
This function works with dropdown DataWindows, dropdown listboxes,
and radiobuttons.

UTLFUNC.PBL

f_lookupdisplay ( dwcontrol, rownumber, columnname )

Parameter Description

dwcontrol DataWindow variable of the DataWindow control containing
the column

rownumber Integer indicating the row that contains the code value

columnname String indicating the column that contains the code value

String containing the display value for the code specified by rownumber
and columnname.

Use this function to determine the display value for a particular row and
column.

This example returns the display value for the 2-character state code.

string 1s_display
long 11_rownum

11_rownum = dw_sheet.GetRow()
1s_display = &
f_lookupdisplay ( dw_sheet, 11 _rownum, "state")

f lookupcode
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f_maillogoff

Description
Library

Syntax

Return value
Usage

Example

See also

f_maillogon

Description
Library

Syntax

Ends a mail session.
UTLFUNC.PBL

f_maillogoff ( mailsession)

Parameter | Description

mailsession MailSession variable identifying the session from which you
want to log off

None
Use this function to end an e-mail session.

This example ends the ims_sess (instance variable) e-mail session.

f maillogoff ( ims_sess )
f_maillogon

f_mailsend
f mailsendnoaddress

Starts a mail session.
UTLFUNC.PBL

f_maillogon (mailsession )

Parameter | Description

mailsession MailSession variable identifying the session you want to log on
to. This variable is passed by reference.

241



f_mailsend

Return value
Usage

Example

See also

f mailsend

Description

Library

Syntax

242

Boolean. Returns TRUE if the function succeeds and FALSE if it does not.
Use this function to establish a new mail session.

This example establishes a new mail session, storing the MailSession in
the ims_sess instance variable.

IF NOT £f_maillogon (ims_sess) THEN
MessageBox("Logon Failed","E-mail logon failed")
END IF

f maillogoff
f mailsend
f mailsendnoaddress

Sends mail to the specified recipients. This function will create a mail
session automatically if no current mail session exists.

UTLFUNC.PBL

f_mailsend ( recipients, cc, mailsession, subject, notetext, filename,
pathname, mailmessage, returnreceipt, framewindow)

Parameter Description

recipients Unbounded string array naming message recipients. The names
in this array must be valid names within your e-mail system.

cc String specifying either yes (display CC dialog box) or no
(don't display the CC dialog box)

mailsession MailSession variable identifying the session you want to use.
This variable is passed by reference.

subject String containing the message subject.
notetext String containing the body of the message.
filename Unbounded string array whose elements specify the names of

files attached to the message.
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Parameter Description

pathname Unbounded string array whose elements specify the
corresponding path names of files attached to the message. For
example, the first element in the pathname array specifies the
path for the first element in the filename array, and so on.

mailmessage MailMessage variable that will be used by the function. This
variable is passed by reference.

returnreceipt Boolean specifying whether you want confirmation that the
message was received.

framewindow Window variable specifying the frame window.
Return value Boolean. Returns TRUE if the function succeeds and FALSE if it does not.
Usage Use this function to send a message.

PowerBuilder supports MAPI-compliant e-mail systems
PowerBuilder supports MAPI (messaging application program
interface). You can use the Application Library's e-mail functions with
an MAPI-compliant electronic mail system. Microsoft Mail is an
example of a MAPI-compliant electronic mail system.

Example This example sends a mail message for the mail session contained in the
ims_sess instance variable.

mailMessage lmm_message

string ls_to[], 1ls_subject, 1ls_text, 1ls files[]
string 1s_path[], 1ls_cc

boolean 1lb_returnreceipt, 1lb_return

window 1lw_frame

lw_frame = This.ParentWindow()
1ls_subject = This.sle_subject
1s_text = This.mle_messagetext
lb_returnreceipt = This.cbx_returnreceipt.Checked

... // Logic to access recipients goes here.
... // Populates ls_to[] array

... // Logic to access specified files and
... // pathnames goes here.
... // Populates ls_files[] and 1ls_path[] arrays.

IF NOT f mailsend ( 1ls_to, ls _cc, ims_sess, &

ls_subject, ls_text, 1ls_files, 1ls_path, &
lmm message, lb_returnreceipt, lw_frame ) THEN
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f_mailsendnoaddress

See also

MessageBox("Failure", "Couldn't send message.")
END IF

f_maillogon
f_maillogoff
f_mailsendnoaddress

f mailsendnoaddress

Description

Library

Syntax
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Sends mail to unknown recipients. This function results in the display of
the e-mail system's address book, which prompts the user for the names of
recipients. It will also create a mail session automatically if no current mail
session exists.

UTLFUNC.PBL

f_mailsendnoaddress ( mailsession, subject, notetext, filename,
pathname, mailmessage, returnreceipt, framewindow )

Parameter Description

mailsession MailSession variable identifying the session you want to use.
This variable is passed by reference.

subject String containing the message subject.
notetext String containing the body of the message.
filename Unbounded string array whose elements specify the names of

files attached to the message.

pathname Unbounded string array whose elements specify the
corresponding path names of files attached to the message. For
example, the first element in the pathname array specifies the
path for the first element in the filename array, and so on.

mailmessage MailMessage variable that will be used by the function. This
variable is passed by reference.

returnreceipt Boolean specifying whether you want confirmation that the
message was received.

framewindow Window variable specifying the frame window.
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Return value Boolean. Returns TRUE if the function succeeds and FALSE if it does not.

Usage Use this function to send mail and allow the user to specify recipients
through the e-mail system's address book.

Example This example sends a mail message for the mail session contained in the
ims_sess instance variable.
mailMessage lmm message
string 1s_subject, 1ls_text, 1ls_files][]
string ls_path[]

boolean 1b_returnreceipt, lb_return
window 1lw_frame

lw_frame = This.ParentWindow()
1ls_subject = This.sle_subject
ls_text = This.mle_messagetext
1lb_returnreceipt = This.cbx_returnreceipt.Checked

// Logic to access specified files and
// pathnames goes here.
// Populates ls_files[] and ls_path[] arrays.

IF NOT f_mailsendnoaddress (ims_sess, ls_subject, &
ls_text, ls_files, ls_path, lmm message, &
lb_returnreceipt, lw_frame ) THEN

MessageBox("Failure", "Couldn't send message.")

END IF

See also f maillogon

f_maillogoff
f_mailsend

f_parsedisplaydata

Description Separates the display~tcode values of an EditMask control or RadioButton-
style column.

Library UTLFUNC.PBL
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f_parseleftright

Syntax

Return value
Usage

Example

See also

f_parsedisplaydata ( initialstring, displaycodearray )

Parameter | Description

initialstring String containing the value to be parsed.

displaycodearray | Two-dimensional string array to contain the separated
values. The bounds of this array must be [100,2]. This
variable is passed by reference.

Integer indicating the number of rows in displaycodearray.
Use this function to separate tab-delimited strings.

This example uses the f_parsedisplaydata function to separate the values in
the code table for the status column.

integer 1li rows
string ls_original, 1s_displayvalues[100,2]

is_original = dw_1.Describe("status.values")
1li_rows = &
f_parsedisplaydata(ls_original,ls_displayvalues)

f parseleftright
f parsestringintoarray

f_parseleftright

Description

Library

Syntax
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Returns everything to the left of the delimiter into one string and
everything to the right of the delimiter into another string.

UTLFUNC.PBL

f_parseleftright ( initialstring, delimiter, leftstring, rightstring )

Parameter | Description

initialstring ‘ String containing the value to be parsed.
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Parameter Description
delimiter String containing the delimiter used to separate initialstring.
leftstring String to contain the characters to the left of delimiter. This

variable is passed by reference.

rightstring String to contain the characters to the right of delimiter. This
variable is passed by reference.

Return value Integer. Returns 7 if delimiter was found in initialstring and -1 if it was
not.

Usage Use this function to separate a two-part string into two separate strings.

Example This example separates the result of a GetObjectAtPointer function.

integer 1li return
string ls_original, 1ls_left, ls_right
string 1ls_delimiter = "~t"
ls_original = dw_sheet.GetObjectAtPointer()
1li_return = &
f_parseleftright(ls_original, 1i_delimiter, &
1s_left, 1s_right)

See also f parsedisplaydata
f parsestringintoarray

f_parsestringintoarray

Description Separates a string into an array, based on the passed delimiter.

Library UTLFUNC.PBL

Syntax f_parsestringintoarray ( initialstring, delimiter, stringarray )
Parameter | Description
initialstring String containing the value to be parsed.
delimiter String containing the delimiter used to separate initialstring.
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f_pop_parm

Return value

Usage

Example

See also

f_pop_parm

Description

Library

Syntax
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Parameter | Description

stringarray Unbounded string array to contain the separated values. This
variable is passed by reference.

Integer indicating the number of rows in stringarray.

Use this function to convert output from the Describe function into
elements in an array.

This example separates the string returned by a Describe function.
integer 1li_num_rows
string ls_original, ls_delimiter = "~t"
string 1ls_elements] ]
ls_original =
dw_sheet.Describe("DataWindow.Objects")
1i_num_rows = &
f_parsestringintoarray(ls_original,ls_delimiter &
1s_elements )

f_parsedisplaydata
f parseleftright

Removes a value from the parameter stack that is contained in the window
w_hold_parms. You insert values into the stack array using the
f push_parm function.

The main purpose of this window (to access passed parameters when
opening windows) has been replaced with the functionality provided by
OpenWithParm and CloseWithReturn functions. Global function
f_pop_parm has been retained for backward compatibility.

UTLFUNC.PBL

f_pop_parm ()
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Return value

Usage

Example

See also

String value of the element on the top of the stack.

This function is provided for backward compatibility. New applications
should use the OpenWithParm and CloseWithReturn functions instead.

Note
To use this function, you must open the w_hold_parms window in the
application's Open event.

This example uses one window to select parameters needed for retrieving
information. These values are pushed on the parameter stack so that the
window that will display the detail information can have access to the
parameters needed for the retrieval.

The selection window pushes the values for li_ref num, li_product_id,
Is_activity, 1d_date, and Is_state_code onto the parameter stack. These
values are needed for the retrieval of the DataWindow dw_1, which is on
the detail information window.

Script in Selection Window

f push _parm (string(li_ref num))

f push_parm (string( li_product_id ))
f push_parm (ls_activity )

f push_parm (string(ld_date, mm-dd-y ))
Open(w_information)

Script in the w_information Window
1li new date = date (f_pop_parm ())
1i new_activity = f_pop_parm ( )
1li new product_id = integer (f_pop_parm ())
1li new ref num = integer(f_pop_parm ())
Retrieve(dw_1, 1li_new ref num, li_new product_id, &
1li_new_activity, li_new_date)

f get_parm

f push_parm
f set_parm
w_hold_parms
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f_print_file

f_print_file

Description Sends the specified file to the default printer.
Library UTLFUNC.PBL
Syntax f_print_file ( printfilename )
Parameter [ Description
printfilename String containing the fully qualified name of the file to be
printed
Return value Boolean. Returns TRUE if the function succeeded and FALSE if it did not.
Usage Use this function to print a text file.

It is assumed that the file to be printed is composed of plain ASCII text
with normal end-of-line characters (carriage return, line feed).

Example This example prints the file named in the string instance variable
is_filename. If the print fails, then an error message is displayed.

string is_filename

IF not f_print_file (is_filename) THEN
MessageBox("PRINT ERROR", &
"An error occured during the printing of " &
+ is_filename + ".")
END IF

f_promptforcriteria

Description Allows you to enable or disable the Prompt for Criteria dialog box for
specified columns

Library UTLFUNC.PBL

Syntax f_promptforcriteria ( dwcontrol, columnnames, yesno )
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Return value
Usage

Example

Parameter Description

dwcontrol DataWindow variable of the DataWindow control containing
the columns to be returned

columnnames Unbounded string array containing the names of columns
affected by the function

yesno String specifying either yes (enable prompt for criteria) or no
(disable prompt for criteria)

Integer. Returns / if the function succeeds and -7 if it does not.
Use this function to control display of the Prompt for Criteria dialog box.

This example enables display of the Prompt for Criteria dialog box for the
emp_id column.

integer 1li_return
string ls_cols[]

1s_cols[1l] = "emp_id"

1li_return = &
f_promptforcriteria ( dw_sheet, 1ls_cols, "YES" )

f_push_parm

Description

Library

Syntax

Adds a string value to the parameter stack that is contained in the window
w_hold_parms.

The main purpose of this window (to pass parameters when opening and
closing windows) has been replaced with the functionality provided by
OpenWithParm and CloseWithReturn functions. Global function
f_push_parm has been retained for backward compatibility.
UTLFUNC.PBL

f_push_parm ( newstackvalue )
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f_referential_int

Return value

Usage

Example

See also

Parameter ] Description

newstackvalue String containing the value to be added to the parameter
stack

None

This function is provided for backward compatibility. New applications
should use the OpenWithParm and CloseWithReturn functions instead.

Note
To use this function, you must open the w_hold_parms window in the
application's Open event.

This example uses f_push_parm to pass title and the error message to an
error handling routine from the window that had the error.

string ls_title, ls_message

ls_title = " OPEN WINDOW EVENT "

ls_message = "Error in the Open window event."
f _push_parm (1ls_title)

f_push_parm (ls_message)

f get parm
f pop_parm
f set_parm
w_hold_parms

f referential _int

Description

Library

Syntax

252

Allows you to determine referential integrity based on a passed SQL
statement. Use it for databases that do not support referential integrity.

UTLWIN.PBL

f_referential_int ( sqlstatement, inputparm )
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Return value

Usage

Example

Parameter Description

sqlstatement String containing the SQL statement used to determine the
referential integrity

inputparm String containing the variable value used by the SQL statement

Long. Returns the number of rows retrieved and -1 if there was an error
executing the statement.

Call this function before allowing the user to delete a row from a
DataWindow. For example, you might use this function to ensure that no
employees exist in a department before deleting the department.

This example determines if any records exist in the EMPLOYEE table
where the DEPT _ID is equal to the passed value. If an error is found with
the SQL, the function returns -1; otherwise, it returns the number of
employee rows found. If the number of rows is greater than 0, there is a
referential integrity problem and the delete is disallowed.

string ls_sql_statement, ls_value
long 11 rows

1ls_sgl_statement = &

"Select * from EMPLOYEE where DEPT ID = ?"
ls_value = "400"
11_rows=f_referential_int(ls_sql_statement,
1ls_value)

CHOOSE CASE 11 _rows
CASE -1
f _error_ box("SQL Error", &
"SQL Error in f_referential_integrity
function")
CASE 0
DeleteRow()
CASE >0
f error_box("Integrity Error", &
"Referential Integrity Violation: " &
+ "Department still has employees.")
END CHOOSE
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f_retrieve_dddw

f retrieve dddw

Description
Library

Syntax

Return value

Usage

Example

Retrieves rows for a specified dropdown DataWindow column.
UTLFUNC.PBL

f_retrieve_dddw ( dwcontrol, columnname, transactionobject )

Parameter Description

dwcontrol DataWindow variable of the DataWindow control that
contains the dropdown DataWindow

columnname String specifying the name of the column that contains the
dropdown DataWindow

transactionobject | Transaction variable specifying the transaction object

Boolean. Returns TRUE if the function succeeds and FALSE if it does not.

Call this function in a window's Open event to retrieve rows for a
dropdown DataWindow.

This example retrieves data for the dropdown DataWindow that contains
the state column.
IF NOT f_retrieve_dddw(dw_sheet, "state",SQLCA) THEN

MessageBox("Retrieve", "Retrieval error: state")
END IF

f_right_justify

Description

Library

254

Returns a string of specified length that is right justified, by adding spaces
to the left of the original string. If the string is longer than the requested
length, the original string is returned.

UTLFUNC.PBL
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Syntax

Return value

Usage

Example

f_right_justify ( originalstring, length )

Parameter | Description

originalstring | String to be right-justified

length Integer representing the length of the string

String containing the right-justified value.

Use this function to right-justify a string that contains numbers.

This global function is necessary when printing information because the
String function does not provide the capability to format numbers or to
right-justify strings.

This example shows how to right-justify the value of the variable li_foo in
a 10-character field.

string ls_output

integer 1i_foo

1li_foo = 100

1ls_output = string(li_foo)

// Right-justify in a l10-character variable.

1s_output = f_right_justify(ls_output,10)

f select data

Description

Library

Syntax

Opens the w_dw_select window, which allows a user to select a row from a
DataWindow. The information from the selected row is passed back to the
calling window. The data displayed by the w_dw_select window is
determined by the SQL statement that you pass to the function. The
function uses this SQL statement to create a DataWindow dynamically.

UTLWIN.PBL

f_select_data ( sq/, title, columns, dwcontrol, row, autoquery )
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Return value

Usage

Example
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Parameter Description

sql String containing SQL statement used to build a
DataWindow.

title String containing title for w_dw_select window.

columns String specifying column mapping. Composed of one or
more pairs of column names from the calling DataWindow
equated to a column number in the passed SQL statement.
This mapping defines which columns in the calling
DataWindow will be updated.

dwcontrol DataWindow variable identifying the DataWindow control
that is to be updated when the user selects a row in the
selection window.

row Long identifying the DataWindow row that is to be updated
when the user selects a row in the selection window.

autoquery Boolean indicating whether to automatically retrieve the
data in the selection window (TRUE) or allow the user to
enter retrieval criteria (FALSE).

None

You typically use this global function to allow users to double-click in a
DataWindow and display a popup selection list from which they can select
rows to be returned to the calling DataWindow.

Use the following code in the DoubleClicked event of a DataWindow. It

displays a select list in the w_dw_select window based on the contents of
the title table, allows the user to enter retrieval arguments (query_mode),
and then selects one of the displayed rows. Then it moves the data from the
selected row back into the calling DataWindow at the row that was double-
clicked. Columns title_id, title, price, ytd_sales, and type are filled with

new values.
string col_name
long row
col_name = GetObjectAtPointer()
col_name = f_get token(col_name,"~t")
IF col_name = 'title id' THEN

row = GetClickedRow()
f_select_data ("SELECT title id,title, price,&
ytd_sales, type FROM titles", &
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"Select Title", "title_id=1, title=2,
price=3,&

ytd sales=4, type=5", this,row, false )
END IF

See also w_dw_select

f set_menu_branch

Description Sets the attributes of all items under a give menu branch to a given state.
Library UTLFUNC.PBL
Syntax f_set_menu_branch ( menubranch, operation )
Parameter Description
menubranch Menu variable of the branch whose menu items will be
affected
operation String specifying the operation to perform on all menu items
under menubranch:
¢ Check
¢ Uncheck
¢ Enabled
¢ Disabled
¢ Visible
¢ Invisible
Return value Integer indicating the number of menu items that were modified.
Usage Call this function to set all menu items under a menu parent to the same
state.
Example This example calls the f_set_menu_branch function and set all items under

the Actions menu be disabled.

f_set_menu_branch(m_share.m_topicactions,"disabled")
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f_set_parm

Description

Library

Syntax

Return value

Usage

Example

See also

258

Adds or updates the w_hold_parms DataWindow using the value of the
passed parameter.

The main purpose of this window (to pass parameters when opening and
closing windows) has been replaced with the functionality provided by
OpenWithParm and CloseWithReturn functions. Global function
f_set_parm has been retained for backward compatibility.

UTLFUNC.PBL

f_set_parm ( itemindicator, itemvalue )

Parameter | Description

itemindicator String representing the item in the stack that will be added or
updated

itemvalue String containing a value for itemindicator

None

This function is provided for backward compatibility. New applications
should use the OpenWithParm and Close WithReturn functions instead.

Note
You must open the w_hold_parms window in the application's Open
event.

This example sets the item PRODUCT_NAME to Jet Fuel in the
parameter stack.

f_set_parm(PRODUCT NAME, "Jet Fuel")

f get parm

f pop_parm

f push_parm
w_hold_parms
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f_set_sqlca

Description Opens the window w_set_sqlca, which allows the user to enter SQLCA-
specific DBMS information.

Library UTLWIN.PBL

Syntax f_set_sqlca ()

Return value None

Usage This function is typically called in the Open event of the application object
when there is no initialization information available to the application. Use
it as an alternative method of establishing database connection
information.
This function is best used in the development and testing environment.
Other methods (such as establishing an application INI file) are preferred
in the production environment since they do not require the user to enter
database-specific information.

Example This example calls the f_set_sqlca global function.

f _set_sqlca()
See also w_set_sqlca

f sort_order

Description Displays the passed DataWindow in the w_sort_order window, which
allows the user to control DataWindow sort order.

Library UTLWIN.PBL

Syntax f_sort_order ( datawindowname, sortcolumns)
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f_string_to_boolean

Return value

Usage

Example

See also

Parameter Description

datawindowname DataWindow variable indicating the DataWindow for
which the sort order is specified.

sortcolumns String containing the possible sort columns on the
DataWindow that a user can choose. Use the format
heading:column name,heading:column name,
heading:column name.

You can pass up to 10 columns that the user may specify to
sort. If the DataWindow is already sorted, the sort window
will display the current sort order.

Boolean. Returns TRUE if it succeeds and FALSE if it fails.

Use this function as a way of allowing users to control DataWindow sort
order.

DataWindow should not use grouping
Unpredictable results can occur if the DataWindow to be sorted contains

grouping.

This example opens the window w_sort_order, which allows the user to
choose from the columns in dw_1 (employee name, department, and
employee number) to sort in either ascending or descending order. The
user can choose more than one sort column.

f_sort_order(dw_l, "Employee Name:emp name," &

+ "Department:dept named,Employee
Number:emp num")

w_sort_order

f_string_to_boolean

Description

260

Returns a boolean value denoting TRUE or FALSE based on the specified
string.
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Library

Syntax

Return value

Usage

Example

See also

f time_diff

Description

UTLFUNC.PBL

f_string_to_boolean (evaluationvalue )

Parameter | Description

evaluationvalue String containing the value to evaluate. This value can be
in either uppercase or lowercase.

Boolean. Returns TRUE if evaluationvalue starts with T or Y and FALSE
if it does not.

Use this function to convert strings into boolean values.

This example uses the f_string_to_boolean function to convert the visible
attribute to a boolean data type. The two f_get_token functions strip off the
beginning of the results variable, leaving the visible attribute remaining.
This contains a string with either "TRUE" or "FALSE" and
f_string_to_boolean sets the Ib_visible variable to the appropriate boolean
value.

string results
integer 1i_x, 1li_y
boolean 1lb_visible

results = &
f dw_get attributes(dw_1,'au_id','x,y,visible’)

1li x = integer(f_get_token(results,'~n'))
li y = integer(f_get_token(results,'~-n'))
1b_visible = f_string_to_boolean(results)

f boolean_to_string
f dw_get_attributes
f get_token

Calculates the difference in milliseconds between two times and returns the
difference.
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f_wait_for

Library UTLFUNC.PBL
Syntax f_time_diff ( starttime, endtime )
Parameter | Description
starttime Time variable containing a valid time that you want to be the

beginning time

endtime Time variable containing a valid time that you want to be the
end time
Return value Ulong containing the difference in milliseconds between the two times.
Usage You might find this function useful in performance profiling.
Example This statement sets the value of lu_diff to five milliseconds.

time 1t _start, 1lt_end
ulong lu_diff

lt_start = 10:00:00
1t_end = 10:00:05
lu_diff = f_time_diff(lt_start,lt_end)

f_wait_for

Description Opens the response window w_wait_for, which checks every three seconds
to determine if a file has appeared or disappeared. This function causes the
PowerBuilder script to wait until the application has completed.

Library UTLWIN.PBL

Syntax f_wait_for ( filename, appeardisappear)
Parameter | Description
filename String containing the name of the file. If filename is not on

the current application library search path, enter the fully
qualified name.
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Return value

Usage

Example

See also

f write file

Description
Library

Syntax

Parameter Description

appeardisappear Boolean variable indicating whether to wait for file to

appear or to disappear:
¢ TRUE — Wait for the named file to appear
¢ FALSE — Wait for the named file to disappear

Boolean. TRUE indicates that the file appeared or disappeared as specified
in appeardisappear. and FALSE indicates that the user clicked the Cancel
button on the w_wait_for window.

Use this function to serialize the running of external applications or when
your application depends on the presence or absence of a particular file.

This example runs a process named work.pif, which writes a file named
done.xxx when it is completed. The script will resume running when this
file appears.

boolean status

// Make sure that the semaphore file does not exist.
FileDelete( 'done.xxx"')
Run("work.pif")
// Wait for the file 'done.xxx' to appear.
status = f_wait_for('done.xxx',TRUE)
IF NOT status THEN
// Error on DOS process or user canceled.
END IF

w_wait_for

Writes the passed string to the designated filename.
UTLFUNC.PBL

f_write_file ( filename, writestring, writemode )
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f_write_log

Return value
Usage

Example

See also

f_write_log

Description

Library

Syntax

Return value

264

Parameter Description

filename String containing the fully qualified name of the file to be
written

writestring String that will be written to the filename

writemode Writemode enumerated data type (Append! or Replace!)

Boolean. Returns TRUE if the write succeeds and FALSE if it fails.
Use this function to write to a file.
This statement appends the mle_description.text to the file SPECS.TXT.
IF NOT &
f write_file("SPECS.TXT",mle_1l.text,Append!) THEN

Message box("Error ","Could not append to file")
END IF

f write_log

Appends the passed string to the end of the passed file name. It adds a
carriage control/line feed to the end of the passed string.

UTLFUNC.PBL

f_write_log ( filename, writetext)

Parameter | Description

filename String containing the fully qualified name of the file that will
have the text appended to it

writetext String containing the text to be appended to filename

Boolean. Returns TRUE if the write succeeds and FALSE if it fails.
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Usage

Example

See also

Use this function to append text to a log file.

This example appends a text string to the file namedate.log. The string
contains the name of the person and date they logged in to an application.
The name and date are values passed from the log in screen.

string ls_person_date, ls_person_name

1ls_person_name "Martha DeMers "
ls_person_date ls_person_name + String( Today() )
f_write_log ("c:\appl\namedate.log",ls_person_date)

f write_file
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Global Stru

About this chapter

str frame

Description

ctures

This chapter describes the global structures in the Application Library.

Contains application information.

Field name Data type
app_name Application
ini_file_name String
allow_multiple_apps Boolean
Library SYS.PBL
Usage This structure is used by scripts in the w_sys_frame window. You do not
typically use it in your applications.
See also w_select

w_sys_mast_detl_dw
w_sys_single_dw
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str_parms

str_parms

Description

Library

Usage

See also

268

Contains all-in-one structure arrays of simple data types.

Field name Data type
string_arg] | String
char_arg[ ] Char
int_arg] ] Integer
long_arg| ] Long
date_arg] ] Date
datetime_arg| | Datetime
time_arg| | Time
boolean_arg] | Boolean
real_arg[ | Real

decimal_arg] ]
canceled

double_arg][ ]

UTLWIN.PBL

You can use this structure in conjunction with the OpenWithParm and
OpenSheetWithParm functions to pass parameters between windows.

w_select
w_sys_mast_detl dw
w_sys_single_dw

Decimal {2}
Boolean

Double
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str_progress

Description

Library

Usage

See also

Passes parameters to window object w_progress. It contains the following
data types:

Field name | Data type
cancel_window ' Window
cancel_event ‘ String
title l String

UTLWIN.PBL

This structure is used by scripts in the w_progress window. You do not
typically use it in your applications.

W_progress

str_select_parms

Description

Library

Passes parameters to window object w_dw_select.

Field name Data type
sql String

title String
columns String

dw DataWindow
ow Long
auto_query Boolean
UTLWIN.PBL
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str_sort

Usage This structure is used by scripts in the w_dw_select window. You do not
typically use it in your applications.

See also w_dw_select
str_sort
Description Passes parameters to window object w_sort.
Field name | Data type
dw DataWindow
title String
Library UTLWIN.PBL
Usage This structure is used by scripts in the w_sort window. You do not typically

use it in your applications.

See also w_sort

str sort _order

Description Passes parameters to window object w_sort_order.
Field name | Data type
sort_info String
dw DataWindow

Library UTLWIN.PBL
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Usage This structure is used by scripts in the w_sort_order window. You do not
typically use it in your applications.

See also w_sort_order
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CHAPTER 8

Menu Objects

About this chapter

m_Dbase

Description

Library

Usage

File menu

File
Close Ctrl+F4

Quit  Alt+F4

This chapter describes the menu objects in the Application Library.

Basic ancestor menu that contains a file menu and a window menu. You
can define additional menu items in the descendent menus.

UTLWIN.PBL

Use the m_base menu object as a basic ancestor menu.

The File menu has predefined menu items that you can use to control the

window.

Menu item Description

Close Closes the current window.
Shortcut key: CTRL+F4

Quit Exits the application.

Shortcut key: ALT+F4
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m_sys_frame

Window menu

Tile Horizontal
Layer
Cascade
Arrange Icons

Tool Bar

The Window menu is a standard for MDI applications.

Menu item

Description

Cascade

Tile Horizontal

Tile Vertical

Layer

Arrange Icons

Tool Bar

m_sys_frame

Description

Library

Menu functions

274

Uses the ArrangeSheets function to cascade the sheets that
are not minimized

Uses the ArrangeSheets function to tile the sheets that are
not minimized from side-to-side

Uses the ArrangeSheets function to tile the sheets that are
not minimized one above the other

Uses the ArrangeSheets function to layer the sheets that are
not minimized

Uses the ArrangeSheets function to arrange the icons for
minimized sheets

Opens the w_set_toolbars window, which allows the user
to control toolbar display

Ancestor menu for applications that use the application framework. It
contains File, Application Topics, Actions, Window, and Help menus.

Many m_sys_frame menu items trigger user events in application
framework windows. The individual discussions note any menu items that
are particular to a single application framework window.

SYS.PBL

mf_frame Returns the frame window.

¢ Parameters. None

¢ Return value. Window.
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Usage
.
File menu
Application Topics Actions Wi
Open... Ctrl+F12
Delete
Save Shift+F12
Save As... F12
Sort
Zoom Qut
Zoom In
Query Mode
Reset Query Criteria
Print... Ctrl+Shift+F12
Print Log
Print Errors
Print Preview
Print Setup...
Close Ctrl+F4
Exit Alt+F4

mf_set_menu_item Sets the specified menu item to the specified state
and shows or hides the corresponding toolbar button.

¢ Parameters:
¢ Menu variable specifying the menu item to be enabled or disabled.

¢ Boolean specifying whether to enable (TRUE) or disable (FALSE)
the menu item.

¢ Return Value. None.

mf_set_query_mode Enables or disables query mode.

¢ Parameters. Boolean specifying whether to enable (TRUE) or disable
(FALSE) query mode.

¢ Return Value. None.

Use the m_sys_frame menu object as the top-level ancestor menu for all
windows created using the application framework..

The File menu has predefined menu items that you can use for window,
file, and database actions. Although this section documents all menu items
for the m_sys_frame File menu, you typically enable or disable items in
this menu to match the unique needs of each descendent menu.

Toolbar
Menu item Description button
New Adds a new row in the dw_sheet
DataWindow by triggering the window's
ue_filenew user event.
Open Allows the user to select a new row to display

by triggering the window's ue_fileopen user
event (ue_fileopen triggers the
ue_select_window user event, to which you
can add selection logic).

Shortcut key: CTRL+F12
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Menu item

Description

Toolbar
button

Delete

Save

Save As

Sort

Zoom Out

Zoom In

Query mode

Reset Query
Criteria

Deletes the current row in the dw_sheet
DataWindow by triggering the window's
ue_filedelete user event. This deletes the row
from the DataWindow and in some cases
deletes the row from the database. See the
ancestor window's ue_filedelete user event
for more information.

Saves all new and modified rows to the
database by triggering the window's
ue_filesave user event.

Shortcut key: SHIFT+F12

Triggers the window's ue_filesaveas user
event, which uses the SaveAs function to
save the DataWindow contents to a file.

Shortcut key: F12

Triggers the window's ue_sort user event,
which opens the w_sort window to allow the
user to specify a sort order for the multirow
DataWindow.

Triggers the window's ue_zoom_smaller user
event, which shrinks the DataWindow. This
menu item is designed to work with
descendants of w_sys_report.

Triggers the window's ue_zoom_bigger user
event, which enlarges the DataWindow. This
menu item is designed to work with
descendants of w_sys_report.

Toggles the DataWindow into or out of query
mode by triggering the window's
ue_toggle_query_mode user event. This
menu item is designed to work with
descendants of w_sys_report. The toolbar
button changes from a hand to a report in
query mode.

Resets query criteria by triggering the
window's ue_reset_query_criteria user event.
This menu item is designed to work with
descendants of w_sys_report.
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Toolbar
Menu item Description button
Print Prints the dw_sheet DataWindow by
triggering the window's ue_fileprint user
event.

Shortcut key: CTRL+SHIFT+F12

Print Log Prints the dw_msg DataWindow by triggering
the window's ue_print_log user event. Use
this menu item with descendants of
w_sys_pipeline.

Print Errors Prints the dw_pipe_errors DataWindow by
triggering the window's ue_print_errors user
event. Use this menu item with descendants
of w_sys_pipeline.

Print Preview Triggers the window's ue_fileprint_preview
user event, which opens the w_printzoom
window. This menu item is designed to work
with descendants of w_sys_report.

Print Setup Uses the PrintSetup function to display the
Printer Setup dialog box.

Close Closes the current window by triggering the
window's ue_fileclose user event.

Shortcut key: CTRL+F4

Exit Exits the application by closing the frame
window.

Shortcut key: ALT+F4

Application Topics menu

The Application Topics menu has no menu items defined. You can add
items at the descendent level when creating a new menu that is inherited
from m_sys_frame. These items are based on the application requirements
and are normally used to allow the opening of application-related sheets.

Application Topics
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Actions menu

Hm Window Help
Delete Row

Insert Detail

Delete Detail

Delete All

Sort

Execute

Repair

Cancel

Reset Log

Pipeline Type »|
Pipeline Commit After »
Pipeline Max Errors Allowed »
Pipeline Copy Extended Attributes

278

The Actions menu at the ancestor level contained predefined menu items
for use with application framework descendent windows. You can add
items at the descendent level when creating a new menu that is inherited
from m_sys_frame. These items are defined based on the application
requirements. Actions are typically dependent on the active sheet. Items
added might include opening a sheet related to the active sheet or other
specific processing.

Toolbar
Menu item Description button

Insert Row Adds a new row in the dw_sheet
DataWindow by triggering the window's
ue_filenew user event.

Delete Row Deletes the current row in the dw_sheet
DataWindow by triggering the window's
ue_filedelete user event. This deletes the row
from the DataWindow and in some cases
deletes the row from the database.

Insert Detail Adds a new row in the dw_detail
DataWindow by triggering the window's
ue_detail_new user event. Use this menu
item with descendants of the
w_sys_mast_detl_dw window.

Delete Detail Deletes the current row in the dw_detail
DataWindow by triggering the window's
ue_delete_detail user event. Use this menu
item with descendants of the
w_sys_mast_detl_dwwindow.

Delete All Deletes all rows in the dw_sheet
DataWindow by triggering the window's
ue_deleteall user event. The descendent
window is responsible for maintaining data
integrity. Use this menu item with
descendants of the w_sys_multi_dw and
w_sys_shared_dw windows.

Sort Triggers the window's ue_sort user event,
which opens the w_sort window to allow the
user to specify a sort order for the multirow
DataWindow.
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Menu item

Description

Toolbar
button

Execute

Repair

Cancel

Reset Log

Pipeline Type

Pipeline Commit
After

Pipeline Max Errors
Allowed

Triggers the window's ue_execute_pipe user
event, which executes a pipeline. Use this
menu item with descendants of the
w_sys_pipeline window.

Triggers the window's ue_repair_pipe user
event, which submits corrected rows to the
destination database. Use this menu item
with descendants of the w_sys_pipeline
window.

Triggers the window's ue_cancel_pipe user
event, which halts pipeline execution. Use
this menu item with descendants of the
w_sys_pipeline window.

Triggers the window's ue_reset_log user
event, which clears rows from the dw_msg
DataWindow. Use this menu item with
descendants of the w_sys_pipeline window.

Displays a cascading menu with a list of
pipeline types, from which you can choose
one. Pipeline types are Create, Replace,
Refresh, Append, and Update. Selecting a
pipeline type triggers the window's
ue_set_pipe_type user event. Use this menu
item with descendants of the w_sys_pipeline
window.

Displays a cascading menu with commit
frequencies, from which you can choose one.
COMMIT frequencies are All, 1, 10, 100,
and 1,000. Selecting a COMMIT frequency
triggers the window's ue_set_pipe_commit
user event. Use this menu item with
descendants of the w_sys_pipeline window.

Displays a cascading menu with a list of
pipeline types, from which you can choose
one. Max errors values are None, 1, 10, 100,
and 1,000. Selecting a max errors value
triggers the window's ue_set_pipe_maxerrors
user event. Use this menu item with
descendants of the w_sys_pipeline window.
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Toolbar

Menu item Description button
Pipeline Copy Enables or disables the copying of database
Extended Attributes | extended attributes. Selecting this option

triggers the window's ue_set_pipe_ext_attr

user event. Use this menu item with

descendants of the w_sys_pipeline window.

Window menu
Window Bl The Window menu is standard for an MDI application. Each menu item

Tile Vertical Shift+Alt+ T

Tile Horizontal Shift+Alt+H has a script to perform the required processing. These scripts are inherited
e e A by a descendent menu. The Toolbars item allows the user to manipulate the
Arrange Icons  Shift+Alt+] toolbar.
Toolbars...

Menu item Description

Tile Vertical Uses the ArrangeSheets function to tile the sheets that are

not minimized one above the other.
Shortcut key: SHIFT+ALT+T

Tile Horizontal Uses the ArrangeSheets function to tile the sheets that are
not minimized from side-to-side.

Shortcut key: SHIFT+ALT+H

Layer Uses the ArrangeSheets function to layer the sheets that
are not minimized.

Shortcut key: SHIFT+ALT+L

Cascade Uses the ArrangeSheets function to cascade the sheets
that are not minimized.

Shortcut key: SHIFT+ALT+C

Arrange Icons Uses the ArrangeSheets function to arrange the icons for
minimized sheets.

Shortcut key: SHIFT+ALT+I

Toolbars Opens the w_set_toolbars window, which allows the user
to control toolbar display.
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Help menu

Help
Contents
Search for Help On...
How to Use Help

Shift+F1

Resources

About...

The Help menu is a standard menu item and is located at the end of the
menu bar. You must add script (typically using the ShowHelp function) to
access your application-specific Windows help file.

& For an example of enabling the first three menu items, see Lesson 5,
"Building a Menu for the Frame Window" in Part Two.

Toolbar

Menu item Description button
Contents Typically used to display an application-

specific Windows Help file.
Search for Help On | Typically used to display the Search dialog

box for an application-specific Windows Help

file.
How to Use Help Typically used to display the WINHELP.HLP

file. Use the following function as an

example:

ShowHelp("winhelp.hlp", Index!)

Resources Opens the w_get_free_resources_graph

window, which display free system resources.
About Displays the w_about window. You can

override this at the descendent level to
display an application-specific About
window.
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User Objects

About this chapter

u_help_bar

Description

Library

Instance variables

User object
functions

This chapter describes the user objects in the Application Library.

Simulates a MicroHelp bar on a non-MDI frame window. You can place
this object on any non-MDI frame window.

UTLWIN.PBL

Variable Data type Access
iw_parent_window Window Public
ii_menu_ht Integer Public
ib_show_clock Boolean Public
ii_resizeable_offset Integer Public

The user object functions encapsulated in u_help_bar are:
+ Uf init, explained on page 285.

¢ Uf _resized, explained on page 285.

¢ Uf_set_clock, explained on page 286.
*

Uf_set_msg, explained on page 286.
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Usage

Examples

See also

284

You can use the u_help_bar user object to provide information to a user,
much like using the SetMicroHelp function on an MDI frame window. To
use the u_help_bar user object:

1 Add the user object control to the bottom of your non-MDI window
and optionally rename it (uo_help_bar is the recommended name).

2 In the window's Open event, call the uf_init, uf_set_msg, and
uf_set_clock (optional) user object functions. If you are displaying the
clock, also code a Timer function (60 seconds is the recommended
interval).

3 Inthe window's Resize event, call the uf_resized user object function.

4  If you are displaying the clock, call the uf_set_clock user object
function in the window's Timer event.

5 Modify the u_help_bar message as necessary by calling uf_set_msg.

In the window's Open event, add these statements:

uo_help bar.uf_init(this,TRUE)

uo_help bar.uf_set_clock()

uo_help bar.uf_set_msg("Your message here")
Timer(60,this)

In the window's Resize event, add this statement:
uo_help bar.uf_resized()

In the window's Timer event, add this statement:

uo_help_ bar.uf_ set_clock()

Use the control name, not the object name

In the parent window scripts, you use dot notation to qualify u_help_bar
user object functions with the control name (for example, uo_help_bar),
not the object name (u_help_bar).

w_mdi_clock
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uf_init

Description

Syntax

Return value

Usage

Example

uf_resized
Description

Syntax

Return value

Registers the window with the user object. It also determines its size and
placement, optionally displaying the date and time if the displaydatetime
boolean variable is TRUE.

controlname.uf_init ( windowname, displaydatetime )

Parameter Description
controlname The window control name of the u_help_bar user object.
windowname Window variable indicating the window in which to place

u_help_bar.

displaydatetime | Boolean. TRUE indicates that the date and time display on
the right hand side of the bar, FALSE indicates that data and
time do not display.

None

Call this user object function in the Open event of the parent window. You
only need to call it once.

This example calls the function uf_init and passes the window name that
the object is placed on and a boolean variable equal to TRUE.

uo_help_bar.uf_init(this, TRUE)

Places the user object on a resized window.

controlname.uf_resized ()

Parameter | Description
controlname | The window control name of the u_help_bar user object
None
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u_help_bar

Usage

Example

uf_set_clock
Description

Syntax

Return value
Usage

Example

uf_set_msg
Description

Syntax

286

Call this user object function in the Resize event of the parent window.

This statement calls the uf_resized function, which positions the user
object on the resized window.

uo_help bar.uf_resized( )

Refreshes the clock information with the current date and time.

controlname.uf_set_clock ()

Parameter | Description
controlname ‘ The window control name of the u_help_bar user object
None

Call this user object function in the Timer event of the parent window.
This example calls the uf_set_clock function.

// Refresh the displayed time and date.
uo_help_ bar.uf_set_clock()

Sets a display message on the left side of the u_help_bar user object.

controlname.uf_set_msg ( message)

Parameter [ Description
controlname The window control name of the u_help_bar user object.
message String containing the text to be displayed on the left side of the

bar. To clear the display, specify an empty string ("").
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Return value
Usage

Example

None
Call this user object function from any event script in the parent window.

This example calls the function uf_set_msg and sets the u_help_bar display
message.

string 1s_msg

ls_msg = "Updates have been applied."
uo_help bar.uf_set_msg(ls_msg)

u_mdi_clock item

Description

Library

User object
functions

Usage

Example

See also

Contains text used as a cell in the w_mdi_clock window..

UTLWIN.PBL

The user object functions encapsulated in u_mdi_clock_item are:
¢ Uf _set_text, explained on page 288.

¢ Uf_set_width, explained on page 288.

The u_mdi_clock_item is used by the w_mdi_clock window to contain the
blocks of text displayed on the right. Access u_mdi_clock_item and its user
object functions through w_mdi_clock window functions.

For examples of using u_mdi_clock_item, see the wf_add_item,
wif_del_item, and wf_set_text window functions in the w_mdi_clock
window.

w_mdi_clock
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uf_set_text
Description

Syntax

Return value

Usage

Example

uf _set width

Description

Syntax

Return value

Usage

Example

288

Sets the text contained in u_mdi_clock_item.

controlname.uf_set_text ( text)

Parameter | Description

text String variable containing the text to be displayed in
u_mdi_clock_item

None

Call this user object function to specify text to display in
u_mdi_clock_item.

For an example of uf_set_text, see the w_mdi_clock's wf_set_text window
function.

Specifies the width of u_mdi_clock_item.

controlname.uf_width ( width, alignment)

Parameter | Description
width Integer specifying a width for u_mdi_clock_item
alignment Alignment enumerated variable type specifying alignment for

u_mdi_clock_item text (center!, left!, or right!)

None

Call this user object function to specify width and alignment for
u_mdi_clock_item.

For an example of uf_set_width, see the w_mdi_clock's wf_add_item
window function.
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u_ole

Description

Library

User object
functions

Usage

uf load

Description

Syntax

Standard visual user object of type OLEControl. This user object provides
basic functions for OLE usage. Place this user object in a window instead
of an OLE 2.0 control.

U_ole is the ancestor object for the u_ole_excel and u_ole_word user
objects, explained later in this chapter.

& For information on using OLE, see Building Applications in the
PowerBuilder documentation set. For information on OLE attributes,
events, and functions, see Objects and Controls in the PowerBuilder
documentation set.

SYS.PBL

The user object functions encapsulated in u_ole are:
¢ Uf_load, explained on page 289.
¢ Uf save, explained on page 290.

¢ Uf saveas, explained on page 291.

You use the u_ole user object to load an object into an OLE control and to
save an object as a binary large object (BLOB).

Loads a file into an OLE control. This file can be a server file with an
extension that is related to an OLE server application (for example, XLS is
related to Microsoft Excel) or a binary large object (BLOB) with the OLE
extension.

olecontrol.uf_load ( filename )

Parameter | Description
olecontrol ‘ Name of the window control containing the u_ole user object
filename String naming the file to be loaded
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u_ole

Return value

Usage

Example

uf_save
Description

Syntax

Return value

Usage

290

None.

Call this user object function to load a file into an OLE control. Users can
then activate the server application using the method associated with the
control (usually double-clicking).

This example calls the uf_load function to load the Q1SALES.XLS file
into the OLE control.

ole_l.uf_load("Ql1SALES.XLS")

Use the control name, not the object name

In the parent window scripts, you use dot notation to qualify u_ole user
object functions with the control name (for example, ole_1), not the
object name (u_ole).

Saves the contents of u_ole as a BLOB (OLE file extension).

olecontrol.uf_save ()

Parameter | Description
olecontrol i Name of the window control containing the u_ole user object
None.

Call this user object function to save the contents of u_ole as a BLOB
(OLE extension). To use this function, you must have already loaded the
control's contents from an OLE file. If you want to save a server file (XLS
or DOC file) as an OLE file, use the uf_saveas function.
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Example

uf_saveas
Description

Syntax

Return value
Usage

Example

This example calls the uf_save function.

ole l.uf_save( )

Saves the contents of u_ole as a BLOB (OLE file extension).

olecontrol.uf_saveas ( filename )

Parameter | Description
olecontrol ’ Name of the window control containing the u_ole user object.
filename String containing the name of the file to be saved. If you do

not provide a filename, the function will prompt for one.

None.
Call this user object function to save the contents of u_ole as a BLOB.

This example calls the uf_saveas function.

ole_1l.uf_saveas("QlSALES.OLE")
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u_ole_excel

u_ole_excel

Description

Library

User object
functions

Usage

uf_getvalue

Description

Syntax

Return value

Usage

292

Standard visual user object of type OLEControl. This user object, which is
inherited from u_ole, provides basic functions for accessing Microsoft
Excel. Place this user object in a window instead of an OLE 2.0 control.

SYS.PBL

The user object functions encapsulated in u_ole_excel are:
¢ Uf_getvalue, explained on page 292.
¢ Uf_setfocus, explained on page 293.
¢ Uf _setvalue, explained on page 294.

You use the u_ole_excel user object to access Microsoft Excel spreadsheet
data through a PowerBuilder window control.

Returns the value in the specified spreadsheet cell.

olecontrol.uf_getvalue ( row, column)

Parameter Description

olecontrol Name of the window control containing the u_ole_excel user
object

row Integer specifying the row location

column Integer specifying the column location

String containing the value in the specified cell.

Call this user object function to access spreadsheet values.
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Example This example calls the uf_getvalue function to return the value at
spreadsheet cell 4,4.

string 1s_cell value

ole_1l.uf_ load("QlSALES.XLS")
ls_cell _value = ole_l.uf_getvalue(4,4)

uf_setfocus
Description Sets focus to the specified spreadsheet cell.
Syntax olecontrol.uf_setfocus ( row, column)

Parameter Description

olecontrol Name of the window control containing the u_ole_excel user

object

row Integer specifying the row location

column Integer specifying the column location
Return value Boolean. Returns TRUE if the function succeeded and FALSE if it did not.
Usage Call this user object function to set focus to an individual spreadsheet cell.
Example This example calls the uf_setfocus function to set focus to cell location 4,4.

ole_l.uf load("QlSALES.XLS")

IF NOT ole_l.uf_setfocus(4,4) THEN
MessageBox("Setfocus Failed","Can't set focus" )

END IF
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uf setvalue
Description

Syntax

Return value

Usage

Example

294

Sets a value in the current spreadsheet cell.

olecontrol.uf_setvalue ( value )

Parameter Description

olecontrol Name of the window control containing the u_ole_excel user
object.

value Value of data type Any that contains the value to be set. You
must ensure that the data type passed matches the data type
for the current cell.

None.

Call this user object function to specify a value for an individual
spreadsheet cell.

This example calls the uf_setvalue function to specify a value of 10 to cell
location 4,4.

any 1li_cell value

ole 1.uf load("QlSALES.XLS")

IF NOT ole l.uf setfocus(4,4) THEN
MessageBox("Setfocus Failed","Can't set focus")

END IF

1i cell_value = 10

ole l.uf_setvalue(li_cell value)
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u_ole word

Description

Library

User object
functions

Usage

Standard visual user object of type OLEControl. This user object, which is
inherited from u_ole, provides basic functions for accessing Microsoft
Word for Windows. Place this user object in a window instead of an OLE

2.0 control.

SYS.PBL

The user object functions encapsulated in u_ole_word are:

¢ Uf_get_bookmarks, explained on page 295.

Uf_getvalue, explained on page 296.

Uf_setfocus, explained on page 297.

*
¢ Ut _is_bookmark_valid, explained on page 297.
*
*

Uf_setvalue, explained on page 298.

You use the u_ole_word user object to access Microsoft Word for Windows
documents through a PowerBuilder window control.

uf_get_bookmarks

Description

Syntax

Returns the number of bookmarks in a document and fills an array with

bookmark names.

olecontrol.uf_get_bookmarks ( bookmarklist )

Parameter Description

olecontrol Name of the window control containing the u_ole_word user
object.

bookmarklist Unbounded string array into which the uf_get bookmarks

function places the bookmark names. This array is passed by
reference.
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Return value
Usage

Example

uf_getvalue
Description

Syntax

Return value

Usage
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Integer specifying the number of bookmarks in the document (and the
number of elements in the bookmarklist array).

Call this user object function to determine the number of bookmarks in a
Word document and to determine bookmark names.

This example calls the uf_get_bookmarks function. The

li_ num_bookmarks variable will contain the number of bookmarks in the
current document and the Is_bookmark_names string array will contain
bookmark names.

string 1s_bookmark_names[ ]
integer 1li_num bookmarks

1i_ num bookmarks = &
ole_1l.uf_get_bookmarks(ls_bookmark names)

Returns the value in the specified bookmark.

olecontrol.uf_getvalue ( bookmark )

Parameter | Description

olecontrol Name of the window control containing the u_ole_word user
object

bookmark String specifying the bookmark from which to obtain the
value

String containing the value in the specified bookmark.

Call this user object function to access data from a Microsoft Word for
Windows document.
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Example This example calls the uf_getvalue function to return the value at the
address1 bookmark.
string 1ls_bookmark = "addressl"

string 1s_bookmark_ value

ole_1l.uf_load("DISTLETT.DOC")
ls_bookmark_value = ole_l.uf_getvalue(ls_bookmark)

uf_is_bookmark valid

Description Indicates whether the passed bookmark name exists in the current
document.
Syntax olecontrol.uf_is_bookmark_valid ( bookmark )
Parameter ] Description
olecontrol Name of the window control containing the u_ole_word user
object
bookmark String containing the bookmark name to be tested
Return value Boolean. Returns TRUE if the string is a bookmark in the current

document and FALSE if it is not.

Usage Call this user object function to determine if a string is a valid bookmark in
the current document.

Example This example calls the uf_is_bookmark_valid function to determine if
addressl is a valid bookmark in the current document.

string 1ls_name = "Jill Jefferson"

IF NOT olel.uf_is_bookmark_valid("addressl") THEN
MessageBox( "Addressl", "Not a bookmark")

ELSE
ole_l.uf_ setfocus("addressl")
ole l.uf_ setvalue(ls_name)

END IF
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uf_setfocus
Description

Syntax

Return value
Usage

Example

uf_setvalue
Description

Syntax

Return value
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Sets focus to the specified bookmark location.

olecontrol.uf_setfocus ( bookmark )

Parameter | Description

olecontrol Name of the window control containing the u_ole_word user
object

bookmark String specifying the bookmark at which to set focus

Boolean. Returns TRUE if the function succeeded and FALSE if it did not.
Call this user object function to set focus to text at a bookmark location.

This example calls the uf_setfocus function to set focus to the bodytext
bookmark.

ole_l.uf_load("QlSALES.DOC")

IF NOT ole_1l.uf setfocus("bodytext") THEN
MessageBox("Setfocus Failed","Can't set focus")

END IF

Sets the text at the current bookmark location.

olecontrol.uf_setvalue ( value )

Parameter Description
olecontrol Name of the window control containing the u_ole_excel user
object.
value Value of data type Any that contains the value to be set. You
' must ensure that the data type passed matches the data type
for the current bookmark.
None.
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Usage

Example

Call this user object function to specify text at a particular bookmark
location.

This example calls the uf_setvalue function to specify a value of "Jill
Jefferson" to the name bookmark.

integer 1ls_name = "Jill Jefferson"

ole_l.uf load("QlSALES.DOC")
IF NOT ole_l.uf setfocus("name") THEN
MessageBox( "Setfocus Failed","Can't set focus")
END IF
ole_l.uf_ setvalue(ls_name)

u_pipeline_kit

Description

Library

Instance variables

Class object descended from the Pipeline system object. The u_pipeline_kit
user object provides functions for data pipeline usage.

& For information on using a data pipeline, see Building Applications
in the PowerBuilder documentation set. For information on pipeline
attributes, events, and functions, see Objects and Controls in the
PowerBuilder documentation set.

SYS.PBL

Variable Data type Access
i_src_trans Transaction Private
i_dest_trans Transaction Private
ib_elapsed_used Boolean Private
ib_executing Boolean Private
idw_errors DataWindow Private
il_lasttime Long Private
il_starttime Long Private
ir_total_time Real Private
ist_elapsed StaticText Private
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User object
functions

Usage
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Variable | Data type Access
ist_errors StaticText Private
ist_read StaticText Private
ist_written StaticText Private

The user object functions encapsulated in u_pipeline_kit are:
Uf_cancel, explained on page 302.
Uf_execute, explained on page 302.
Uf_get_commit, explained on page 304.
Uf_get_elapsed_time, explained on page 304.
Uf_get_error_msg, explained on page 305.
Uf_get_extended_attr_copy, explained on page 306.
Uf_get_maxerrors, explained on page 306.

Uf_get_syntax_value, explained on page 307.

*

*

.

*

L4

*

*

.

¢ Uf get type, explained on page 308.
¢ Uf_init, explained on page 309.

¢ Uf _init_elapsed_time, explained on page 310.

¢ Uf _repair, explained on page 311.

¢ Uf set_commit, explained on page 312.

¢ Uf set_extended_attr_copy, explained on page 313.
¢ Uf_set_maxerrors, explained on page 313.

¢ Uf_set_syntax_value, explained on page 314.

14

Uf_set_type, explained on page 315.

You can use the u_pipeline_kit user object to control a pipeline object. The
w_sys_pipeline application framework window uses the u_pipeline_Kit
user object to provide data pipeline functionality.

&> For more information on the w_sys_pipeline window, see the
"w_sys_pipeline" discussion in Chapter 4.



Chapter 9 User Objects

Examples

See also

Although it is recommended that you take advantage of u_pipeline_kit
functionality by using a descendant of the w_sys_pipeline window, you can
use u_pipeline_kit separately. To use the u_pipeline_ kit user object apart
from the w_sys_pipeline window:

1
2

Use the Pipeline painter to create and save a pipeline object.

Use the Window painter to create and save a window containing a
DataWindow control and four static text controls (these will contain
static text for rows read, rows written, rows in error, and elapsed
time).

Perform the remaining steps in your application's events and
functions.

Create transaction objects for the source and destination databases and
connect to these databases.

If the pipeline copies rows within the same database, you still must
define two separate transaction objects.

Create an instance of the pipeline object defined in step 1.
Initialize the pipeline object with the uf_init function.
Execute the pipeline with the uf execute function.

If there are errors, PowerBuilder displays them in the DataWindow
control.

Optionally display pipeline information such as pipeline type, commit
level, maximum errors, and elapsed time by using the appropriate
functions.

Allow the user to fix errors or cancel the process by providing options
for the uf_repair and uf_cancel functions.

Review the w_sys_pipeline window's Open, ue_execute, ue_repair, and
ue_cancel events for an example of using u_pipeline_kit.

Use the instance name, not the object name

In the parent window scripts, you use dot notation to qualify
u_pipeline_kit user object functions with the instance name (for
example, i_pipe), not the object name (u_pipeline_kit).

w_sys_pipeline
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uf_cancel
Description

Syntax

Return value

Usage

Example

See also

uf_execute

Description

Syntax

302

Stops pipeline execution.

pipelineinstance.uf_cancel ()

Parameter | Description

pipelineinstance | Instance name of the pipeline user object

Integer. Returns 1 if it succeeds and -1 if an error occurs.

Call this user object function after issuing uf_execute or uf_repair

functions. The pipeline user object instance remains, but you must reissue

the uf_init function before executing the pipeline again.

This example calls the uf_cancel function.
Long 11 _return

11 return = i_pipe.uf_cancel()

IF 11 return = -1 THEN
MessageBox("Pipeline Cancel","Cancel Failed")
END IF
uf_execute

Executes the pipeline object, which transfers data from the source to the
destination as specified by the SQL query in the pipeline object.

pipelineinstance.uf_execute ( message )

Parameter | Description

pipelineinstance \ Instance name of the pipeline user object
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Return value

Usage

Example

See also

Integer. Returns 7 if it succeeds and a negative number if an error occurs.
Error values are:

® & & 6 6 O O O O O O o O o o o

-1 Pipe open failed

-2 Too many columns

-3 Table already exists

-4 Table does not exist

-5 Missing connection

-6 Wrong arguments

-7 Column mismatch

-8 Fatal SQL error in source

-9 Fatal SQL error in destination
-10 Maximum number of errors exceeded
-12 Bad table syntax
-13 Key required but not supplied
-15 Pipe already in progress
-16 Error in source database
-17 Error in destination database

-18 Destination database is read-only

Call this user object function to transfer data from the source to the
destination as specified by the SQL query in the pipeline object named in
the uf_init function.

This example calls the uf_execute function.

int 1li_return

1li return = i_pipe.uf_execute( )
IF 1i_return < 0 THEN
MessageBox("Pipeline Execute Error", &
i_pipe.uf get_error msg( li_rc ),
Exclamation!)
END IF

uf_cancel
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uf_get_commit

Description

Syntax

Return value

Usage

Example

See also

Returns the number of rows issued between COMMITs.

pipelineinstance.uf_get_commit ()

Parameter | Description

Ppipelineinstance | Instance name of the pipeline user object

Long indicating the number of rows that will be added before the pipeline
issues a COMMIT.

Call this user object function to determine the COMMIT frequency.

This example calls the uf_get commit function.
long 11_commit

11 _commit = i_pipe.uf_get_commit( )

uf_set_commit

uf_get_elapsed_time

Description

Syntax

Return value

Usage
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Returns the number of seconds used in the last pipeline execution.

pipelineinstance.uf_get_elapsed_time ()

Parameter | Description

pipelineinstance ‘ Instance name of the pipeline user object

Real indicating the number of seconds used in the last pipeline execution.

Call this user object function to determine how long the last pipeline
execution took.
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Example This example calls the uf_get_elapsed_time function.
real 1lr elapsed time

lr _elapsed_time = i_pipe.uf_ get_elapsed_time( )

See also uf_set_elapsed_time

uf_get_error_msg

Description Returns the error message that corresponds to the passed error number.
Syntax pipelineinstance.uf_get_error_msg ( errornumber)
Parameter | Description

pipelineinstance | Instance name of the pipeline user object

errornumber Integer specifying the error number returned by the
uf_execute function

Return value String containing the error message that corresponds to the passed error
number.

Usage Call this user object function to access a message to display in an error
window.

Example This example calls the uf get error_msg function.

integer li_return

li_return = i_pipe.uf_ execute( )
IF 1li_return < 0 THEN
MessageBox( "Pipeline Execute Error", &

i _pipe.uf_get_error_msg(li return),Exclamation!)
END IF
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uf_get_extended_attr_copy

Description

Syntax

Return value

Usage

Example

See also

Returns a boolean indicating whether extended attributes will be copied.

pipelineinstance.uf_get_extended_attr_copy ( )

Parameter | Description

pipelineinstance ‘ Instance name of the pipeline user object

Boolean. Returns TRUE if extended attributes will be copied and FALSE if
they will not.

Call this user object function to determine whether extended attributes will
be copied.

This example calls the uf_get_extended_attr_copy function and updates a
checkbox with the returned value.

IF i pipe.uf_get_extended_attr_copy( ) THEN
cbx_extended_attr.checked = TRUE

ELSE
cbx_extended_attr.checked = FALSE

END IF

uf_set_extended_attr_copy

uf_get_maxerrors

Description

Syntax

Return value

306

Returns the value of the attribute indicating the number of errors the
pipeline will allow before canceling execution.

pipelineinstance.uf_get_maxerrors ()

Parameter | Description

pipelineinstance 1 Instance name of the pipeline user object

Long indicating the maximum errors that the pipeline will allow before
canceling execution.
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Usage

Example

See also

Call this user object function to determine the maxerrors value.

This example calls the uf_get_maxerrors function.
long 11 maxerrors

11 maxerrors = i_pipe.uf_get_maxerrors( )

uf_set_maxerrors

uf_get_syntax_value

Description

Syntax

Return value

Usage

Returns the value in the pipeline object syntax that corresponds to the
passed parameter. This is an internal function that is used by other
u_pipeline_kit user object functions; do not call this function directly.

pipelineinstance.uf_get_syntax_value ( pipelineparm)

Parameter | Description

pipelineinstance | Instance name of the pipeline user object

pipelineparm String specifying the parameter whose value is to be returned

String. Returns the parameter value if it exists in the syntax and an empty
string if it does not.

Call this user object function to determine the value that corresponds to a
pipeline object parameter. For example, to find out the name of the source
database, pass the string "source_connect" and the function will return the
data source name of the source database.

Export a pipeline object to view sample syntax

To see an example of the parameters used in pipeline syntax, use the
library painter to export a pipeline object to a text file. You can then
examine the file using the PowerBuilder File Editor, the Windows
Notepad, or some other ASCII text editor.
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Example

See also

uf_get_type
Description

Syntax

Return value

Usage

308

This example calls the uf_get_syntax_value function.
string 1ls_parm_value

ls_parm value = i _pipe.uf_get_syntax_value("type")
IF ls_parm value = "replace" THEN
MessageBox( "Replace"”, &
"Table will be replaced. OK to Proceed?", &
Exclamation!,OKCancel!,2)
END IF

uf get type
uf_set_syntax_value
uf_set_type

Returns the pipeline processing type (create, replace, append, and so on).

pipelineinstance.uf_get_type ()

Parameter ] Description

pipelineinstance | Instance name of the pipeline user object

String containing the processing type.

¢ Create
¢ Replace
¢ Append
¢ Refresh
¢ Update

Call this user object function to determine the processing type.
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Example

See also

uf_init
Description

Syntax

This example calls the uf_get_type function.

string

1s_type =

1s_type
i _pipe.uf_get_ type( )

IF ls_type = "replace" THEN
MessageBox( "Replace", &
"Table will be replaced. OK to Proceed?", &
Exclamation!,OKCancel!,h2)

END IF

uf_get syntax_value
uf_set_syntax_value

uf_set_type

Initializes the pipeline user object instance.

pipelineinstance.uf_init ( pipelineobject, sourcetransaction,
desttransaction, dwcontrol, rowsread, rowswritten, rowsinerror)

Parameter Description

pipelineinstance Instance name of the pipeline user object.

pipelineobject String containing the name of the data pipeline object
defined in the Data Pipeline painter

sourcetransaction | Transaction object with which to connect to the source
database

desttransaction Transaction object with which to connect to the destination
database (must be different from sourcetransaction)

dwcontrol DataWindow variable specifying the DataWindow control
to contain pipeline errors

rowsread StaticText window control to contain the number of rows
read value

rowswritten StaticText window control to contain the number of rows
written value

rowsinerror StaticText window control to contain the number of rows in

error value
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Return value

Usage

Example

None

Call this user object function before executing a pipeline. Before calling

uf_init, you must create an instance of u_pipeline_Kkit, connect to the
source database, and connect to the destination database.

This example calls the uf_init function (i_pipe, i_src and i_dest are

instance variables; dw_pipe_errors, st_read, st_written, and st_errors are

window controls).

// I_src will be the source transaction.
i_src = Create transaction
i_src.dbms = "ODBC"
i_src.dbparm = &
"ConnectString= 'DSN=Pipel;UID=dba;PWD=sql'"
CONNECT using i_src;

// I_dest will be the source transaction.
i_dest = Create transaction
i _dest.dbms = "ODBC"
i_dest.dbparm = &

"ConnectString= 'DSN=Pipe2;UID=dba;PWD=sql'"
CONNECT using i_dest;

// Create and initialize the pipeline.
i_pipe = Create u_pipeline kit
i_pipe.uf_init("p_pipe test", i_src, i_dest, &

dw_pipe_errors, st_read, st written, st_errors)

uf_init_elapsed_time

Description

Syntax

Return value

310

Initializes the variable that holds elapsed time information.

pipelineinstance.uf_init_elapsed_time ( elapsedtime )

Parameter | Description

pipelineinstance | Instance name of the pipeline user object

elapsedtime Statictext window control to contain the elapsed time

None
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Usage

Example

uf_repair
Description

Syntax

Return value

Usage

Example

See also

Call this user object function to initialize the user object variable that holds
elapsed time information.

This example calls the uf_init_elapsed_time function (st_elapsed_time is a
window control).

i _pipe.uf_init_elapsed_time ( st_elapsed_time )

Resubmits corrected rows to the destination database.

pipelineinstance.uf_repair ()

Parameter | Description

pipelineinstance ‘ Instance name of the pipeline user object

Integer. Returns I if the Repair function succeeded and -1 if it failed (or if
the pipeline was already executing).

Call this user object function to resubmit corrected rows to the destination
database.

This example calls the uf_repair function.
int 1li_rc

li_rc = i_pipe.uf_repair( )
IF 1li_rc < 0 THEN
MessageBox("Pipeline Repair Error", &
i pipe.uf_get_error msg( li_rc ),
Exclamation!)
END IF

uf_execute
uf_cancel
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uf_set_commit

Description Sets the Commit frequency.
Syntax pipelineinstance.uf_set_commit ( commitfactor)
Parameter Description

pipelineinstance | Instance name of the pipeline user object.

commitfactor Long specifying the number of rows to be copied between
COMMITs. Commitfactor must be one of the following:
0 (commit after all updates)

1

10

100

1,000

10,000

100,000

* & & 6 o o o

Return value Boolean. Returns TRUE if the function succeeded and FALSE if it did not.

Usage Call this user object function to control the frequency with which the
pipeline issues database COMMITs.

Example This example calls the uf_set_commit function.
long 11_parm

11_parm = 1000

IF NOT i_pipe.uf_set_commit(ll_ parm) THEN
MessageBox("Failure","Commit could not be set")

END IF

See also uf_get_commit
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uf_set_extended_attr_copy

Description

Syntax

Return value

Usage

Example

See also

Controls whether the pipeline copies extended attributes.

pipelineinstance.uf_set_extended_attr_copy ( copy)

Parameter | Description

pipelineinstance | Instance name of the pipeline user object

copy Boolean that specifies whether to copy attributes (TRUE) or
not (FALSE)

Boolean. Returns TRUE if the function succeeded and FALSE if it did not.

Call this user object function to control whether the pipeline copies
extended attributes.

This example calls the uf_set_extended_attr_copy function.

boolean 1b_copy
IF cbx copy_extended.checked = TRUE THEN

lb copy = i_pipe.uf_set_extended_attr_copy(TRUE)
ELSE

1b copy = i_pipe.uf_set_extended_attr_copy(FALSE)
END IF

uf get extended_attr_copy

uf_set_maxerrors

Description

Syntax

Sets the value of the attribute indicating the number of errors the pipeline
will allow before canceling execution.

pipelineinstance.uf_set_maxerrors ( maxerrors )

Parameter ‘ Description

pipelineinstance | Instance name of the pipeline user object

maxerrors Long indicating the number of errors the pipeline will allow
before canceling execution
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Return value
Usage

Example

See also

Boolean. Returns TRUE if the function succeeded and FALSE if it did not.
Call this user object function to control the maxerrors value.

This example calls the uf_set_maxerrors function.

long 11 _parm

11_parm = 100

IF NOT i_pipe.uf_set_maxerrors(ll_parm) THEN
MessageBox("Failure", "MaxErrors could not be

set")

END IF

uf_get_maxerrors

uf_set_syntax_value

Description

Syntax

Return value

Usage
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Sets a value in the data pipeline object. This is an internal function that is
used by other u_pipeline kit user object functions; do not call this function
directly.

pipelineinstance.uf_set_syntax_value ( item, value)

Parameter Description

pipelineinstance | Instance name of the pipeline user object
item String specifying the item whose value will be changed

value String specifying the new value

Boolean. Returns TRUE if the function succeeded and FALSE if it did not.

Call this user object function to modify attributes of the data pipeline object
(that is, the object defined in the Data Pipeline painter). For example, you
can use this function to change values for source database, destination
database, commit frequency, and so on.
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Example

See also

uf_set_type
Description

Syntax

Return value

Usage

Export a pipeline object to view sample syntax

To see an example of the parameters used in pipeline syntax, use the
library painter to export a pipeline object to a text file. You can then
examine the file using the PowerBuilder File Editor, the Windows
Notepad, or some other ASCII text editor.

This example calls the uf_set_syntax_value function to reset the COMMIT
frequency to 1000.

IF NOT &
i_pipe.uf_set_syntax_value("commit","1000") THEN
MessageBox("Commit", &
"Problem changing Commit factor")
END IF

uf get syntax_value

uf_get type
uf_set_type

Modifies the pipeline processing type (create, replace, append, and so on).

pipelineinstance.uf_set_type ( pipelinetype )

Parameter Description

pipelineinstance | Instance name of the pipeline user object.

pipelinetype String specifying whether one of the following:
¢ Replace

Create

Update

Refresh

Append

* & o o

Boolean. Returns TRUE if the function succeeded and FALSE if it did not.
Call this user object function to modify the pipeline processing type.
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Example

See also

uo_ dw

Description

Library

Instance variables

Structures

316

This example calls the uf_set_type function to change the processing type
to Append.
IF NOT i_pipe.uf_set_type("append") THEN
MessageBox("Set Type", &

"Unable to modify processing type.")
END IF

uf_get syntax_value

uf_get_type
uf_set_syntax_value

Standard user object that is a DataWindow and contains precoded scripts
for events, user events, and user object functions.

SYS.PBL

Variable Data type Access
ib_allow_updates Boolean Public
ib_allow_inserts Boolean Public
il_selected_row Long Public
isrt_validations[] Validation_struct Public

Validation_struct An array that defines the relationships between rules
and their error messages. You add rules to this structure array with the
uf_add_validation user object function.

Field | Data type

expression ‘ String
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User object
functions

User object events

Field | Data type

€ITOI_message I String

The user object functions encapsulated in uo_dw are:
¢ Uf add_validation, explained on page 318.
¢ Uf_check_required, explained on page 319.
¢ Uf_is_modified, explained on page 320.
¢

Uf_validate, explained on page 320.

Event Description

Clicked Sets the current row in the DataWindow to the clicked row
even if the user clicks on a column with a tab value of 0.

DBError Sets focus to the row in error and uses the f_error_box
function to display a popup window with an error message.

SQLPreview Triggers the appropriate event for additional processing to
check each update, insert, or delete before actually sending it
to the DBMS. If the event determines the action is invalid, it
sets Message.Return value to 7 and then returns.

add_row Inserts a row at the bottom of the DataWindow and sets focus
(user event) to that row.

del_row Prompts the user with a message box when a row is about to
(user event) be deleted. If the user's response is Yes, the row is deleted.
del_all_rows Deletes all the rows in the DataWindow.

(user event)

on_delete Adds application-specific delete processing to the descendent
(user event) DataWindow control. This event is triggered in the
SQLPreview event just before the SQL to delete the row is
sent to the database.

on_insert Adds application-specific insert processing to the descendent
(user event) DataWindow control. This event is triggered in the
SQLPreview event just before the SQL to insert the row is
sent to the database.

on_update Adds application-specific update processing to the descendent
(user event) DataWindow control. This event is triggered in the
SQLPreview event just before the SQL to delete the row is
sent to the database.
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Usage Use this user object in windows instead of a DataWindow control.

In Application Library application framework windows, the uo_dw user
object is associated with the dw_sheet control.

Example For examples of uo_dw usage, see any of the application framework sheet
windows.
See also w_sys_mast_detl_dw

w_sys_multi_dw
W_Sys_report
w_sys_shared_dw
w_sys_single_dw

uf_add_validation

Description Adds application-specific validation rule(s) for the DataWindow. These are
rules that are applied to all rows that have been modified and can be
formulated so that any combination of columns for a row can be combined
into one expression.

Syntax controlname.uf_add_validation ( expression, errormessage )

Parameter Description

controlname | The window control name of the uo_dw user object.

expression String used to define the rule. Rules are strings in the same
format as validation rules defined in the DataWindow painter.

For example, to make sure that the start_date is before the
end_date, use the following rule:

start_date < end_date
These rules must evaluate to a boolean result.

errormessage | String containing the error message to be displayed when the
rule fails.

Return value None
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Usage

Example

You typically call this function from the Open event of a window to set the
validation rule(s) for the control.

This example calls uf_add_validation in the Open event of a window
where uo_dw is named dw_sheet.

dw_sheet.uf_add_validation("len(trim(au_id)) = 9", &
"Author id must be 9 characters in length")

uf_check_required

Description

Syntax

Return value

Usage

Example

Checks to see if there are any columns on the DataWindow marked as
required and not filled in. If a required entry has not been entered, it issues
an error message and sets focus to the row and column that has not been
filled in.

controlname.uf_check_required ()

Parameter | Description

controlname l The window control name of the uo_dw user object

Boolean. Returns TRUE if all required columns have completed and
FALSE if they have not.

Call this user object function to see if there are any columns on the
DataWindow that have the Required attribute set to TRUE and have not
been filled in.

This example calls the uf_check_required function.

// Check for required fields.
IF NOT dw_sheet.uf_check_required() THEN return
FALSE
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uf_is_modified
Description

Syntax

Return value

Usage

Example

uf validate

Description

Syntax

Return value

320

Determines if there have been any modifications to the data in the control.

controlname.uf_is_modified ()

Parameter | Description

controlname I The window control name of the uo_dw user object.

Boolean. Returns TRUE if any data has been modified or if rows have been
inserted or deleted. Otherwise it returns FALSE.

Call this user object function in the CloseQuery event of a window to see if
any columns have been modified. If unmodified data exists, use the
f_exit_status function to ask the user how to proceed.

This example calls the uf_is_modified function.

// Are there unsaved changes?
IF NOT dw_sheet.uf_is_modified() THEN return FALSE

Test data in the control against previously added rules. You can pass a row
number to specify the row that is validated.

controlname.uf_validate ( rownumber)

Parameter | Description
controlname The window control name of the uo_dw user object.
rownumber Long specifying which row to test. If rownumber is 0 then all

modified rows are tested.

Boolean. Returns TRUE if the row passes validation and FALSE if it does
not.
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Usage You typically call this function before saving the DataWindow or when the
user has moved to a new row in the DataWindow.

Example This example calls the uf_validate function.

// Check for validation errors on the entire

// DataWindow.
IF NOT dw_sheet.uf_validate(0) THEN return FALSE
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PART FOUR
Sample Applications

This part describes the sample applications and code
examples included with the Application Library.






CHAPTER 10

Pubs Sample Application

About this chapter This chapter describes the Pubs sample application. By running this
application and reviewing its events, windows, and functions, you can
learn about using the Application Library in a complex application.

Contents Topic

| Page
Application setup ‘ 326
Usage instructions l 331
Things to note ‘ 345
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Application setup

Before running the Pubs sample application, you must:

¢ Add Application Library libraries to the a_pubs application library
search path

¢ Configure the PUBS database
¢ Modify the PUBS.INI file

% To modify the application library search path:
1  Start PowerBuilder.
2 Open the Application painter.
3 Select File>Open from the menu bar.

The Select Application Library dialog box displays.

Select Application Library

| pbexamdw.pbl
. | pbexamfe.pbl
| | pbexamfn.pbl
| pbexammn.pbl
o 1

4

author.pbl
publish_pbl
pubs.pbl
stores.pbl
titles.pbl

Libraries [=.pbl)

5 Double-click PUBS.PBL.
6 Click OK.
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The Select Application dialog box displays.

7 Click OK.
Click the Library List button in the PainterBar.

The Select Libraries dialog box displays.
Select Libraries

c:\pbapp\pubs\pubs_pbl:

9 Include the following libraries in your library search path by double-
clicking on the PBL name in the Paste Libraries listbox. This is the
recommended order.

Library | Location
PUBS.PBL ’ \PBAPP\PUBS (included automatically)
SYS.PBL \PBAPP

UTLFUNC.PBL \PBAPP
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Library Location

UTLWIN.PBL \PBAPP

AUTHOR.PBL \PBAPP\PUBS

PUBLISH.PBL \PBAPP\PUBS

STORES.PBL \PBAPP\PUBS

TITLES.PBL \PBAPP\PUBS
10 Click OK.

The Application painter workspace displays.

< To configure the PUBS database:

1  Open the Database painter.

2 Select File» Configure ODBC from the menu bar.
The Configure ODBC dialog box displays.

Ac D
Btrieve Data (file.ddf)
dBase files (*.dbf)
Excel Files (*.xls)
FoxPro Files (~.dI

es =
PB Q+E Btrieve

3 Select Watcom SQL 4.0 from the list of installed drivers.
4  Click Create.
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The WATCOM SQL ODBC Configuration dialog box displays.

Data Source Name: [

Description: I ]

[ Connection Information

User ID: [ ]
|
|

Password: I

Server Name: |(delaull)

Database Alias: |
[ Database Startup
Database File: | 1

O Local O MNetwork ® Custom

[ Microsoft Applicati {Keys in SQL

[ Prevent Driver not Capable errors

5  Enter this information:

Field Value
Data Source Name pubs
Description Pubs Database
User ID dba
Password sql
Database file pathname\pubs.db
This is typically C:\PBAPP\PUBS\PUBS.DB
Database Startup Select Local
6  Click OK.

The Configure ODBC dialog box displays.
7  Click Done.

The Database painter workspace displays.
8  Select File»Connect from the menu bar.

9  Select pubs from the list of profiles.
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The list of tables displays.

10 Click Cancel.

These steps register the PUBS database with PowerBuilder so that you can
run the Pubs sample application.

< To modify the PUBS.INI file:

1  Using the PowerBuilder File Editor, the Windows Notepad, or any
other ASCII text editor, open the PUBS.INI file in the PBAPP\PUBS

directory.

2 Replace the bracketed names with your own settings.

; Setup for ODBC
DBMS=0DBC
ServerName=
Database=

Userld=
DbParm=Connectstring='DSN=PUBS; UID=DBA; PWD=SQL'

For ODBC, use DBMS and DbParm only

For ODBC, you only need to specify values for DBMS and
DbParm. For other databases, you may need to specify additional
values. To determine the values to include in the PUBS.INI file,
refer to the Pubs database Profile section in the PB.INI file.

3 Save the file.
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Usage instructions

When you run the Pubs sample application, the w_login window displays
and, after a successful login, the frame window displays.

Pubs Database Sample Application

From the frame window, you have many options:
¢ Display and modify author information

¢ Display and modify publisher information

¢ Display and modify store information
L4

Display and modify title information

Not all functionality is covered

The following discussions provide an overview of what you can do with
the Pubs sample application. They do not cover every possible action.
For example, they do not cover updating and deleting information,
which you perform using Save and Delete items on the File menu.
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Accessing author information

Tasks you can perform related to authors include:
Add an new author
Access information for an existing author
Access titles for an author
Add titles for an author

Access author Master/Detail information for published titles

* & & & o o

Delete a title for an author

% To add a new author:
1  Select Topics> Authors from the menu bar.

The New Author window displays.

Author ID: - -

Last Name :
First Name:
Address:
City:
State: Zip: |
Phone:|( ) -
Contract :

2 Add new author information.

Click the save button.
or
Select File» Save from the menu bar.

< To access information for an existing author:
1 Select Topics> Authors from the menu bar.

The New Author window displays.

Last Name :
|| First Name:

Address :
City:
State :
Phone :
Contract:
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Click the Open button.
or
Select File»Open from the menu bar.

The Select an Author dialog box displays.

7 Selectan Autho

0 Records Found

Author ID_| Last Name | First Name Contract

3 Display the author list by clicking Search. The text for the button
toggles to Query.

648921872

Blotchet-Halls

846927186

1
238957766  Carson Cheryl 1
617708484  Coopernum Davidoff 3
722515454  DeFrance Michel 1F
712451867  del Castillo Innes 1
427172319 Dull Ann 1
1213468915  Green Marjorie 1
(627723246  Greene Morningstar 0
472272349 Gringlesby Burt 1

1

Hunter

You can also use Query mode

Because this dialog box is a descendant of w_select, you can also
use query mode to display the author list. To use query mode, type
an author ID, last name, first name, or contract into the first line of
an empty window and click Search. The author list displays rows
that match the specified query. To return to query mode from the
author list display, click Query.

4 Select an author by double-clicking or by clicking the author and
clicking OK.
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The Author Information window displays.

i Author Information for. - Marjorie Green %
| Author ID: 13-46-8915
| Last Name :(Green
1l First Name : Marjorie
Address :[309 63rd 5t #411
City:|Oakland
State :[California [#] zin:[ossts
Phone :((315) 986-7020
[ 1

< To access titles for an author:

¢ With the Author Information window displayed, select Actions> Titles

for Author from the menu bar.

The Titles for Author window displays.

itles for - Marjorie G

Title ID : [BU2075 You Can Combat Computer Stress!

Type of Book : business Price: $2.99 YTD Sales : $18,722

< To add titles for an author using this window:
1

With the Titles for Author window displayed, select Actions> Insert
Row from the menu bar.
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An empty row displays.
Position the cursor over the Title ID column.

The cursor changes to an up arrow, which indicates that you can
display a selection list by double-clicking.

Double-click.
The Select Title dialog box displays.

Select Title
[ Price | Type Of
Thie Buzy Executive's Databaze Suide 12500 4 o bz A
Cooking with Computers: Surreptitious Balance Sheets 1185 3,876.00
You Can Combat Computer Stress! 283 1872200
Straight Talk About Computers 19.98 4,095.00
Silicon Valley Gastronomic Treats 1993 203200

The Gourmet Microwave 299 2224600
The Psychology of Computer Cooking 1895 25,000.00
But Is tt User Friendly? 101.34  8,780.00
Secrets of Silicon Valley 20.00 4,095.00
Net Etiquette 2985 30,000.00
Computer Phobic and Non-Phobic Individuals: Behavior Varie 21.58 375.00

& You can also use query mode with this dialog box. For

information on using query mode, see "Accessing author information"
on page 332.

Double-click on the desired title.

The Titles for Author window displays with the selected title in the
NEW TOW.

Click the Save button.
or
Select File» Save from the menu bar.

< To access author Master/Detail information:

¢ Select Topics> Author Master/Detail from the menu bar.
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The Author Master/Detail window displays.

Author ID Last Name
PRl vite Johnson F
213-46-8315 Green Marjune (31 5) 985 7020 3[]9 63rd St. #4
238-85-7766 Carson Cheryl (415) 548-7723 589 Darwin Ln|
267-41-2394 O'Leary Michael (408) 286-2428 22 Cleveland A

i S0The Peychaloay of Computer Cocking ! 2
Ps3333 [ 1] 100Prolonged Data Deprivation: Four Case 19.98  4,072.00 612/85
Studies

28,072.00

J

L)

% To add a new title for an author using the Master/Detail
window:

1  Select the desired author in the top half of the window.

2 Click the Insert Detail button.
or
Select Actions Insert Detail from the menu bar.

A blank row displays in the bottom half of the window.
G 3 Position the cursor over the Title ID column.

The cursor changes to an up arrow, which indicates that you can
display a selection list by double-clicking.

4 Double-click.
The Select Title dialog box displays.

%ﬂ______J_—]ED: =]

1 : Execitive's [ b

Caakmg with Computers: Surrepmous Balance Sheets 1.95 3,876

You Can Combat Computer Stress! 298 18,72200
Straight Talk About Computers 19.98 4,095.00
Silicon Valley Gastronomic Treats 1998 2,032.00

The Gourmet Microwave 289 2224600
The Psychology of Computer Cooking 1885 2500000
But Is It User Friendly? 101.34 §,780.00
Secrets of Silicon Valley 2000 409500
Net Etiquette 2985 30,000.00
Cornputer Phobic and Non-Phobic Individuals: Behavior Varie 21.59 375.00
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& You can also use query mode with this dialog box. For
information on using query mode, see "Accessing author information"
on page 332.

Double-click on the desired title.

The Author Master/Detail window displays with the selected title in
the new row.

Click the Save button.
or
Select File» Save from the menu bar.

o delete a title for an author:

In the Author Master/Detail window, click in the title to be deleted.

Click the Delete button.
or
Select Actions> Delete Detail from the menu bar.

Accessing publisher information

Tasks you can perform related to publishers include:

*
14
¢

Add an new publisher
Access information for an existing publisher

Access titles for a publisher

< To add a new publisher:

1

Select Topics> Publishers from the menu bar.

The New Publisher window displays.

Publisher ID: |

Publisher Name :
i City:
State :

Add new publisher information.
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3

Click the save button.
or
Select File> Save from the menu bar.

% To access information for an existing publisher:

1

Select Topics>Publishers from the menu bar.

The New Publisher window displays.

vvl vp.uvhlnigl;clv e

Publisher ID :

‘ Publisher Name :
City:
State :

Click the Open button.
or
Select File>Open from the menu bar.

The Select a Publisher dialog box displays. Since there are relatively
few publishers, the application displays this list immediately.

3 Records Found |7 OK
Publisher Name

Calforma B
Binnet & Hardley Washington District of Colul#§
New Moon Books Boston [Massachusett{#}

Select a publisher by double-clicking or by clicking the publisher and
clicking OK.

The Publisher Information window displays.

Publisher Information for: - New Moon Books [ bl |
Publisher ID: JEEE

| Publisher Name : [New Moon Books ]
i City: [Boston ]
State :

Massachusetts

< To access titles for a publisher:

¢  With the Publisher Information window displayed, select
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The Titles for Publisher dialog box displays.

Titles for - New Moon Books
Publish Date
at i
$24 YTD Sales:

dith the

: psychology Publish Date: 06/15/1985
: Is Anger the Enemy?

$10.95 Advance:  $2,275 Royalty: $12 YIDSales: $2,045

[Notes :  Carefully researched study of the effects of strong emotions on the body.
Metabolic charts included.

Accessing store information

Tasks you can perform related to stores include:

*

L4
L4
.

Add an new store
Access information for an existing store
Access sales for a store

Access discounts for a store

< To add a new store:

1

Select Topics> Stores from the menu bar.

The New Store Information window displays.

Store ID :
l|Store Name :

Address :
City:
State :
Zip:

Add new store information.

Click the save button.
or
Select File» Save from the menu bar.
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< To access information for an existing store:
1  Select Topics>Stores from the menu bar.

The New Store Information window displays.

New Store Information

| storem:
l{Store Name :

Address :
City:
State :
Zip:

Click the Open button.
or
Select File»Open from the menu bar.

The Select a Store dialog box displays.

Select a Store

0 Records Found

Store ID | Store Name

kelebehelebepefehobepele]

& You can also use query mode with this dialog box. For
information on using query mode, see "Accessing author information"
on page 332.

3 Display the store list by clicking Search.

7 Records Found

| Store Name
Eric the Feard Bnoks
Barnum's Tustin
News & Brews Los Gatos
Doc-U-Mat: Quality Laundry and Books Remulade
Fricative Bookshop Fremont
Bookbeat Portland

Barnes and Noble Grand Forks
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4 Select a store by double-clicking or by clicking the store and clicking
OK.

The Store Information window displays.

lStore Name : [Barnurn's
Address : [567 Pasadena Ave.
City: [Tustin

State : [California 3]
Zip: (92789

< To access sales for a store:

1 With the Store Information window displayed, select Actions> Sales
for Store from the menu bar.

The Sales for Store window displays.

s Aniger the Enermy? 3]
The Busy Executive's Database Gui Fl’s'f

2 With this window displayed, you can use the Actions menu to insert,
delete, and sort rows.

< To access discounts for a store:

1 With the Store Information window displayed, select
Actions> Discounts for Store from the menu bar.

The Discounts for Store window displays.

! LowQty | High Gty | Discount |
11 100 15
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2 With this window displayed, you can use the Actions menu to insert,
delete, and sort Tows.

Accessing title information
Tasks you can perform related to titles include:
¢ Addanew title
¢ Access information for an existing title
¢ Access sales for a title
¢

Access royalty schedules for a title

'0

* To add a new title:
1  Select Topics>Titles from the menu bar.

The New Title window displays.

" New Title

Tew:! |
Title : [
Type: ]
Publisher 1D:[ #] Pubishpate: [ |

oty [ ] vosoes: ]

Notes :

2 Add new title information.

Click the save button.
or
Select File> Save from the menu bar.

< To access information for an existing title:

1  Select Topics> Titles from the menu bar.

342



Chapter 10 Pubs Sample Application

The New Title window displays.

TitleID :

Tite : | |
Type : [ ]
pupishero:[ [3] Publishbate:| |

Price: Advance :
oy: [ ] vosaes: [ ]

Notes :

2 Click the Open button.
or
Select File> Open from the menu bar.

The Select a Title dialog box displays.

Select a Title
23 Records Found

Title

BLI1032 The Busy Executive’s Database Guide husiness £
BU1111 Cooking with Computers: Surreptitious Balance Sheetbusiness 6/9/85 22:22:22
BU2075 You Can Combat Computer Stress! business B/30/85 77:22:7 :
BU7832 Straight Talk About Computers business 6/22/85 7?:
MC2222 Silicon Valley Gastronomic Treats mod_cook 619185 27:2 .
MC3021 The Gourmet Microwave mod_cook 611885 22:22:90
MC3026 The Psychology of Computer Caaking UNDECIDED  9/28/82 ?7:22:70
PC1035 Butls It User Friendly? popular_comp  6/30/85 ?22:22:2f |
PC8888 Secrets of Silicon Valley popular_comp  6/12/85 27:77:%|

PC9999 Net Etiquette popular_tomp  9/28/92 22:7? ”

&~ You can also use query mode with this dialog box. For
information on using query mode, see "Accessing author information"
on page 332.

3 Select a title by double-clicking or by clicking the title and clicking
OK.

The Title Information window displays.

Title Information for: - S{r;i;ﬁt Talk About
Title ID:

Title : [Straight Talk About Computers i
Type: pusiness |
Publisher ID : [Algodata Infosystems |  PublishDate:
Price: Advance :
Royalty : ¥TD Sales :

Notes : jAnnotated analysis of what computers can do for you: a no-hype guide for
he critical user.
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< To access sales for a title:

*

< T
1

2

344

With the Title Information window displayed, select Actions>Sales
for Title from the menu bar.

The Sales for Title window displays.

hm:(_}/ales rT’l‘lTe“é;ri;”I;t.u‘tv}alk About Computers

Total: $1,289.35

o access the royalty schedule for an existing title:

With the Title Information window displayed, select Actions> Royalty
Schedules from the menu bar.

The Royalty Schedules window displays.

T — I
Royalty Schedules for - Straight Talk About Computers u}
LowRange | HighRange | ___Rovalty | 2]

A000

With this window displayed, you can use the Actions menu to insert,
delete, and sort rows.
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Things to note

Selection windows The Pubs application uses descendants of the w_select window to select
rows to add to a DataWindow. These windows are:

¢ w_author_select

¢ w_publishers_select
¢ w_store_select

¢ w_title_select

Control of window The Pubs application keeps track of the contents of each sheet and will

display allow only one sheet instance for each row. That is, for a certain title, the
Pubs application will allow only one instance of the Title Information
window for that title. This is accomplished by calling the wi_set_sheettitle
window function in the ue_fileopen user event of the sheet window. The
wi_set_sheettitle window function is defined in the w_sys_single_dw

ancestor window.
Application Library This discussion outlines some of the Application Library objects used in
object usage the Pubs application

¢ m_sys_frame menu

¢ m_pubs menu
m_author_master_detail menu
m_author_sheet menu
m_discount_sheet menu
m_publishers_menu menu
m_sales_sheet menu

m_store_sheet menu

* & 6 6 o o o

m_title_roysched menu

*

m_title_sales menu
m_title_sheet menu

m_titleauthor_sheet menu

* & o

m_titlepubs_sheet menu
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select window
w_author_select window
w_publishers_select window
w_store_select window
w_title_select window

sys_frame window
w_pubs_frame window

sys_mast_detl_dw window
w_authors_master_detail window

sys_single_dw window
w_author_sheet window
w_publishers_sheet window
w_store_sheet window

sys_multi_dw window
w_publishers_title_sheet window
w_store_discounts_sheet window
w_store_sales_sheet window
w_title_roysched window
w_title_sales window

sort_order window

Opened any time you choose the Sort option



CHAPTER 11
Time Management Sample Application

About this chapter This chapter describes the Time Management sample application. By
running this application and reviewing its events, windows, and functions,
you can learn about using the Application Library in a complex application.

Contents Topic | Page
Application setup ‘ 348
Usage instructions ’ 353
Things to note , 364
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Application setup

Before running the Time Management sample application, you must:

¢ Add Application Library libraries to the TIMEMGMT application
library search path

Configure the TIMEMGMT database
Modify the TIMEMGMT.INI file

*

*

.
0.0

o modify the application library search path:

T
1  Start PowerBuilder.

2 Open the Application painter.
3

Select File»Open from the menu bar.

The Select Application Library dialog box displays.

pﬁcxanl;n =
pbexamfe.pbl
pbexamfn.pbl

pbexammn.pbl
pbexamuo.pbl
pbexamw1_pbl
pbexamw2.pbl
pbexamwn. pbi

4  Use the Directories listbox to access the PBAPP\TIMEMGMT
directory.

nnemgml,pbi -

PB Libraries (*.pbl)

5 Double-click TIMEMGMT.PBL.
6 Click OK.
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The Select Application dialog box displays.

“\pbapp\timemgmt\timemgmt.pbl

7  Click OK.
8  Click the Library List button in the PainterBar.

The Select Libraries dialog box displays.

c:\pbapp\timemgmt\timemgmt.pbl;

[ pbapp
2> timemgmt

9 Include the following libraries in your library search path by double-
clicking on the PBL name in the Paste Libraries listbox. This is the
recommended order.

Library Location

TIMEMGMT.PBL | \PBAPP\TIMEMGMT (included automatically)

SYS.PBL \PBAPP
UTLFUNC.PBL \PBAPP
UTLWIN.PBL \PBAPP
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10 Click OK.

The Application painter workspace displays.

% To configure the TIMEMGMT database:

1  Open the Database painter.

2 Select File» Configure ODBC from the menu bar.
The Configure ODBC dialog box displays.

Paradox Fil

3 Select Watcom SQL 4.0 from the list of installed drivers.
4  Click Create.
The WATCOM SQL ODBC Configuration dialog box displays.

Watcom SQL ODBC Configuration -

Data Source Name: f

Description: |

[ Connection Information
User ID: |

Password:

Server Name: |<default>
Database Alias:

[ Database Startup
Database File: r

O Local O Network @® Custom

Od Microsoft Applications (Keys in SQLStatistics)

[ Prevent Driver not Capable ernors

5  Enter this information:
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Field

Value

Data Source Name
Description

User ID

Password

Database file

Database Startup

6 Click OK.

timemgmt

Time Management Database
dba

sql

pathname\timemgmt.db

This is typically
C:\PBAPP\TIMEMGMT\TIMEMGMT.DB

Select Local

The Configure ODBC dialog box displays.

7  Click Done.

The Database painter workspace displays.

8 Select File»Connect from the menu bar.

9  Select timemgmt from the list of profiles.

The list of tables displays.

10.Click Cancel.

These steps register the TIMEMGMT database with PowerBuilder so that
you can run the Time Management sample application.

< To modify the TIMEMGMT.INI file:

1 Using the PowerBuilder File Editor, the Windows Notepad, or any other
ASCII text editor, open the TIMEMGMT.INI file in the
PBAPP\TIMEMGMT directory.
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2 Replace the bracketed names with your own settings.

; Setup for ODBC
DBMS=0DBC
ServerName=
Database=

UserId=
DbParm=Connectstring='DSN=TIMEMGMT ; UID=DBA; PWD=SQL'

For ODBC, use DBMS and DbParm only

For ODBC, you only need to specify values for DBMS and DbParm.
For other databases, you may need to specify additional values. To
determine the values to include in the TIMEMGMT.INI file, refer to

the Timemgmt database Profile section in the PB.INI file.

3 Save the file.
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Usage instructions

When you run the Time Management sample application, the w_login
window displays and, after a successful login, the frame window displays.

From the frame window, you have many options:

¢ Display and modify consultant information
¢ Display and modify customer information

¢ Display and modify state information
L4

Display reports

Not all functionality is covered

The following discussions provide an overview of what you can do with
the Time Management application. They do not cover every possible
action. For example, they do not cover updating and deleting
information, which you perform using the Save and Delete items on the
File menu.
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Accessing consultant information
Tasks you can perform related to consultants include:
+ Display a list of consultants

¢ Add a new consultant

< To display a list of consultants:
¢ Select Tasks> Consultants from the menu bar.

The Consultants window displays.

i Ep ced P elop A
it /Numerous federal projects

< To add a new consultant:

With the Consultants window displayed, click the New button.
or
Select File>New from the menu bar.

A blank row displays in both the top and the bottom DataWindow.
2 Add new consultant information to the bottom DataWindow.

Click the Save button.
or
Select File> Save from the menu bar.
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Accessing customer information

Tasks you can perform related to customers include:

¢

*
L4
L
*

Display a list of customers
Add a new customer
Display project detail
Generate an invoice

Display a customer detail report

< To display a list of customers:

¢

Select Tasks> Customers from the menu bar.

The Customers window displays.

0Oil and Gas exploration company. Some existing PB

P!

ob Huddelston

< To add a new customer:

With the Customers window displayed, click the New button.
or

Select File»New from the menu bar.
A blank row displays in both the top and the bottom DataWindow.
Add new customer information to the bottom DataWindow.

Click the Save button.
or
Select File»Save from the menu bar.
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< To display project detail for a customer:

1  With the Customers window displayed, select Actions> Project/Detail
from the menu bar.

The Project/Detail window displays.

Projects/Detail for - RSX

2 With this window displayed, you can use the Actions menu to insert,
delete, and sort detail rows.

+ To generate an invoice for a customer:
1

With the Customers window displayed, select Actions> Generate
Invoice from the menu bar.

The Invoice window displays.

~.....,,,,~.W " lnvoice - RSX
. e
Systems Consulting Company
Specializing bt Pow ider C ing
100 Buffalo Speedway
Houston TX. 77056
(713)-555-9000
Customer : RSX RSX
1 RSX Drive
Houston, TX 77058
(713) 655-1000 § .
Start Ending Hours
Description Consultant Title Date Date Workes

2 At this point, you can view the report online, zoom in, zoom out, and
print, optionally selecting File> Print Preview from the menu bar.
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< To display a customer detail report:
1

With the Customers window displayed, select Actions> Detail Report
from the menu bar.

The Customer Detail window displays.

“Customer Detail - RSX

.
Systems Consulting Company
Customer Detail Report
Customer: RSX Contact: Rudy deYong Phone: (713) 555-1000
Start  Ending Hours Billing
Description Date Date Ci Worked Rate Fee
Develop C/S plan 10/3/83  11/1/93 Alan Bennett 160 $187.00  $29,920.0f
Develop detailed specifications for conversion process and design of new syste!
Alan Wilson 160 $250.00  $40,000.0¢
Oversee development of conversion plan.
1111793 12/1/93 Alan Bennett 160 $187.00  $29,920.0f #
Continue to develop plans i
Ruth Rollins 160 $187.00  $29,920.00 :
User interviews to assist in development of conversion plans. "

2 At this point, you can view the report online, zoom in, zoom out, and
print, optionally selecting File> Print Preview from the menu bar.

Accessing state information
Tasks you can perform related to states include:
¢ Display state information

¢ Add a new state

< To display state information:

¢ Select Tasks> States from the menu bar.
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The States window displays.

‘Arizona

Arkansas

California

Colorado

iConneticut

iDelaware

District of Columbia
Florida |

< To add a new state:
1

With the States window displayed, click the New button.
or
Select File»New from the menu bar.

2 Add new state information.

3 Click the Save button.
or
Select File» Save from the menu bar.

Accessing reports
The Time Management reports are:
Customer detail
Customer summary
Consultant detail
Consultant summary
Accounts receivable summary

Accounts receivable aged

* & & & o o o

Sales by month
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% To display the customer detail report:

*

Select Tasks>Reports>Customer Detail from the menu bar.

The Customer Detail report displays. This is the same report as that

accessed from the Customer window, but for all customers.

Systems Consulting Company

Customer Detail Report

Customer: Anexco Contact: Bob Huddelston Phone: (713) 555-3326

Start  Ending Hours  Billing
Description Date Date C Worked Rate Fee
Migrate to Watcom 10/10/94 12/31/94 Mark Carlson 200 $125.00  $25,000.0]
Preliminary entry
$25,000.0

8/22/93  8/22/93 Jim Wilson 16 $187.00 $2,992.0
Reviewed marketing application. Problems with amount of time it takes for windo
open. The developers had coded an embedded SQL statement in the open event
window rather than using a datawindow. Switched to a datwindow. Open time we

15 seconds to 2. Also optimized SQL used for retrieval (old one had several subsg
switched to Union and then group breaks in the datawindow to summarize the dat|
Suggested that they may want to use stored procedures for complicated queries f

Performance review

¢ To display the customer summary report:

¢ Select Tasks> Reports> Customer Summary from the menu bar.

The Customer Summary report displays.

Cus 3 ry Re
. 10/27/94
Systems Consulting Compan Pace 1011
age 1 o
Sales By Customer
Customer Fee
Anexco $35,984.00 Percentage of Sales
Enersoft Corp $236,465.00
Intelligent Systems $40,481.00
PC's are Us $14,500.00
Prozal Corp $59,840.00 14.76% B 2nexco
RSX $189,600.00 B Enersotc
Walters Furniture $99,860.00 B inteliigent
$676,730.00 34.94% PC'sare U
Prozal Cori
28.02% RSX
Il walters Fu
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+ To display the consultant detail report:
1

Select Tasks> Reports>Consultant Detail from the menu bar.

The Consultant Detail query mode window displays.

Systems Consulting Company

Consultant Detail Report Page 1 of 5

Start Ending Hours
Consultant Date Date Customer

Click on the down arrow at the right of the Consultant column.

A dropdown listbox displays.

Consultant

Click on the desired consultant.

Click the Query Mode button.
or
Select File»Query Mode from the menu bar.
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The Consultant Detail report displays for the selected consultant.

Consullams Detaﬂ Repon

Systems Consulting Company 10727194
Consultant Detail Report Page L of 1
Start Ending Hours
C Date Date ‘Worked Ci Project|
Alan Bennett 10/3/93 1111493 160.00 RSX Develop C/S plan
Develop detailed specifications for conversion process and design of new systems
111793 1211193 160.00
Continue to develop plans
1211793 111194 160.00
Start prototyping of core components (application framework) of system

¢ To display the consultant summary report:
¢ Select Tasks>Reports> Consultant Summary from the menu bar.

The Consultant Summary report displays.

Lnnsultants ’c.ummary Report
10/27/94
Systems Consulting Company -
age 1 o
Sales By Consultant
Consultant Fee
Alan Bennett $89,760.00 Percentage of Sales
Alan Wilson $75,500.00
Butch Evans $59,840.00 B Aan ol
Della Nelson $46,500.00 9% 3
Jim Wilson $65,824.00 s.42% 13.26% B Aanwi
June Williams $116,501.00 Butch §
Mark Carlson $64,376.00 13.26% 1.18% Della N
i . Jim Wil
Ruth Rolling $89,760.00
Scott Flink $29,920.00 — June
Steve Ellinsons $38,750.00 — gatf:;
$676,730.00 9.51% 8.84% ] S:Dn all
B steved
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¢ To display the accounts receivable summary report:

¢ Select Tasks>Reports> Accounts Receivable Detail from the menu bar.

The Accounts Receivable report displays.

10127194

Page 1 of 6
Accounts Recievable Report, By Customer

Customer Phone # Contact Name
Anexco (713) 555-3326 Bob Huddelston
Project Ending Date Hours Worked Billing Rate Fee C
Migrate to Watcom 12131794 200.00 $125.00 _ $25,000.00 Mark Carlson
$25,000.00
Performance review 08122193 16.00 $187.00 $2,992.00 Jim Wilson
10/05/93 40.00 $125.00 $5,000.00 Mark Carlson
$7,992.00
$32,992.00

¢ To display the accounts receivable aged repott:
¢  Select Tasks™ Reports> Accounts Receivable Aged from the menu bar.

The Aged Accounts Receivable report displays.

Systems Consulting Company 1012754
Aged Accounts Receivable Page 1 of4
420 To 450 Days
Ending Hours
Days Date  Worked Amount C Project
431 08/22/193 16.00 $2,992.00 Anexco Performance review  Jim Wilg
T $289200
390 To 420 Days
Ending  Hours
Days Date  Worked Amount C Project Ci
381 10/01/93 140.00 $17,500.00 Walters Furniture Construct Manf system Della N¢
140.00 $26,180.00 Butch E
30.00 $7,500.00 Alan Wilg
$51,180.00
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¢ To display the sales by month report:

¢ Select Tasks>Reports>Sales by Month from the menu bar.

The Sales by Month report displays.

% Sales by Month
Systems Consulting Company 1012754
Revenue by Month and Customer Page 1 of 4
June, 1993 Revenue
Intelligent Systems ~ $10,000.00
$10,000.00
July, 1993
Enersoft Corp $15,000.00
Prozal Corp $29,920.00
$44,920.00
August, 1993
Enersoft Corp $26,180.00
Prozal Corp $29,920.00
Anexco $4,488.00
$60,588.00 + } f i
0 S0000 100000 150000 200000
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Things to note

Things to note

Shared
DataWindow
ancestor

Report ancestor

Query mode

Application Library
usage

364

The w_consultants and w_customers windows are descendants of the
w_sys_shared_dw shared DataWindow ancestor. Examine these windows
for examples of how to use the shared DataWindow feature.

The report windows are all descendants of the w_sys_report ancestor.
Examine these windows for examples of how to use this ancestor. It includes
user events for zoom in, zoom out, print preview, and query mode.

The w_consultant_summary window uses query mode, allowing you to
restrict the report to a single consultant. Examine this window for an
example of how to use query mode in a window.

This discussion outlines some of the Application Library objects used in the
Time Management application:

¢ m_sys_frame menu
¢ m_timemgmt menu
¢ m_consultant menu
¢ m_customer menu
¢ m_details menu
4 m_report_menu menu
¢ m_state menu
¢ w_sys_frame window
¢ w_timemgmt_frame window
¢ w_sys_mast_detl_dw window
¢ w_details window
¢ Ww_sys_report window
¢ w_rpt_accts_rec window
¢ w_ipt_accts_rec_aged window
¢ w_rpt_consultant_detail window
¢ w_rpt_consultant_summary window
¢ w_rpt_customer_detail window
L4

w_rpt_customer_summary window
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¢ w_rpt_invoice window
¢ w_rpt_revenue window
w_sys_shared_dw window
¢ w_consultants window
¢ w_customers window
w_sort window

¢ Opened any time you choose the Sort option
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CHAPTER

12

Application Library Code Examples

About this chapter

Contents

This chapter describes how to install the code examples delivered with the
Application Library. This application (EXAMPLE.PBL in
C:\PBAPP\EXAMPLE) demonstrates the usage of the Application Library
objects that are not referenced in the sample applications.

The example application allows you to execute a series of windows that
show working examples of some of the Application Library's utility
functions and objects.

Topic | Page

Application setup l 368
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Application setup

Before running the code examples, you must add Application Library
libraries to the example application library search path

< To modify the application library search path:
1 Start PowerBuilder.

2 Open the Application painter.

3 Select File»Open from the menu bar.

The Select Application Library dialog box displays.

Select Application Library

pbexamdm;)bl ]

pbexamfe_pbl
{1 pbexamfn_pbl
| pbexammn.pbl

pbexamuo.pbl

pbexamw1_pbl

5 Double-click EXAMPLE.PBL.
6 Click OK.
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The Select Application dialog box displays.

7 Click OK.
8  Click the Library List button in the PainterBar.

The Select Libraries dialog box displays.

& o
{22 pbapp
B samples

9 Include the following libraries in your library search path by double-
clicking on the .PBL name in the Paste Libraries listbox.

Library Location

EXAMPLE.PBL \PBAPP\EXAMPLE (included automatically)

SYS.PBL \PBAPP
UTLFUNC.PBL \PBAPP
UTLWIN.PBL \PBAPP
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10 Click OK.
The Application painter workspace displays.

< To run the Application Library code examples:

1 With example as the current application, select File> Run from the
menu bar.

2 Click the button that correspond to the function you want to see.
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APPENDIX

Application INI File

Database
connection
information

Prototype INI file

The PowerBuilder Application Library application framework (specifically,
the f_app_open function) uses an INI file as the source of database
connection information. You must save the application INI file in the same
directory as the PBL file that contains the application object.

If desired, you can use the f_app_open function apart from the application
framework.

The INI files shown in this manual (PUBS.INI, TIMEMGMT.INI, and
TUTOR_AL.INI) all contain parameters for connecting through ODBC to
the Watcom SQL database.

Modify the application INI file according to your specific application
requirements. For ODBC, you only need to specify values for DBMS and
DbParm. For other databases, you may need to specify additional values.
To determine the values to include for your DBMS, refer to the database's
Profile section in the PB.INI file.

Below is a prototype INI file.

; Setup for ODBC

[Databasel]

DBMS=0DBC

LogId=

LogPassword=

ServerName=

Database=PUBS

UserId=dba

DatabasePassword=
DbParm=Connectstring='DSN=PUBS;UID=DBA; PWD=SQL'
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ancestor
m_base menu 273
m_sys_frame menu 274
w_select 158
w_sys_frame 169
w_sys_mast_detl dw 172
w_sys_multi_dw 179
w_sys_report 187
w_sys_single_dw 194
application creation 7
application framework
overview 4
w_sys_frame 169
w_sys_mast_detl dw 172
w_sys_multi dw 179
w_sys_pipeline 181
w_sys_report 187
w_sys_single_dw 194
application INI file 36
Application Library
installation 10
list of files 11
application library search path
about 24
recommended order 25
application object
creation 19
Open event 39
SystemError event 199
assumptions 18
attribute, DataWindow object 220

Cc

Close event 27
CloseWithReturn, replacement for w_hold_parms
144

D

d_file_display 203
d_free_resources 204
d_global_vars 205
d_profile 205
d_progress 206
d_sort 206
d_sort_order 207
d_system_error 207

data pipeline see also pipeline

database connection, INI file 371
database error

u_pipeline_kit 299
w_sys_pipeline 181

f db_error 124,213
w_db_error 124

DataWindow
associating with window controls 99

f dddw_lookup 214

f dw_fill ddlb 217
f_dw_get_attributes 217

f dw_get objects 219

f dw_get objects_attrib 220
f _dw_getcolnames 222

f dw_getheaderlabel 223

f dw_getvisiblecolumns 224

f dw_set_color 228

f dw_set_color_row 229
f_dwobjectatpointer 225
f lookupcode 239

f lookupdisplay 240
f_promptforcriteria 250
f retrieve_dddw 254

f sort_order 259
str_select_parms 269
str_sort 270

uo_dw user object 316

DataWindow objects

adding to DataWindow control 102

d_file_display 203
d_free_resources 204
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DataWindow objects (continued)
d_global_vars 205
d_profile 205
d_progress 206
d_sort 206
d_sort_order 207
d_system_error 207

DataWindow Operations
f select_data 255
str_sort_order 270

DBMS, Watcom SQL 18

debugging
w_debug_box 126
w_error_box 134

disconnect, in Close event 27

dropdown DataWindow
f dddw_lookup 214
f_dw_fill_ddlb 217
f_lookupcode 239
f_lookupdisplay 240
f retrieve_dddw 254

E

EditMask control, parsing 245

elapsed time, uf_get_elapsed_time 304

e-mail
f_maillogoff 241
f_maillogon 241
f mailsend 242
f_mailsendnoaddress 244
MAPI-compliance note 243
EITOr message
f db_error 124
uf_get error_msg 305
w_db_error 124
example application 367
example.pbl 367
extended attributes
copying through pipeline 313
uf_get_extended_attr_copy 306
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F

f_app_open

about 209

application Open event 39
f block_text 210
f _boolean_to_string 211
f cascade_window 212
f db_error

about 213

in application Close event 27

w_db_error 124
f_dddw_lookup 214
f _debug_box

about 215

w_debug_box 126
f_display_file

about 216

d_file_display 203

w_file_display 138
f dw_fill ddlb 217
f_dw_get_attributes

about 217

f_get_token example 235
f_dw_get_objects 219
f_dw_get_objects_attrib 220
f dw_getcolnames 222
f_dw_getheaderlabel 223
f_dw_getvisiblecolumns 224
f_dw_print

about 226

w_dw_print_options 127
f dw_set_color 228
f_dw_set_color_row 229
f_dwobjectatpointer 225
f_error_box

about 230

w_error_box 134
f exit_status

about 231

w_exit_status 136
f get parm 232
f get string

about 233

w_get_string 142
f get token 234
f_global_replace 235
f_invert_color 236



f_julian 237
f login
about 238

application INI file usage 36

w_login 146
f_lookupcode 239
f_lookupdisplay 240
f_maillogoff 241
f _maillogon 241
f mailsend 242
f_mailsendnoaddress 244
f_parsedisplaydata 245
f_parseleftright 246

f parsestringintoarray 247

f pop_parm 248
f_print_file 250
f_promptforcriteria 250
f push_parm
about 251
f pop_parm 248
f _referential_int 252
f retrieve_dddw 254
f right_justify 254
f_select_data
about 255
w_dw_select 131
f_set_menu_branch 257
f_set_parm 258
f_set_sqlca
about 259
w_set_sqlca 161
f_sort_order
about 259
d_sort_order 207
w_sort_order 167
f string_to_boolean 261
f time_diff 262
f_wait_for
about 262
w_wait_for 201
f write_file 263
f write_log 264
File Editor 36
file structure 10
frame window
adding the menu 73
creating 31
menu 63

frame window (continued)

OpenSheet function 49
post_open user event 49

PostEvent function 49, 51
free memory

w_get_free_resources 139
w_get_free_resources_graph 141

w_mdi_clock 148

functions see global functions

f app_open 209

f block_text 210

f boolean_to_string 211
f cascade_window 212
f db_error 124,213

f dddw_lookup 214
f_debug_box 126, 215

f display file 138,203,216

f dw_fill_ddlb 217
f dw_get_attributes 217
f dw_get_objects 219

f dw_get_objects_attrib 220

f_dw_getcolnames 222
f dw_getheaderlabel 223

f dw_getvisiblecolumns 224

f dw_print 226

f dw_set_color 228

f dw_set_color_row 229
f_dwobjectatpointer 225
f _error_box 134,230

f _exit_status 136, 231
f get parm 232

f_get string 142,233
f _get token 234

f global_replace 235
f_invert_color 236

f julian 237

f login 146, 238

f lookupcode 239

f lookupdisplay 240

f _maillogoff 241

f maillogon 241

f _mailsend 242

GetObjectAtPointer function, parsing results 225
global functions
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global functions (continued)
f_mailsendnoaddress 244
f_parsedisplaydata 245
f_parseleftright 246
f_parsestringintoarray 247
f pop_parm 248
f_print_file 250
f_promptforcriteria 250
f_push_parm 248, 251
f_referential_int 252
f_retrieve_dddw 254
f right _justify 254
f select_data 131, 255
f set_menu_branch 257
f set_parm 258
f_set_sqlca 161, 259
f sort_order 167,207, 259
f _string_to_boolean 261
f_time_diff 262
f wait_for 201, 262
f write_file 263
f_write_log 264

graphic display interface (GDI) memory
w_get_free_resources 139
w_get_free_resources_graph 141
w_mdi_clock 148

H

Help see online Help

icon, application 28

inheritance
m_base 273
m_sys_frame 274
tutorial example 101
w_select 158
w_sys_frame 169
w_sys_mast_detl_dw 172
w_sys_multi_dw 179
w_sys_pipeline 181
w_sys_report 187
w_sys_shared_dw 191
w_sys_single_dw 194
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INI file
about 371
application 36
f app_open 209
f login 146
Installation 10

L

library search path see application library search
path

M

m_base 273
m_sys_frame
about 274
frame menu 64
integration with w_sys_frame 171
m_tut_frame
associating with w_tut_frame 73
creating 63
m_tut_report
associating with w_tut_report 96
creating 87
m_tut_shared
associating with w_tut_shared 85
creating 75
mail see e-mail
MAPI 243
MDI frame
simulating in non_MDI window with
u_help_bar 283
w_mdi_clock 150
w_sys_frame 169
menu
f_set_menu_branch 257
for w_tut_report sheet window 87
for w_tut_shared sheet window 75
frame window 63
menu items, adding 66
menu objects
m_base 273
m_sys_frame 274
message object, retrieval arguments 49, 60
MessageBox function, w_debug_box 126



MicroHelp
simulating with u_help_bar in non_MDI
window 283
u_mdi_clock_item 287
w_mdi_clock 150
w_sys_frame 169

(0

object library, overview 5

see also UTLFUNC.PBL; UTLWIN.PBL
OLE

accessing Excel data 292

accessing Word bookmarks 295, 297

accessing Word documents 296

loading a server file 289

saving contents 290, 291

setting focus in a document 298

setting focus in a spreadsheet 293

setting values in a document 298

setting values in a spreadsheet 294

u_ole 289

u_ole_excel 292

u_ole_word 295
online Help, calling with ShowHelp function 69
Online Linking and Embedding see OLE
OpenSheet function 49
OpenSheetWithParm 49, 60
OpenWithParm, replacement for w_hold_parms

144

P

page range, w_dw_print_options 127
parsing, f_get token 234
performance statistics 154
pipeline
canceling 302
error mesages 305
errors 302
executing 302
exporting data pipeline syntax 307
repairing 311
u_pipeline_kit 299
w_sys_pipeline 181
popup window, f_cascade_window 212

post_open user event

about 49

application INI file usage 36
PostEvent 51
PowerBuilder File Editor 36
Powersoft Demo DB 18
PowerTips 21
print options dialog box, replacing with

w_dw_print_options 127

printing

f dw_print 226

f print_file 250

w_dw_print_options 127
profiling 154
Pubs sample application 325

Q

query mode
Pubs sample application 333
Time Management sample application 360
w_select window 158

R

RadioButton control, parsing 245
referential integrity, using f_referential int 252
report window
creating 55
menu 87
w_sys_report 187
retrieval arguments 49, 60
reusable objects see object library

S

sample applications
Pubs 325
Time Management 347
search path see application library search path
security, using f_login 238
sheet window
adding the menu for w_tut_report 96
adding the menu for w_tut_shared 85
descendant of w_sys_report 56
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sheet window (continued) tutor_al.pbl, creating 19

descendant of w_sys_shared_dw 44 tutorial, introduction 16
menu 75, 87
ShowHelp function
m_sys_frame Help menu 281 U
tutorial example 69
sorting u_help_bar
f_sort_order 259 about 283
w sort 165 uf_init 285
SQLCA uf_resized 285
f set_sqlca 259 uf_set_clock 286
w_db_error 125 uf_set_msg 286

w_set_sqglca 161 u_mdi_clock_item
str_frame 267 about 287

str_parms 268 uf_set_text 288
str_progress 269 uf_set_width 288

str_select_parms 269 u_ole
str_sort 270 about 289
str_sort_order 270 uf_load 289
structure objects uf_save 290
defined 267 uf saveas 291
str_parms 267, 268 u_ole_excel
about 292

str_progress 269

str_select_parms 269 uf_getvalue 292
str_sort 270 uf_setfocus 293

uf_setvalue 294

str_sort_order 270
u_ole_word

system memory
w_get_free_resources 139 about 295
w_get_free_resources_graph 141 uf_get _bookmarks 295
w_mdi_clock 148 uf_getvalue 296
systeH1 resources uf_is_bookmark_valid 297
w_get_free_resources 139 uf_setfocus 298
w_get_free_resources_graph 141 uf_setvalue 298
w_mdi_clock 148 u_pipeline_kit
SystemError event 26 about 299
uf_cancel 302
uf_execute 302
uf_get_commit 304

T uf_get_elapsed_time 304
tag value, use by f_dw_getheaderlabel 223 uf_get_error_msg 305
text file, displaying 138 uf_get extended_attr_copy 306
Time Management sample application 347 uf_get_maxerrors 306
token, defined 234 uf_get_syntax_value 307
toolbars, PowerTips versus text 21 uf_get_type 308
transaction object uf_init 309
f _set_sqlca 259 uf_init_elapsed_time 310
w_set_sqlca 161 uf_repair 311
tutor_al.ini file 36 uf_set_commit 312
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u_pipeline_kit (continued)
uf_set_extemded_attr_copy 313
uf_set_maxerrors 313
uf_set_syntax_value 314
uf_set_type 315
w_sys_pipeline 181
uf_add_validation 318
uf_cancel 302
uf_check_required 319
uf_execute 302
uf_get_bookmarks 295
uf_get commit 304
uf_get_elapsed_time 304
uf_get_error_msg 305
uf_get_extended_atttr_copy 306
uf_get_maxerrors 306
uf_get_syntax_value 307
uf_get_type 308
uf_getvalue
about (u_ole_excel) 292
about (u_ole_word) 296
uf_init
about (u_help_bar) 285
about (u_pipeline_kit) 309
uf_init_elapsed_time 310
uf_is_bookmark_valid 297
uf_is_modified 320
uf_load 289
uf repair 311
uf_resized 285
uf_save 290
uf_saveas 291
uf_set_clock 286
uf_set_commit 312
uf_set_extended_attr_copy 313
uf_set_maxerrors 313
uf_set_msg 286
uf set_syntax_value 314
uf_set_text 288
uf_set_type 315
uf_set_width 288
uf_setfocus
about (u_ole_excel) 293
about (u_ole_word) 298
uf_setvalue
about (u_ole_excel) 294
about (u_ole_word) 298
uf_validate 320

uo_dw
about 316
inheritance example 101
uf_add_validation 318
uf_check_required 319
uf_is_modified 320
uf_validate 320

user memory
w_get_free_resources 139
w_get_free_resources_graph 141
w_mdi_clock 148

user objects
defined 283
u_help_bar 283
u_mdi_clock_item 287
u_ole 289
u_ole_excel 292
u_ole_word 295
u_pipeline_kit 299
uo_dw 316

\')

validation
uf_add_validation 318
uf_validate 320

virtual memory
w_get_free_resources 139
w_get_free_resources_graph 141

w

w_about 123
w_db_error

about 124

example 125

f db_error 213
w_debug_box

about 126

f debug_box 215
w_dw_print_options

about 127

f dw_print 127, 226
w_dw_select

about 131

f select_data 255
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w_dw_select (continued)

str_select_parms 269
w_error_box

about 134

f error_box 230
w_exit_status

about 136

f_exit_status 231
w_{file_display

about 138

d_file_display 203

f_display_file 216
w_get_free_resources 139
w_get_free_resources_graph

about 141

d_free_resources 204
w_get_string

about 142

f get string 233
w_hold_parms

about 144

d_global_vars 205

f get parm 232

f pop_parm 248

f push_parm 251

f set_parm 258
w_login

about 146

f login 238
w_mdi_clock

about 148

w_sys_frame 170
w_printzoom 153
w_profile

about 154

d_profile 205
W_progress

about 155

d_progress 206

str_progress 269
w_select 158
w_set_sqglca

about 161

f set_sqlca 259
w_set_toolbars 163

w_sort
about 165
d_sort 206
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w_sort(continued)

str_sort 270
w_sort_order

about 167

d_sort_order 207

f _sort_order 259

str_sort_order 270
w_sys_frame

about 169

inheriting from 33

str_frame 267
w_sys_mast_detl_dw 172
w_sys_multi_dw

about 179

inheritance example 101
w_sys_pipeline

about 181

u_pipeline_kit 181
w_sys_report

about 187

inheriting from 57
w_sys_shared_dw

about 191

inheritance example 101

inheriting from 45
w_sys_single_dw

about 194

ancestor of w_sys_multi_dw 179

inheritance example 101
Ww_system_error

about 199

d_system_error 207

SystemError event 26
w_tut_frame

associating with m_tut_frame 73

creating 31
w_tut_report

associating with m_tut_report 96

creating 55
w_tut_shared

associating with m_tut_shared 85

creating 44

inheritance example 101
w_wait_for

about 201

f_wait_for 262
Watcom SQL 18
window function, tutorial example 108



window objects
w_about 123
w_db_error 124,125,213
w_debug_box 126, 215
w_display_file 203
w_dw_print_options 127
w_dw_select 131, 255, 269
w_error_box 134, 230
w_exit_status 136, 231
w_file_display 138, 216
w_get_free_resources 139
w_get_free_resources_graph 141, 204
w_get_string 142, 233
w_hold_parms 144, 205, 232, 248, 251, 258
w_login 146, 238
w_mdi_clock 148, 170
w_printzoom 153
w_profile 154, 205
w_progress 155, 206, 269
w_select 158
w_set_sqlca 161, 259
w_set_toolbars 163
w_sort 165, 206, 270
w_sort_order 167, 207, 259, 270
w_sys_frame 169, 267
w_sys_mast_detl dw 172
w_sys_multi_dw 179
w_sys_pipeline 181
w_sys_report 187
w_sys_shared_dw 191
w_sys_single_dw 180, 194
w_system_error 199, 207
w_wait_for 201, 262

Windows Help see online Help
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